Xmanager Forum

Xbrowser does not work with RHEL V7

Last post: Wednesday, March 11, 2015 12:42 AM by Support, 8 reply

 
Wednesday, December 11, 2013 1:46 PM - Terry Lemons

Xbrowser does not work with RHEL V7

 
Hi

I can't get Xbrowser to show an X session from a RHEL 7 beta system. I've followed the advice in this forum for a RHEL 6 system.

Thanks
tl

Program Ver. : Xmanager 3.0
Connect Method : XDMCP connection
Thursday, December 12, 2013 9:53 PM - Support

Re: Xbrowser does not work with RHEL V7

 
Enabling XDMCP on Red Hat Enterprise Linux 7.0 is same as version 6.x. Make sure you have done the following steps

1. Enable XDMCP in /etc/gdm/custom.conf
2. Allow incoming UDP port 177 on Red Hat

However, we get the attached error message when connecting to the remote host. Our developers are checking on this issue right now.




---
Technical Support
Friday, June 27, 2014 11:41 AM - Joe Berthiaume

Re: Xbrowser does not work with RHEL V7

 
Hi,

I noticed that this bug has not been addressed since December 2013. I just installed RHEL 7 and got the host to appear in the XBrowser list.

However, when I try to launch it, I too am seeing the exact same image that was attached in the previous reply to this bug. "Oops, something went wrong..."

So, it is still not working. I am using XManager 4, Build 0153.

Please help.

Thanks a lot.
Monday, March 2, 2015 11:48 AM - Terry Lemons

Re: Xbrowser does not work with RHEL V7

 
Hi - I'm trying to use Xbrowser for Xmanager 3.0 (build 0145) with RHEL 7. I was able to get my RHEL 7 host to appear in the Xbrowser list, after putting the following in /etc/gdm/custom.conf and rebooting:

# GDM configuration storage

[daemon]

[security]
DisallowTCP=false

[xdmcp]
Enable=true

[greeter]

[chooser]

[debug]

[root@pallas ~]

But a Windbg window appears and I can't proceed any further (please see attachment).

What should I do?

Thanks
tl
Thursday, March 5, 2015 4:38 AM - Support

Re: Xbrowser does not work with RHEL V7

 
RHEL 7 and CentOS 7 requires direct access to local graphic hardware and this causes problem when you are connecting via XDMCP.

To connect to remote CentOS, you cannot use the default gdm and Gnome desktop environment. Here is how you can switch to lightdm and xfce:

*You need root user rights to complete this guide.

Switching XDM from gdm to lightdm

1. Install lightdm

# yum install ftp://ftp.sunet.se/pub/Linux/distributions/fedora/epel/7/7/ppc64/epel-release-7-0.2.noarch.rpm

# yum install lightdm

2. Configure lightdm
# vi /etc/lightdm/lightdm.conf

*If the file does not exist, create a new file.

[XDMCPServer]
enabled=true

3. Change the Display Manager to lightdm

# systemctl disable gdm ; systemctl enable lightdm

4. Start lightdm

# systemctl start lightdm

5. Disable firewall.
# systemctl stop firewalld.service

* If you do not want to disable firewall, you can just allow incoming UDP port 177.

Install Xfce

1. Add repository
# yum install ftp://ftp.sunet.se/pub/Linux/distributions/fedora/epel/7/7/ppc64/epel-release-7-0.2.noarch.rpm

2. Install Xfce

# yum groupinstall xfce

If you prefer KDE, you can use KDE instead of Xfce.

- Install KDE
# yum groupinstall kde-desktop

3. Restart lightdm

# systemctl restart lightdm

4. Use Xmanager to login.



---
Technical Support
Friday, March 6, 2015 1:32 PM - Terry Lemons

Re: Xbrowser does not work with RHEL V7

 
Hi

Thanks very much for the reply, and for the detailed instructions. I executed the instructions to install lightdm and Xfce, and did not have any problems.

But, Xmanager does not see this system, even after a RHEL 7 system reboot.

[root@pallas ~]# systemctl is-active lightdm
active
[root@pallas ~]# systemctl is-active Xfce
unknown
[root@pallas ~]# systemctl enable Xfce.service
Failed to issue method call: No such file or directory
[root@pallas ~]#

Thoughts about what I should do to debug this?

Thanks
tl
Sunday, March 8, 2015 7:40 PM - Support

Re: Xbrowser does not work with RHEL V7

 
There are few reasons when XDCMP fails:

1. Your PC cannot reach the remote host via UDP port 177. This port is used for XDMCP initiation.

2. Your remote cannot connect back to your PC. By default, Xmanager uses TCP ports 6000 and above. Make sure Xmanager is allowed to use these ports.

You can try starting xfce by using Xstart and SSH connection. This is usually much quicker than setting up XDMCP and painless way to start a desktop session. To do this:

1. Open Xstart and create a new session.
2. Select SSH for Protocol.
3. For command, enter startxfce4.

*This will start Xfce session in multiple window mode. If you would like to make it run in a single window:

1. Open Xstart.
2. Click on the Advanced button.
3. Click on the Configure... button in the X Server profile section.
4. Select Single Window Mode in the Window mode section.

Click OK to save the changes.



---
Technical Support
Tuesday, March 10, 2015 8:32 AM - Terry Lemons

Re: Xbrowser does not work with RHEL V7

 
Thanks for your suggestions. But I'm still getting WinDBG cores when I attempt to use Xbrowser or Xstart. I'm using a years-old version of the Xmanager suite (3.0). Are RHEL 7 systems supported in this old version?

Thanks
tl
Wednesday, March 11, 2015 12:42 AM - Support

Re: Xbrowser does not work with RHEL V7

 
Do you mean Xmanager crashes when you are connecting to RHEL 7? Xmanager 3.0 was never tested with RHEL 7 but still you shouldn't have problem running X applications via Xstart & SSH.

Can you please write to us at support@netsarang.com?


---
Technical Support