Xmanager Forum

can not work in redhat server 6.3 for x86_64

Last post: Wednesday, November 5, 2014 4:55 AM by Mohamed Ashry, 18 reply

 
Tuesday, September 11, 2012 6:52 PM - ldq

can not work in redhat server 6.3 for x86_64

 
hello,i have made follow changes in redhat server 6.3,but it can not work
, i have disablde iptable and Selinux

file: /etc/inittab
#--------------------------------------------------
id:5:initdefault:

file: /etc/gdm/custom.conf
#--------------------------------------------------
# GDM configuration storage
[daemon]

[security]

[xdmcp]
Enable=1
[greeter]

[chooser]

[debug]

and ,in Xbrowser , i make a session under XDMCP with default setup except ip address, and the session seemd to be disabled, double click it, then a window come with nothing. then "XDMCP connection failed ,try again?"

Program Ver. : Xmanager 4
Connect Method : XDMCP connection
Wednesday, September 12, 2012 12:32 AM - Support

Re: can not work in redhat server 6.3 for x86_64

 
It looks like you have configured the remote host correctly. You have to restart gdm process after making the changes. Have you done this already?

If the problem persists, please send us the following information:

1. Xmanager log file. To get the log files, enter the IP address in the session dialog box and wait until the connection fails. Then, right click on the Xmanager title bar and select Log > File.

2. Try opening an xterm window via SSH using Xstart. If you don't know how to open x applications on Xstart, please refer to the following link:

Xmanager Tutorial : Connecting and executing remote X application with Xstart


---
Technical Support
Wednesday, September 12, 2012 2:10 AM - ldq

Re: can not work in redhat server 6.3 for x86_64

 
first , i try xstart in 2), it work !

then , i check what you tell me in 1)
yes,i have reboot the machine, but it does not work yet, and the following is the log:
----------------------------------------------------------------------------------------------
Xmanager 4.0.0.8
Copyright (c) 1997-2012 NetSarang Computer, Inc.
All rights reserved.

UTC Date: Wed Sep 12 09:05:14 2012
Local Date: Wed Sep 12 17:05:14 2012

X Server Directory: "C:\Program Files (x86)\NetSarang\Xmanager Enterprise 4\"
Session File: C:\Users\knt\AppData\Roaming\NetSarang\Xmanager\Sessions\Xmanager\testsvr.xdts
Connection Method: 1
Xdmcp UDP Port: 177
Xdmcp Host: '139.24.25.2'
Default Display Number:
Product Code: 6
License Type: 2

Server Generation 1
CreateConfig returns a return value: 3
Server profile: %system%\Default Profile.xcf
Desktop composition is enabled.

Hardware information:
Processor architecture: 0
Number of processors: 4
Page size: 4096
Processor type: 586
Minimum application address: 10000
Maximum application address: 7ffeffff
Active processor mask: 15
Allocation granularity: 65536
Processor level: 6
Processor revision: 0x2a07
============ Global Memory Status ==========
Memory Load : 47%
Total Physical Memory : 4176288 Kbytes
Available Physical Memory : 2185768 Kbytes
Total Page File : 4194303 Kbytes
Available Page File : 4194303 Kbytes
Total Virtual : 2097024 Kbytes
Available Virtual : 1997252 Kbytes
=============================================
WinSock Version 2.2 is selected.
Highest Version 2.2
Description: WinSock 2.0
System Status: Running
Max Sockets: 0
Max UDP Datagram: 0
RGB database: C:\Program Files (x86)\NetSarang\Xmanager Enterprise 4\rgb\rgb.txt
Local Hostname: 'knt-PC'
Local Host IP Address: 139.24.25.222
Listening port: 6002
XDMCP Display Number: 2
Xdmcp: sent a QUERY message.
Window Mode: 0
Primary Screen Resolution: 1680 x 1050
Size of Palette: 0
Number of Reserved Colors: 0
Resolution of Color: 24
Depth of Screen: 32
Maximum Cursor Width: 32
Maximum Cursor Height: 32
Frame Width: 8
Frame Height: 8
Border Width: 1
Border Height: 1
Maximum Client Area Width: 1680
Maximum Client Area Height:998
Icon Width: 32
Icon Height: 32
Small Icon Width: 16
Small Icon Height: 16
Caption Height: 22
Shade Blend Pixel Alpha: 1
DBCS Enabled: 1
GDI batch limit: 20

Mouse buttons: 8
Waveform Output Devices: 1
Mouse wheel present: 1

Monitors: 1
Selected Monitor: Virtual Screen
Same display format: 1
Virtual screen x 0, y 0, w 1680 h 1050
Root Window x 0, y 0, w 1680, h 998
Exact StoreColor: 0
Reverse RGB Order: 0

Screen 0: 1680 x 998, depth 24, dpi 90 x 90
Keyboard file version: 3.0
Keyboard file: US 101 keyboard
Keyboard type: 0
nKeys, minKC, maxKC, mapWidth, nCompose: 101, 8, 109, 4, 0
Number of keycodes: 102
Number of KeySyms: 408
Bytes of KeySyms: 1632

=== OS Version Information ===
Platform id : 2
Major Version : 6
Minor Version : 1
Build Number : 7600
Description : ""
Country Code : 86
Country String: ¿¿¿¿¿¿¿
ANSI Code Page: 936
Language ID : 4
==============================
Running Xsound...

Waiting for client connections ...

Xdmcp: Timed out, state 3. Retransmissions: 0
Xdmcp: sent a QUERY message.
Xdmcp: Timed out, state 3. Retransmissions: 1
Xdmcp: sent a QUERY message.
Xdmcp: Timed out, state 3. Retransmissions: 2
Xdmcp: sent a QUERY message.
Xdmcp: Timed out, state 3. Retransmissions: 3
XDM go to sleep: too many retransmissions
Error: Low level keyboard proc already hooked.
Wednesday, September 12, 2012 3:09 AM - Support

Re: can not work in redhat server 6.3 for x86_64

 
The log indicates Xmanager could not send message to the remote host via UDP port 177. This can mean:

1. gdm is not running on the remote host. Please make sure gdm is installed and running on the remote host. Many Linux ditros do not install gdm by default. Using the default RHEL application install tool, install all Gnome packages (i.e. gdm, gnome desktop environment)

2. Firewall or router maybe blocking Xmanager from accessing the remote host via UDP port 177. On Windows firewall settings, allow UDP port 177 for outgoing connections. Also, if you have any 3rd party internet security tools installed, please make sure Xmanager is allowed to receive/send network connections.


---
Technical Support
Wednesday, September 12, 2012 3:50 AM - ldq

Re: can not work in redhat server 6.3 for x86_64

 
sorry, it does not work yet , i am crazy!

1. i am sure the gdm is running on the rhel server 6.3, by this

[root@testsvr ~]# lsof -i :177
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
gdm-binar 2356 root 7u IPv4 14073 0t0 UDP *:xdmcp

2. and i'm sure there is not a network problem

because , on the same network environment, there is one rhel server 5.5, it work!
Wednesday, September 12, 2012 4:06 AM - Support

Re: can not work in redhat server 6.3 for x86_64

 
Please try setting the DisallowTCP to false in custom.conf like this:

[security]
DisallowTCP=false

Remember to start gdm after making the change.

---
Technical support
Wednesday, September 12, 2012 7:27 PM - ldq

Re: can not work in redhat server 6.3 for x86_64

 

i have try that, no success, has the xmanager been test with rhel6.3?

now i am fighting with rhel6.3 and xmanager4, may the force be with me.

Wednesday, September 12, 2012 8:02 PM - Support

Re: can not work in redhat server 6.3 for x86_64

 
We have tested RHEL 6.3 x64 and it wasn't any different from its predecessors. Let me check again with their newest build and get back to this post shortly.

Meanwhile, please try doing the followings:

1. Start RHEL 6.3
2. Make sure gdm is running
To check if gdm is running, do 'ps -aef | grep gdm' and see if gdm (or gdm-binary) is in the list.
3. Disable iptables & selinux
4. Open the session from Xbrowser

The Force is strong with you. =)

---
Technical Support
Wednesday, September 12, 2012 9:50 PM - ldq

Re: can not work in redhat server 6.3 for x86_64

 
thanks a lot!
i have done everything you told me , all these work seemed useless in this situation.

there must be something else we can not see...in the darkside.

if you like test it again, this is my environment:

x client
machine: dell poweredge 710
source: rhel-server-6.3-x86_64-dvd
and i select 'basic server' install, and select all option packages
x server
machine: PC windows 7 x64
xmanager 4
Thursday, September 13, 2012 2:44 AM - Support

Re: can not work in redhat server 6.3 for x86_64

 
We have reinstalled RHEL 6.3 x64 from scratch with 'basic server' install.

Here is what we had to do:

1. Finish installing RHEL 6.3 with basic server setup.
2. Once install is done, install X Window System packages with the following command

# yum groupinstall "X Window System" Desktop

3. Edit the /etc/gdm/custom.conf file to allow XDMCP connections. You have done this already.

3. Restart server

4. Disable firewall (since this is for test purpose only. You should configure your firewall to allow UDP port 177).

#service iptables stop

5. Start gdm

# startx

And, the server appeared on Xbrowser and I was able to access it.

Please try installing X Window System again if you haven't installed the full package. Also, make sure the RHEL server is connected to network.



---
Technical Support
Saturday, November 10, 2012 6:31 PM - venkat

Re: can not work in redhat server 6.3 for x86_64

 
Please provide x window full package details
Monday, November 12, 2012 12:36 AM - Support

Re: can not work in redhat server 6.3 for x86_64

 
Could you be little more specific on what you mean by "x window full package details"?

---
Technical Support
Wednesday, November 14, 2012 8:43 AM - venkat

Re: can not work in redhat server 6.3 for x86_64

 
When i try to install the X window system i got the below output

yum groupinstall "X Window System" Desktop
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Group Process
Package xorg-x11-server-Xorg-1.10.6-1.el6.x86_64 already installed and latest version
Package xorg-x11-xinit-1.0.9-13.el6.x86_64 already installed and latest version
Package 1:xorg-x11-xauth-1.0.2-7.1.el6.x86_64 already installed and latest version
Package xorg-x11-drivers-7.3-13.3.el6.x86_64 already installed and latest version
Package wdaemon-0.17-2.el6.x86_64 already installed and latest version
Package xorg-x11-server-utils-7.5-5.2.el6.x86_64 already installed and latest version
Package hal-0.5.14-11.el6.x86_64 already installed and latest version
Package plymouth-system-theme-0.8.3-24.el6.noarch already installed and latest version
Package subscription-manager-firstboot-0.99.19-1.el6.x86_64 already installed and latest version
Package xorg-x11-utils-7.4-8.el6.x86_64 already installed and latest version
Package wacomexpresskeys-0.4.2-3.el6.x86_64 already installed and latest version
Package spice-vdagent-0.8.1-3.el6.x86_64 already installed and latest version
Package firstboot-1.110.13-1.el6.x86_64 already installed and latest version
Package glx-utils-7.11-5.el6.x86_64 already installed and latest version
Package xvattr-1.3-18.el6.x86_64 already installed and latest version
Warning: Group x11 does not have any packages.
Package nautilus-2.28.4-19.el6.x86_64 already installed and latest version
Package 1:control-center-2.28.1-37.el6.x86_64 already installed and latest version
Package gvfs-smb-1.4.3-12.el6.x86_64 already installed and latest version
Package xdg-user-dirs-gtk-0.8-7.el6.x86_64 already installed and latest version
Package gnome-power-manager-2.28.3-6.el6.x86_64 already installed and latest version
Package alsa-plugins-pulseaudio-1.0.21-3.el6.x86_64 already installed and latest version
Package at-spi-1.28.1-2.el6.x86_64 already installed and latest version
Package 1:gdm-2.30.4-33.el6_2.x86_64 already installed and latest version
Package notification-daemon-0.5.0-1.el6.x86_64 already installed and latest version
Package 1:NetworkManager-0.8.1-33.el6.x86_64 already installed and latest version
Package 1:NetworkManager-gnome-0.8.1-33.el6.x86_64 already installed and latest version
Package polkit-gnome-0.96-3.el6.x86_64 already installed and latest version
Package gnome-session-2.28.0-18.el6.x86_64 already installed and latest version
Package gnome-terminal-2.31.3-7.el6.x86_64 already installed and latest version
Package gnome-panel-2.30.2-14.el6.x86_64 already installed and latest version
Package gvfs-fuse-1.4.3-12.el6.x86_64 already installed and latest version
Package metacity-2.28.0-23.el6.x86_64 already installed and latest version
Package gnome-screensaver-2.28.3-18.el6.x86_64 already installed and latest version
Package yelp-2.28.1-13.el6_2.x86_64 already installed and latest version
Package 1:dbus-1.2.24-5.el6_1.x86_64 already installed and latest version
Package gvfs-archive-1.4.3-12.el6.x86_64 already installed and latest version
Package 1:gdm-user-switch-applet-2.30.4-33.el6_2.x86_64 already installed and latest version
Package rhn-setup-gnome-1.0.0-87.el6.noarch already installed and latest version
Package 1:control-center-extra-2.28.1-37.el6.x86_64 already installed and latest version
Package eog-2.28.2-4.el6.x86_64 already installed and latest version
Package gnome-packagekit-2.28.3-3.el6.x86_64 already installed and latest version
Package gok-2.28.1-5.el6.x86_64 already installed and latest version
Package gnome-media-2.29.91-6.el6.x86_64 already installed and latest version
Package gnome-vfs2-smb-2.24.2-6.el6.x86_64 already installed and latest version
Package subscription-manager-gnome-0.99.19-1.el6.x86_64 already installed and latest version
Package openssh-askpass-5.3p1-81.el6.x86_64 already installed and latest version
Package pulseaudio-module-x11-0.9.21-13.el6.x86_64 already installed and latest version
Package pulseaudio-module-gconf-0.9.21-13.el6.x86_64 already installed and latest version
Package 1:gnome-applets-2.28.0-7.el6.x86_64 already installed and latest version
Package orca-2.28.2-1.el6.x86_64 already installed and latest version
Package vino-2.28.1-3.el6.x86_64 already installed and latest version
Package 1:gdm-plugin-fingerprint-2.30.4-33.el6_2.x86_64 already installed and latest version
Warning: Group basic-desktop does not have any packages.
No packages in any requested group available to install or update

----------------------------------------------------------------------------------
Then executed the below command
startx
xauth: creating new authority file /root/.serverauth.4288
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the Red Hat, Inc. support
at https://www.redhat.com/apps/support/
for help.
-------------------------------------------------------------------------------------------------------------


Wednesday, November 14, 2012 3:50 PM - Support

Re: can not work in redhat server 6.3 for x86_64

 
Thank you for the above information.

I will have this forwarded to our developers and let you know when we have any updates.

---
Technical Support
Wednesday, November 14, 2012 5:16 PM - Support

Re: can not work in redhat server 6.3 for x86_64

 
It seems like you already have X Windows System installed. Also you dont have to run startx to use with Xmanager.

Please let us know the following information:

1. Is XDMCP enabled in your remote host?
2. Is UDP port 177 from the PC to the remote host direction opened?
3. Is incoming TCP ports 6000~6010 from the remote host to your PC opened?

If you have not done the above, please see the below link to perform a remote host configuration:

http://www.netsarang.com/faq/xmanager/list


---
Technical Support
Wednesday, November 14, 2012 9:37 PM - venkat

Re: can not work in redhat server 6.3 for x86_64

 
1.Enabled XDMCP
2. The 177 port also opened
lsof -i :177
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
gdm-binar 3388 root 7u IPv4 13502 0t0 UDP *:xdmcp
3. Incoming ports also enabled

netstat -tanp | grep 6000
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 3548/Xorg
tcp 0 0 :::6000 :::* LISTEN 3548/Xorg

Monday, November 19, 2012 6:24 AM - suling

Re: can not work in redhat server 6.3 for x86_64

 
I met the same problem in CentOS6.3 X86_64, mini install,
yum groupinstall "X Window System' Desktop
gdm is running
lsof -i:177 has some thing
selinux is disabled
iptables stop
custom.conf
Enable=1
DisallowTCP=false
AllowRemoteRoot=true

i tried almost what i searched on the internet, but still doesn't work
made me Crazy.
Monday, December 3, 2012 5:49 PM - Support

Re: can not work in redhat server 6.3 for x86_64

 
After installing the X window system on Linux, there are few more steps you need to take before you can access the machine via Xbrowser.

1. Configure firewall on Windows and Linux
on Windows firewall settings, allow Xmanager.exe to accept incoming TCP connections.

On Linux, allow incoming UDP port 177.

2. Restart Linux
After re-configuring the firewall settings and display manager, you have to restart them. Easiest way is to restart the machine if you can.


If you still cannot connect to the machine, try the following diagnostics:

1. Try ping from Linux to PC. Make sure Linux has connection back to PC.

2. Try connecting to Linux with SSH or TELNET.

---
Technical Support
Wednesday, November 5, 2014 4:55 AM - Mohamed Ashry

Re: can not work in redhat server 6.3 for x86_64

 
its too simple

just install gdm packge

and modify /etc/gdm/custom.conf with the following

[xdmcp]
enabled=1

working good with me

selinux disabled

iptables off