Xmanager Forum

Keyboard issues

Last post: Wednesday, May 9, 2012 7:01 PM by Support, 4 reply

 
Sunday, April 29, 2012 3:50 PM - Jared

Keyboard issues

 
Hi, when using XDMCP connections I am experiencing intermittent issues with the keyboard where the numbers on the numpad are mapping to their Function equivalent. For example, the number '1' maps to 'F1' (Help), '2' maps to 'F2' etc.

I am connecting to Ubtuntu 10.04 with the XDMCP protocol using Xmanager 4 build 0111.

Thanks



Program Ver. : Xmanager 4
Connect Method : XDMCP connection
Wednesday, May 2, 2012 6:54 PM - Support

Re: Keyboard issues

 
We tried but failed to reproduce this issue.

Please provide us with the follwoing information:

1. What is the language setting in remote host (result of 'echo $LANG')
2. Windows version and language
3. How can we reproduce the problem (in steps)?

---
Technical Support
Tuesday, May 8, 2012 6:21 PM - Jared

Re: Keyboard issues

 
1. en_AU.UTF-8
2. Windows 7 Professional, English
3. Open up gnome session with XDMCP connecting to XDM

The issue only happens about 75% of the time. I have tried to reproduce with another X Server (Xming) but the problem is absent.


Tuesday, May 8, 2012 6:35 PM - Jared

Re: Keyboard issues

 
also worth mentioning that if I hold the left CTRL key, the numbers are inserted as normal.
Wednesday, May 9, 2012 7:01 PM - Support

Re: Keyboard issues

 
Thank you for the information. We have duplicate a similar case but this only happened when the "Permit Modification of Keymap" option is selected in the Keyboard settings dialog box. This option is not selected by default. To locate this option:

1. Open Xbrowser and right click on the session.
2. Click Properties.
3. Click on the X Server tab.
4. Click on the Configuration button.
Result: Profile Properties dialog box opens
5. Click on the Devices tab.
6. Cick onthe Keyboard Settings button.
7. Make sure you have not selected the "Permit Modification of Keymap" option.
8. Select the "Send the left Windows key to X" and "Send the right Windows key to X" options.
9. Click OK

Here is our test environment:

1. Remote OS: Ubuntu 10.04
2. Language setting: English (Australian)
3. Windows: Windows 7 x64 Enterprise edition (English)
4. Tested applications: vi, gnome-terminal
5. Gnome-session version (result of 'gnome-session --version'): 2.30.0


---
Technical Support