Xmanager Forum

RHEL 6.1

Last post: Tuesday, June 26, 2012 1:28 PM by rheluser, 11 reply

Friday, July 29, 2011 3:27 AM - Rustam

RHEL 6.1

How to configure Red hat Enterprise Linux 6.1?

Program Ver. : Xmanager 3.0
Connect Method : XDMCP connection
Tuesday, August 2, 2011 1:06 AM - Support

Re: RHEL 6.1

Please follow the instruction below to enable XDMCP on RHEL:

Xmanager Faq : Red Hat Configuration Red Hat 7, Red Hat 8, Red Hat 9, Red Hat 3.0 AS, Red Hat 5 EL, Red Hat 4 EL

If you have already done this, it might be firewall or network issue.

If the problem persists, please attach the Xmanager log file. To get the Xmanager file, wait for connection failure. Right click on the Xmanager title bar and select Log > File.

Technical Support
Tuesday, August 2, 2011 7:42 PM - Rustam

Re: RHEL 6.1

RHEL 6.1 it is visible in Xbrowser but if to press button Refresh, it disappears, then after a while appears again.
Log the file is enclosed.
Attachment X0.txt (3.3 KB)  
Wednesday, August 3, 2011 6:44 AM - Support

Re: RHEL 6.1

If you can see the RHEL session (dynamic session) on Xbrowser, it means XDMCP is enabled on RHEL.

I can think of 2 possible causes:

1. Windows firewall or third party firewall is blocking Xmanager from using TCP port 6000. To fix this problem, add Xmanager.exe to the exception list on firewall settings.

2. DNS entry for either your PC or RHEL is not configured correctly. Try doing 'nslookup' for your PC and the remote host. Make sure the IP addresses are correct. Then, try doing 'nslookup' with IP address. Make sure the hostname is entered correctly.

Technical Support

Wednesday, August 3, 2011 9:01 PM - Rustam

Re: RHEL 6.1

1. All firewall are switched off
2. Using Nslookup I have not found what problems
There is another PC with installed OS RHEL 6.0, there the same options and it Xmanager are defined without problems

I have installed parametre Xbrowser-> Tools-> Options-> Host Availability Check=15 sec. And now RHEL 6.1 disappears and there are each 15 seconds.
Thursday, August 11, 2011 1:58 AM - Support

Re: RHEL 6.1

What are the results of forward and reverse nslookup?

If you can connect to RHEL 6.0 but not RHEL 6.1, it means Xmanager is installed and working fine. It is usually the network or remote host configuration issue.

If the problem persists, please send us the following information:

1. Xmanager log file. Wait until the XDMCP failed message to open and right click on the Xmanager title bar. Select Log > File.
2. Log files on the remote host. All files under /var/log/gdm/

Technical Support
Sunday, December 25, 2011 9:25 AM - george

Re: RHEL 6.1

netsarang can not connet to centos, redhat el 6.1 and 6.2 at all
it is very easy to verify the problem, it takes only 15 minutes to install centos to your vmware.
Sunday, December 25, 2011 9:39 AM - george

Re: RHEL 6.1

send you some logs from /var/log/gdm
The behaviour is the following:
The computer icon appears after some minutes at netsarang. If you double click it nothing happens and the connection failed after some time.
After the connection failed the computer icon dissapears from netsarang.
this is happening to centos 6.1 , centos 6.2 for sure.

All the configuration/firewall/networking is fine.

Monday, December 26, 2011 1:06 AM - Support

Re: RHEL 6.1

I have just tested Centos 6.2 on VMware Workstaion 7 and can confirm that XDMCP worked. Here is what I have done:

1. Install CentOS 6.2 64 bit edition on VMware Workstation 7.
2. Configure gdm to allow remote XDMCP connections. Open /etc/gdm/custom.conf and set the following values:



3. Open /etc/sysconfig/selinux and disable by setting the SELINUX to disable like this:


4. Add UDP port 177 in Centos firewall (System > Administration > Firewall) settings.

5. Change the run level to 3 with 'init 3' command and brining it back up to 5 by with 'init 5'.

Sometimes VMware network driver can misbehave and prevent Xmanager from accessing the remote hosts. Restarting the PC usually fixes this problem.

Also, if you have 3rd party internet security applications installed, it may prevent Xmanger from receiving incoming connections. Try turning off Windows firewall and 3rd party security suites temporaily to find the cause.

Technical Support
Monday, December 26, 2011 2:35 PM - george

Re: RHEL 6.1

Of course the steps you mention are absolute necessary.
This is very interesting, so I install at VMWare workstation 8.0.1 the following

Centos 6.2 x86
Centos 6.2 x64
Redhat el 6.2 x64

At both x64 the xdmcp failed. At x86 worked immediately.
All vms have exactly the same settings at /etc/gdm/custom.conf and networking
Tuesday, December 27, 2011 12:56 AM - Support

Re: RHEL 6.1

If you can connect to any one of the Linux hosts, it means Xmanager is installed and running correctly. This is probably a network configuration issue. You can try the followings:

1. Make sure the addresses on all Linux hosts are unique
2. Try restarting the PCs where Xmanager and VMware workstation are installed
3. Add your PC IP address in the /etc/hosts file like the following example: PC_NAME

If the problem persists, please send us the Xmanager log file. To get the log file, wait for the connection failure message and then right click on the Xmanager title bar and select Log > File.

Technical Support
Tuesday, June 26, 2012 1:28 PM - rheluser

RHEL 6.3 x64


testing new redhat ent linux 6.3 x64 could not connect. at /var/log/gdm
there messages like:

** (:2623): DEBUG: Client registered with session manager: /org/gnome/SessionManager/Client1

(polkit-gnome-authentication-agent-1:2636): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:2636): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
** (process:2638): DEBUG: Greeter session pid=2638 display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-O7uQym/database
gdm-simple-greeter[2638]: Gtk-WARNING: gtkwidget.c:5460: widget not within a GtkWindow
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x240002b (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Failed to play sound: File or data not found