Xmanager Forum

How to configure Red hat Enterprise Linux 6

Last post: Tuesday, October 22, 2013 11:22 PM by Support, 13 reply

 
Thursday, June 2, 2011 7:58 PM - jackson

How to configure Red hat Enterprise Linux 6

 
How to configure Red hat Enterprise Linux 6 use Xmanager

Red hat Enterprise Linux 6 is different from Red hat Enterprise Linux 5.X

Program Ver. : Xmanager 4
Connect Method : XDMCP connection
Tuesday, June 7, 2011 2:08 AM - Support

Re: How to configure Red hat Enterprise Linux 6

 
1. Open /etc/gdm/custom.conf and edit the security and xdmcp section like the followings:

[security]
DisallowTCP=false

[xdmcp]
Enable=true

3. Add UDP port 177 to the Allow list on firewall.

2. As an admin, do 'init 3' and then, 'init 5'

---
Technical Support

Monday, June 13, 2011 11:48 AM - Terry Lemons

Re: How to configure Red hat Enterprise Linux 6

 
Hi

Thanks for providing these instructions. I used them on a RHEL 6 x64 system. But, even after a reboot of the system, I don't see thi ssystem show up in the list in Xbrowser 3.

Is there something else that needs to be done?

I have RHEL 5 systems that work fine.

Thanks
tl
Tuesday, June 14, 2011 5:32 AM - Support

Re: How to configure Red hat Enterprise Linux 6

 
If you have enabled XDMCP and open UDP 177 on the server, make sure gdm is running. Use 'ps -aef | grep dm' and it should give you the display manager that is running on the server.

If it it not running, please make sure the display manager such as gdm or kdm is installed on the machine. Red Hat 6 does not install display manager by default.

---
Technical Support
Tuesday, June 14, 2011 6:21 AM - Terry Lemons

Re: How to configure Red hat Enterprise Linux 6

 
[root@eros ~]# ps -aef | grep gdm
root 2322 1 0 Jun13 ? 00:00:00 /usr/sbin/gdm-binary -nodaemon
root 2388 2322 0 Jun13 ? 00:00:00 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display1 --force-active-vt
root 2392 2388 0 Jun13 tty1 00:00:13 /usr/bin/Xorg :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-P0Scy8/database vt1
gdm 2501 1 0 Jun13 ? 00:00:00 /usr/bin/dbus-launch --exit-with-session
gdm 2502 1 0 Jun13 ? 00:00:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
gdm 2504 2388 0 Jun13 ? 00:00:00 /usr/bin/gnome-session --autostart=/usr/share/gdm/autostart/LoginWindow/
gdm 2511 1 0 Jun13 ? 00:00:00 /usr/libexec/gconfd-2
gdm 2526 2504 0 Jun13 ? 00:00:00 /usr/libexec/at-spi-registryd
gdm 2529 1 0 Jun13 ? 00:01:14 /usr/libexec/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins
gdm 2531 1 0 Jun13 ? 00:00:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=12
gdm 2539 1 0 Jun13 ? 00:00:00 /usr/libexec/gvfsd
gdm 2540 2504 0 Jun13 ? 00:00:00 metacity
gdm 2541 2504 0 Jun13 ? 00:00:00 /usr/libexec/polkit-gnome-authentication-agent-1
gdm 2544 2504 0 Jun13 ? 00:00:01 /usr/libexec/gdm-simple-greeter
gdm 2545 2504 0 Jun13 ? 00:00:00 gnome-power-manager
gdm 2556 1 0 Jun13 ? 00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
root 2563 2388 0 Jun13 ? 00:00:00 pam: gdm-password
root 2564 2388 0 Jun13 ? 00:00:00 pam: gdm-fingerprint
root 15928 15885 0 09:19 pts/0 00:00:00 grep gdm
[root@eros ~]#

[root@eros ~]# cat /etc/gdm/custom.conf
# GDM configuration storage

[daemon]

[security]
DisallowTCP=false

[xdmcp]
Enable=true

[greeter]

[chooser]

[debug]

[root@eros ~]#

I don't see this system (eros) in the Xbrowser list.

Thoughts?

Thanks!
tl
Thursday, July 14, 2011 12:36 PM - Terry Lemons

Re: How to configure Red hat Enterprise Linux 6

 
Hi

Sorry to nag, but how can we move forward on this? What else can I try?

Thanks
tl
Tuesday, July 19, 2011 2:10 AM - Support

Re: How to configure Red hat Enterprise Linux 6

 
Please try turning iptables off for a test.

Also, try adding the server's IP address manually. To do this:

1. Open Xbrowser
2. Open Tools > Options
3. For the Search list, add the IP address of the remote host



---
Technical Support
Tuesday, July 26, 2011 7:58 AM - Terry Lemons

Re: How to configure Red hat Enterprise Linux 6

 
Hi

Thanks very much for the reply! I did:

/etc/init.d/iptables stop

and, voila!, my RHEL 6 system showed up in the Xbrowser list. When I re-started iptables, my RHEL6 system disappeared from the Xbrowser list. So there must be something there that is interferring with the X advertisement broadcast.

Here are the rules currently enabled. Any thoughts about what should be changed?

Thanks very much!
tl

[root@eros ~]# iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere PHYSDEV match --physdev-is-bridged
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[root@eros ~]#
Tuesday, July 26, 2011 6:38 PM - Support

Re: How to configure Red hat Enterprise Linux 6

 
You have add UDP port 177 to allowed list. To do this:

1. On console, go to System > Administration > Security Level and Firewall.
Result: Security Level Configuration dialog box opens.
2. Click 'Other Ports'
3. Click the Add button
Result: Add Port dialog box opens.
4. Enter 177 for Port.
5. Select UDP for Protocol.
6. Click OK to save the changes.

Restart firewall.

---
Technical Support
Wednesday, July 27, 2011 8:15 AM - Terry Lemons

Re: How to configure Red hat Enterprise Linux 6

 
EXCELLENT instructions. I added what you suggested, and can now connect and browse via Xmanager, even with the firewall enabled.

Thanks again!
tl
Monday, December 10, 2012 5:14 AM - Amit

Re: How to configure Red hat Enterprise Linux 6

 
Hi,

I am trying to configure xmanager to be able to connect a remote RHEL 6.2 machine. I followed all the above instructions but still its not working for me.

Program Ver. : Xmanager 4
Connect Method : XDMCP connection

Steps done so far.
1. Configured /etc/gdm/custom.conf,
[security]
DisallowTCP=false
[xdmcp]
Enable=true

2. Disabled the firewall.
service iptables status
iptables: Firewall is not running.

3. checked if gdm is installed and running.

yum list | grep gdm
gdm.x86_64 1:2.30.4-32.el6 @anaconda-RedHatEnterpriseLinux-201111171049.x86_64/6.2


ps -eaf | grep gdm
root 1851 1 0 10:27 ? 00:00:00 /usr/sbin/gdm-binary -nodaemon
root 1881 1851 0 10:27 ? 00:00:00 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display1 --force-active-vt


Kindly assist.

Thanks
Monday, December 10, 2012 4:48 PM - Support

Re: How to configure Red hat Enterprise Linux 6

 
Please try the below:

1. Restart RHEL
2. In Windows firewall, open incoming TCP ports 6000~6010.

If the problem persists, please send us your Xmanager log.

---
Technical Support
Tuesday, October 22, 2013 1:58 AM - Daxesh Laiwala

Re: How to configure Red hat Enterprise Linux 6

 
I done said configuration but still not getting any one can help me
Tuesday, October 22, 2013 11:22 PM - Support

Re: How to configure Red hat Enterprise Linux 6

 
Can you try the followings and send us the result?

1. From the Red Hat console, can you ping your PC?
2. From your PC, can you ping the Red Hat machine?
3. Do you see the Red Hat host icon on Xbrowser?
4. If you answered "yes" to # 3, can you see the login screen when you double click on it?

---
Technical Support