Xmanager Forum

Starting Red Hat 9 at boot time

Last post: Tuesday, July 1, 2003 12:01 AM by Support, 1 reply

 
Monday, June 30, 2003 5:00 AM - Mike

Starting Red Hat 9 at boot time

 
I need to manually enter "/usr/X11R6/bin/xdm &" every time I boot my Red Hat 9.0 server.

If I enter a script at rc5.d to do this, the boot endlessly loops around the XFree login screen.

Is there a way for Red Hat 9 to accept XDMCP without my entering ".../xdm &" at bootup?

Thanks.
Tuesday, July 1, 2003 12:01 AM - Support

Re: Starting Red Hat 9 at boot time

 
To get a graphic login screen at bootup, you should change the runlevel of the Linux to 5 as following:

1. Open /etc/inittab file with an editor.
2. Change "id:3:initdefault:" to "id:5:initdefault:"

This will enable the gdm at bootup time.

If you would like to use "xdm" instead of "gdm", open "/etc/sysconfig/desktop" file, and then set the desktop to "XDM" such as:

DESKTOP="XDM"

----
Technical Support