Xmanager Forum


Last post: Friday, March 12, 2010 1:52 AM by Daniella, 3 reply

Saturday, March 6, 2010 12:53 AM - Philip Lee


I have installed a new system of Suse Linux 10 Enterprise version. Also I have download the Xmanager and planing use Xmanager to connect Suse Linux.
I have following this link to make setting changed: /products/xmg_faq.html. But there is some problem when I'm tried to following the setting.
1. In step2, it said I need update kdmrc in /etc/opt/kde3/share/config/kdm/. However there is no this folder and file. Could you tell me where I can update this file?

2. How can I open the port 177 and 6000~6010 port? I cannot find where I can changed.

Thank you.

Program Ver. : Xmanager 1.3.x
Connection Method : XDMCP connection
Sunday, March 7, 2010 9:31 PM - Daniela

Re: administrator

Here is how to setup SUSE XDMCP, the graphical way:

To enable this on the "server" side (the "remote" system), select "Security and Users" in YAST, then click on "Security Settings" and proceed to the 4th form. There put an X before "Allow remote Graphical Login". This changes the file /etc/sysconfig/displaymanager and takes effect with the next boot-up (the file /etc/X11/xdm/xdm-config will be modified on the fly by the rc script). If you wish you can run "rcxdm restart." Do this by switching to a non-graphical console such as with the key combination ctrl-alt-F1 to go to console #1. Login as root and run "rcxdm restart." Note that alt-ctrl-F7 returns you to the default graphical console, but you'll be returned there automatically as the display manager is reset.

You must also adjust the default settings of the Firewall. Go to YAST then "Security Settings" and choose "Firewall." Once there choose "Allowed Services" and go into the "Services to Allow" pull down. Pull it down (down arrow if you're running the non-graphical version) and choose "Remote Access to Display Manager" then "Add."

To allow Xmanager to accept incoming XDMCP request, open Windows firewall settings, go to Control Panel > Firewall and add TCP port 6000 to 6010 to the Exception list.

Tuesday, March 9, 2010 6:10 PM - Philip

Re: administrator

I'm still failed to enable XDMCP in Suse Linux 10. Also it caused I cannot test the XManager in Suse Linux 10 server.
I have followed your steps. But I cannot find "Allow remote Graphical Login".
In YAST > Security and Users, there is no opinions for security. So how can I enable "Allow remote Graphical Login"?

Thank you.
Friday, March 12, 2010 1:52 AM - Daniella

Re: administrator

1.Open a terminal as root
2.Start Yast2
3.Click System and then, /etc/sysconfig Editor
4.Under Desktop and Display manager, find DISPLAY_MANAGER_REMOTE_ACCESS and set its value to 'yes'

And, now open UDP 177 port on firewall:

5. Firewall > SuSEfirewall2 > FW_SERVICES_EXT_UDP > 177
6.Click Finish

Don't forget to open TCP 6000~6005 on your PC.