Xmanager Forum

problems with Xstart+ SSH

Last post: Wednesday, June 11, 2003 10:49 PM by Vallery Stanishev, 4 reply

Sunday, June 8, 2003 12:50 AM - Vallery

problems with Xstart+ SSH


I'm trying to connect to my Linux PC (RH7.3) with Xstart + SSH but
I couldn't get it working. Each time I tried I got this message.
Can anyone help me?



Exchanging SSH version...Done.
Server: SSH-1.99-OpenSSH_3.5p1.
Client: SSH-1.5-Xssh_1.0.
SSH1 is enabled.

Authenticating remote SSH server...
Waiting for server host key...Received.
Fingerprint: 1024 8d:4a:b4:4d:f5:69:83:a6:e4:b9:9e:fd:80:39:4a:cc.
Verifying host key...Verified.

Negotiating cipher (encryption method)...Done.
Selected cipher: 3DES.

Trying to login as vall.
Trying password authentication...Done.

Requesting X11 forwarding...Done.

Requesting compression...Done.

Remote command has been requested.

X11 channel request arrived.
Establishing X11 connection (id=1)...Done.

X11 channel (id=1) has been closed.

All forwarding channels are closed, disconnecting...


X11 channel request arrived.
Establishing X11 connection (id=2)...Done.

Attachment Xmanager.log ()  
Sunday, June 8, 2003 2:12 AM - Support

Re: problems with Xstart+ SSH

In regarding the log messages, you might have run a script that invokes several X applications. Xmanager restarts when the first X application is closed automatically.

Please just run an xterm with Xstart and try to the script at the prompt of xterm.

If the problem persists, let us know the command you entered in the Xstart.

Technical Support
Sunday, June 8, 2003 10:12 PM - Vallery

Re: Re: problems with Xstart+ SSH


I didn't try to run any scripts. The command I execure in Xstart
is: /usr/bin/X11/xterm -ls

Should I do some configuration before tring to run Xsrart? I just installed it and tried to run it.

Monday, June 9, 2003 11:19 PM - Support

Re: Re: Re: problems with Xstart+ SSH

It seems that some X commands such as "xsetroot" or "xmodmap" are specified in your login shell script. You need to try to remove "-ls" option in the command. Also try to turn the "Terminate at reset" option off in the Xconfig->option.

Hope to solve the problem.

Technical Support
Wednesday, June 11, 2003 10:49 PM - Vallery Stanishev

Re: Re: Re: Re: problems with Xstart+ SSH

It worked. Thans a lot.