Xmanager Forum

Problem with mouse pointer ...

Last post: Wednesday, February 3, 2010 11:21 PM by Support, 11 reply

 
Wednesday, December 16, 2009 12:43 AM - Anatol

Problem with mouse pointer ...

 
Hi, we have a problem on using XManage 3.0
We use XManager on MS WinXP SP3 to connect Sun Solaris 10 box (CDE) via XDMCP, where run an application in full screen mode. After starting this application, mouse pointer not visible. But if the application window hide and unhide the mouse pointer do visible. In XManager ver. 2 this application works correctly - mouse pointer always visible. Can you help me correct this problem with mouse pointer in XManage 3.0?
P.S.
In attachment extended log, which look nice.


Program Ver. : Xmanager 3.0
Connection Method : XDMCP connection
Attachment X0.log (6.5 KB)  
Wednesday, December 16, 2009 10:29 PM - Support

Re: Problem with mouse pointer ...

 
We will have to try duplicating the problem. Please send us the following information:

1. Name and version of the X application
2. Screenshot of the problem (Good and bad would be very helpful)

Thank you for your cooperation.

---
Technical Support
Thursday, December 17, 2009 3:10 AM - Anatol

Re: Problem with mouse pointer ...

 
To repeat the given problem at you will be problematic, because we cannot give this X application to you for testing and that application not free available. The name of this application PSIcontrol is a SCADA developed PSI AG Germany.
On a following link you can download video with problem demonstration, because screeenshots don`t capture mouse pointer.

http://www.4shared.com/file/175008747/a190fc20/17122009_13-18-27.html
Sunday, December 27, 2009 10:12 PM - Support

Re: Problem with mouse pointer ...

 
Thank you for your patience.

We are now trying to find a way to duplicate the problem or possibly prepare a debugging module. (Otherwise, it would be difficult for us to reolve this issue). Please allow us a few days to get back to this issue.

---
Technical Support
Monday, December 28, 2009 6:18 PM - Support

Re: Problem with mouse pointer ...

 
We have prepared a debugging module for the problem. This module will create more thorough log. To apply the module, follow the instruction below:

1. Extract the Xmanager.exe from the attached file and save it on your desktop.
2. Move the file to Xmanager Enterprise installed path.

Default installation path: C:\Program Files\NetSarang\Xmanager Enterprise 3

3. Run Xconfig and open the default profile.
4. Click the Advanced tab and select the "Verbose Log Message" option.

To retrieve the log file, run the Xmanager session and reproduce the problem. At this point, right click on the Xmanager title bar and select Log, and then File.

Send us the log file to support@netsarang.com.

---
Technical Support
Monday, January 18, 2010 11:30 PM - Anatol

Re: Problem with mouse pointer ...

 
We tried to run our X application (PSIcontrol) in Xmanager with a debugging module and "Verbose Log Message" option enabled, but Xmanager crash with critical error. In attachment log file ...
Attachment X0.log (5.8 KB)  
Wednesday, January 20, 2010 1:15 AM - Support

Re: Problem with mouse pointer ...

 
Do you see the mouse cursor before Xmanager crashes? If so, please send us all crash Inforamtion in you see on the Crash information dialog box. Also, if you don't see this window, check the Windows Event viewer (Control Panel > Administrative Tools > Event Viewer) for Xmanager crash event.


---
Technical Support
Wednesday, January 27, 2010 1:20 AM - Anatol

Re: Problem with mouse pointer ...

 
Yes, when we run XManager and connect to Solaris box the mouse pointer - visible. But when we run our X application the XManager crash. In attachment:
dialogbox_crash_screenshot.gif - screenshot of crash error dialog box;
crash_report_for_MS.txt - crash report for sending to MS;
crash_event.txt - information from event viewer about this crash.
Wednesday, January 27, 2010 1:21 AM - Anatol

Re: Problem with mouse pointer ...

 
attachment continue ...
Wednesday, February 3, 2010 1:01 AM - Support

Re: Problem with mouse pointer ...

 
Thank you for your patience. We have prepared a new Xmanager execuatable file. Please place the attached file in Xmanager directory and see if the problem persists.

If the problem persists, please capture a screenshot of the problem and send it to us at support@netsarang.com

We look forward to hearing from you soon.

---
Technical Support
Wednesday, February 3, 2010 4:59 AM - Anatol

Re: Problem with mouse pointer ...

 
With new Xmanager executable file the mouse pointer in our X Application work fine. Thank you for solving this problem.
We hope, this problem can be fixed in next build of XManager.
Wednesday, February 3, 2010 11:21 PM - Support

Re: Problem with mouse pointer ...

 
I am glad to hear the fix worked for you. This fix will be included in February update.

February update is scheduled to be released on the 28th of this month.


---
Technical Support