Xmanager Forum

Cutting " or ' From a Document Yields <93> and <92> -- Why?

Last post: Monday, September 7, 2009 6:35 PM by Bill Goffe, 2 reply

 
Friday, September 4, 2009 1:31 PM - Bill Goffe

Cutting " or ' From a Document Yields <93> and <92> -- Why?

 
When I cut text from a document like http://well.blogs.nytimes.com/2009/09/01/phys-ed-does-ibuprofen-help-or-hurt-during-exercise/ (you may need a free account) characters like ¿ (curly double quotes) are pasted into vim on Linux as <93>, which appears to be a special character (i.e. searching for 93 yields nothing and it is deleted as one character). Something similar happens with other characters such as apostrophes.

Is there a way I can cut from such documents and have them appear as curly brackets in vim?

Program Ver. : Xmanager 3.0
Connection Method : Xstart connection
Monday, September 7, 2009 12:47 AM - Xshell_user

Re: Cutting " or ' From a Document Yields <93> and <92> -- Why?

 
Check the language setting on the server (echo $LANG) and try selecting that same language encoding on Xshell.


For instance, my server's lang is set as 'en_US' and on Xshell, I select "Western European (ISO)" or "Default". It works either way.
Monday, September 7, 2009 6:35 PM - Bill Goffe

Re: Cutting " or ' From a Document Yields <93> and <92> -- Why?

 
Thanks -- that worked. I started fresh with Xshell and forgot to reset the character set in it. Very nice to have this working correctly.