Xmanager Forum

Can't open X session on RHEL 5.3

Last post: Tuesday, August 11, 2009 8:54 AM by ipman, 3 reply

 
Wednesday, July 15, 2009 10:45 AM - Terry Lemons

Can't open X session on RHEL 5.3

 
Hi

I'm using Xbrowser 2.0 to create an X session on a RHEL 5.3 system. I followed the instructions in the FAQ, and edited the /etc/gdm/custom.conf file:

[security]
AllowRemoteRoot=true
DisallowTCP=false

[xdmcp]
Enable=true

The FAQ mentions only the 'xdmcp' entry, but I've added the two other entries (having seen them on other system), in an attempt to make this work. But it's not working. I do see the RHEL 5.3 system name show up in Xbroswer. But when I double-click on the system name, a X session window flashes into existence, then disappears. I don't see any error messages in /var/log/messages on the host. Nor do I see any files in C:\Program files\NetSarang\Xmanager2 that could be log files.

What else can I check?

Thanks!
tl

Program Ver. : Xmanager 2.x
Connection Method : XDMCP connection
Wednesday, July 15, 2009 8:02 PM - Support

Re: Can't open X session on RHEL 5.3

 
Please send us the following information:

1. Upgrade to Xmanager 3.0 and see if the problem persists. Download Xmanager 3.0 at:

/download/down_xmg3.html

2. What is the language setting on the remote host.

3. Xmanager log file. Please follow the link below for the log file location:

/products/xmg_faq.html#i-1

Thank you.


---
NetSarang Support
Friday, August 7, 2009 9:48 AM - ipman

Re: Can't open X session on RHEL 5.3

 
Having the same problem with the same OS. Here is what my log says

Waiting for client connections ...

Xdmcp: received a WILLING message.
Xdmcp Request Address: 10.*.*.*
Xdmcp Connection Address 0: 10.*.*.*
Xdmcp: sent a REQUEST message.
Xdmcp: received an ACCEPT message.
Xdmcp: sent a MANAGE message.
Xdmcp: Timed out, state 8. Retransmissions: 0
Xdmcp: sent a MANAGE message.
Xdmcp: Timed out, state 8. Retransmissions: 1
Xdmcp: sent a MANAGE message.
Xdmcp: Timed out, state 8. Retransmissions: 2
Xdmcp: sent a MANAGE message.
Xdmcp: Timed out, state 8. Retransmissions: 3
XDM go to sleep: too many retransmissions
Tuesday, August 11, 2009 8:54 AM - ipman

Re: Can't open X session on RHEL 5.3

 
Issue resolved after doing this:

1. Edit the /etc/sysconfig/desktop file to define GNOME as the X desktop environment that loads on connection.
1. Open the /etc/sysconfig/desktop file.
2. Locate the DESKTOP= entry. Note: The entry may need to be created and it is case sensitive.

Change this setting to: DESKTOP="GNOME"

3. Save the file.