Xmanager Forum

strange things for DISPLAY setting

Last post: Thursday, May 7, 2009 4:32 PM by Roberto, 2 reply

Thursday, May 7, 2009 8:05 AM - Roberto

strange things for DISPLAY setting

No matter I use xshell or xterm to connect to my linux box. I noticed that the default DISPLAY is:

tivc02:~ # echo $DISPLAY

And it works for "xclock". But in my knowledge, the DISPLAY should be set to the client IP.

My client IP is:
IP Address. . . . . . . . . . . . :

My linux IP is: inet addr:

So, it "should be" set to export DISPLAY=

but this setting not work, and the default setting work well!!

Who can make me understand that?

Thank you very much!

Program Ver. : Xmanager 3.0
Connection Method : Other
Thursday, May 7, 2009 10:24 AM - Support

Re: strange things for DISPLAY setting

This is normal when you use SSH as your connection protocol. DISPLAY is set as localhost because SSH uses secure tunnel that is created between your PC and the Linux server to send data to your PC. In other words, when you launch an X application such as xclock, all of it data will be sent via SSH Tunnel which is located on localhost:10.0 other than sending it directly to your PC with no encryption and protection.

For more information, please visit.

Displaying Ubuntu Linux Applications Remotely (X11 Forwarding)

Note: The page explains X11Forwarding on Ubuntu but the same rule applies to any other Linux machines as well.

Technical Support
Thursday, May 7, 2009 4:32 PM - Roberto

Re: strange things for DISPLAY setting

Understood! Thx.