Xmanager Forum

emacs: Undefined color: "black"

Last post: Monday, May 11, 2009 6:24 PM by Support, 5 reply

Tuesday, April 21, 2009 9:49 PM - xuser

emacs: Undefined color: "black"

I am new to xmanager 3.0. I am getting a weired error. When I XDMCP into my redhat box (both e3 and e5 tested), everything seems to work fine, until I launch emacs, then I get:

Undefined color: "black"

Through trial and error, I eventually figured out a workaround, if I reset my XManager, then everything works afterwards. So it seems upon startup some state is not fully set correctly in xmanager, but a reset of the server fixes the problem.

this is what I do:

1) launch xbrowser
2) double click on my redhat box
3) after I see the redhat login window, I right click on my xmanager icon on the task car, and select "reset server".
4) I am back at the login screen agin, log in.

If I don't do server reset, then i can't run emacs. removing my .emacs file made no difference. I have 32-bit XP with SP3.

Is this a known problem? I have xmanager 3.0 build 0186. Thanks.

Program Ver. : Xmanager 3.0
Connection Method : XDMCP connection
Friday, April 24, 2009 3:24 PM - Support

Re: Emacs: Undefined Color: "black"

This problem may occur when the color database is not loaded properly.

To find out if the color database is causing the problem, please try performing the followings:

When you get the "Undefined color: 'block'" error, give the following command:

xterm -bg black&

If the command returns the following error, it means the color database is the problem.

"Warning: Color name 'black' is not defined"

To resolve this problem, try uninstalling Xmanager and reinstall it with Administrator previlage.

Techincal Support
Wednesday, April 29, 2009 7:24 PM - xuser

Re: emacs: Undefined color: "black"

Thank you for the reply.

Running "xterm -bg black&" does generate the same error. Likewise, if I perform a "server reset" by right click on xmanage on the task car, the problem disappears.

Looking at the file "C:\Program Files\NetSarang\Xmanager Enterprise 3\rgb\rgb.txt", I do see black defined:

255 255 255 white
0 0 0 black
47 79 79 dark slate gray

so I don't think it's an installer issue.

The fact that performing a 'server reset' the problem disappears lead me to think this is a bug in the software, rather than an installer issue.
Thursday, April 30, 2009 4:17 PM - Support

Re: emacs: Undefined color: "black"

I think the problem is that Xmanager is not being able to find/read the rgb.txt file at initial startup and when it resets, then it is able to access it.

The cause for it is unclear but reinstalling the software as administrator may fix the problem.

If your problem persists, please send us the Xmanager log file. To retrieve Xmanager log file, right click on Xmanager title bar and select Log > File.

Technical Support
Friday, May 1, 2009 10:27 AM - xuser

Re: emacs: Undefined color: "black"

Aha, I see the problem.

In the log file, I see the following before reset:

RGB database: C:\Program Files\NetSarang\Xmanager Enterprise 3\\rgb.txt
Couldn't open RGB_DB 'C:\Program Files\NetSarang\Xmanager Enterprise 3\\rgb.txt'

notice the double \\ in front of rgb.txt.

After reset, i see

RGB database: C:\Program Files\NetSarang\Xmanager Enterprise 3\rgb\rgb.txt

Looking at the X-config color database path, it is

C:\Program Files\NetSarang\Xmanager Enterprise 3\rgb\rgb.txt

so I am not sure where the extra \\ comes from.

Monday, May 11, 2009 6:24 PM - Support

Re: emacs: Undefined color: "black"

Thank you for your patience.

Our developers are now working on this problem. At this point, the cause of the problem is still not clear. Could you provide us with the following extra information?

1. Full Xmanager log file (not a clip) after doing a reset.
2. Xcofig profile used by the session.

If you are using the Default Xconfig profile, it is located under:

C:\Documents and Settings\All Users\Application Data\NetSarang\Xmanager Enterprise\3\Xconfig

If you are using a custom Xconfig profile, you can find it under:

C:\Documents and Settings\$USERNAME$\Application Data\NetSarang\Xmanager Enterprise\3\Xconfig
Note: Substitude $USERNAME$ with the real username.

Thank you.

Technical Support