Xmanager Forum

color depth problems specific to Xmanager Enterprise and Avizo 5.1

Last post: Thursday, March 19, 2009 6:58 PM by Support, 1 reply

 
Wednesday, March 18, 2009 4:35 PM - B. Marcahnd

color depth problems specific to Xmanager Enterprise and Avizo 5.1

 
I am trying to execute a program called Avizo, installed on a linux host running RHEL 5, from a Windows Vista PC at home. I have, in the past, always been able to run previous versions of the program through Xmanager Enterprise 2.0, but the latest version (5.1) seems to have issues ONLY with Xmanager Enterprise 2.0 and 3.0. I am able to run the program just fine with Xming-mesa, a free x-server available from http://www.straightrunning.com/XmingNotes/, so I am curious as to the source of the problem and whether or not there is a fix or work-around.

A trial version of Avizo 5.1 may be downloaded from http://www.vsg3d.com/, in case you want to try this out yourselves. I've included a copy of the error below. As you can see, I first type the command that starts Avizo, conveniently named "start", the splash screen shows up on the screen as expected, then the program exits immediately with the following error:

[marchand@wrw208-pc1 bin]$ /opt/Mercury/Avizo5.1/bin/start
Using arch-Linux-Optimize ...
QObject::connect: Cannot connect (null)::XEnterEvent(unsigned int) to QxViewer::processCommonEnterEvents(unsigned int)
QObject::connect: Cannot connect (null)::XLeaveEvent(unsigned int) to QxViewer::processCommonEnterEvents(unsigned int)
Segmentation fault


With the help of the Avizo technical support folks, I narrowed down the problem to the "color depth" of the server. For some reason, the "color depth" detected and used by Xming is 24 bits, but Xmanager insists on using Pseudocolor. The question is why are Xmanager Enterprise and Xming detecting different things? The color settings are set to "Autodetect" in XConfig. I also deselected anything to do with Pseudocolor in XConfig during my testing, but that did not seem to help. I downloaded Xmanager Enterprise 3.0 to test as well, but that also has the same problem. Is there any way to force Xmanager to use the correct color depth?

I've attached the output of an xdpyinfo command when running Xmanager Enterprise 2.0 and Xming-mesa for your reference. If you examine the file xdpyinfo_xmanager_enterprise_2.out, you'll note that all the "visual" sections list:

class: PseudoColor
depth: 8 planes

while xdypinfo_xming.out lists:

class: TrueColor
depth: 24 planes

Also, xdpyinfo_xming.out lists:

depths (7): 24, 1, 4, 8, 15, 16, 32
root window id: 0x3e
depth of root window: 24 planes

while in xdpyinfo_xmanager_enterprise_2.out lists:

depths (3): 1, 8, 24
root window id: 0x29
depth of root window: 24 planes

Even though they both say that the depth of the root window is 24 planes, Xmanager only detects 3 depths while Xming detects 7. Xming also defaults to 24 while Xmanager does not appear to do so even though it claims to.

Do you have any suggestions on other things to try? or is this always going to be a problem with Xmanager Enterprise and Avizo?

Program Ver. : Xmanager 2.x
Connection Method : Xstart connection
Thursday, March 19, 2009 6:58 PM - Support

Re: color depth problems specific to Xmanager Enterprise and Avizo 5.1

 
Color depth is automcatically selected by x applications. So in this case, it looks like Avizo is selecting Pseudo color (8bit) automatically.

With help of Mercury Computer Systems, we have received an evaluation copy of Avizo 5.1. We will try replicating the problem. Please allow us about a week to get back to this post.

Also, Xmanager 3.0 supports the following 7 color depths.

depth 1, bits_per_pixel 1, scanline_pad 32
depth 4, bits_per_pixel 4, scanline_pad 32
depth 8, bits_per_pixel 8, scanline_pad 32
depth 15, bits_per_pixel 16, scanline_pad 32
depth 16, bits_per_pixel 16, scanline_pad 32
depth 24, bits_per_pixel 32, scanline_pad 32
depth 32, bits_per_pixel 32, scanline_pad 32




---
Technical Support


Did you know that Xshell and Xftp are free for home and school use? To find out more, please click here.