Xmanager Forum

Telnet to Sun Solaris 10 via XManager

Last post: Saturday, August 16, 2008 5:58 AM by Support, 1 reply

Tuesday, August 12, 2008 4:26 PM - brandon

Telnet to Sun Solaris 10 via XManager

I wanted to remote to my Solaris and access some programs from my Xmanager.
When i do the telnet, i can get the Splashscreen of Xmanager after i have logon BUT nothing happens after that. Anything wrong here?

I have opened up this ports...
From remote host to local PC (Inbound):
- TCP 6000 ~ 6010 for Xmanager

From local PC to remote host (Outbound):
- UDP 177 for XDMCP
- TCP 512, 513, 514, 23, 22 for Xstart

Here are the message from the Xmanager...
login: root
Last login: Tue Aug 12 14:06:29 from
Sun Microsystems Inc. SunOS 5.10 Generic January 2005
You have mail.
Sourcing //.profile-EIS.....
root@dealerdb02 # /usr/openwin/bin/xterm -ls -display
/usr/openwin/bin/xterm Xt error: Can't open display:
root@dealerdb02 #

Program Ver. : Xmanager 3.0
Connection Method : Xstart connection
Saturday, August 16, 2008 5:58 AM - Support

Re: Telnet to Sun Solaris 10 via XManager

1. First, check if is your IP address.
2. Make sure there is no 3rd party internet security application that is blocking Xmanager.
3. Your remote host must be able to make a connection back to your PC via TCP port 6000. Make sure that the remote host can reach your PC.
4. If you have SSH on the remote server, try using SSH instead. (Among many benefits of using SSH, it allows you to run the remote X applications without reconfiguring firewall or gateway)

Technical Support

Did you know that Xshell and Xftp are free for home and school use? To find out more, please click here.