Xmanager Forum

Use Xmanager with X11Forward UNset on remote ssh server

Last post: Saturday, March 1, 2003 9:41 PM by Support, 3 reply

 
Thursday, February 27, 2003 10:55 PM

Use Xmanager with X11Forward UNset on remote ssh server

 
I work on win2000.
I want to connect on a machine running a BSD with
OpenSSH as server. The X11Forward option is UNsets.

The program says the remote server has not this option set.

How can we use XManager with ssh, when this option is unset ?

Tanks
Thursday, February 27, 2003 11:23 PM - Support

Re: Use Xmanager with X11Forward UNset on remote ssh server

 
You should enable X11Forward option in the /etc/ssh/sshd_config file on your BSD Linux. And then restart sshd.

We hope this can help you.

----
Technical Support
Saturday, March 1, 2003 7:05 PM

Re: Re: Use Xmanager with X11Forward UNset on remote ssh server

 
In fact I work in a company which doesn't allowed me to change
the server.

So I need a way to set up a ssh-forwarding-tunnel for the X, without
changing the server configuration.

I have to do it the way a unix ssh client does, I connect from win2k
via a ssh client to the remote machine which doesn't have XForward
option set, and then, adjust
parameters like : export display, set xauthority cookie, and redirect
X datas to the ssh tunnel to the local machine (win2k with Xmanager).

Do you know the manual way to do that stuff ?

Thanks
Saturday, March 1, 2003 9:41 PM - Support

Re: Re: Re: Use Xmanager with X11Forward UNset on remote ssh server

 
To set up X11 forward manually, please do the following steps:

1. Run Xmanager in a passive mode. It will listen TCP 6000.
2. Configure SSH client's port forwarding as following:

TCP 6020 (of Unix) ==> TCP 6000 (of Windows)

3. Connect to the Unix using the SSH client.
4. Set DISPLAY variable to ":20.0" as following:

# export DISPLAY=:20.0

5. Run an xterm at the prompt of SSH client.

If you forward TCP 6021 from the Unix, the DISPLAY variable will be ":21.0".

We hope this can help you.

----
Technical Support