Xmanager Forum

Can't create a usable display on SLES 10 SP1

Last post: Monday, July 20, 2009 11:21 PM by NetSarang, 12 reply

 
Saturday, June 16, 2007 2:24 PM - Terry Lemons

Can't create a usable display on SLES 10 SP1

 
Hi

I'm trying to use Xbrowser 2.0 to open an X session on a SLES 10 SP1 system.

I can see this SLES 10 system listed in the Xbrowser window.
I can double-click on this entry, and I then see the SLES 10 login window.
I enter my username, then my password. The login window disappears, and now I just see a black screen inside a Xmanger 2.0 window.

I use the same Xbrowser application to connect successfully to SLES 9 and many other systems.

Before I could see this SLES 10 system listed in Xbrowser, I modified these settings in the /etc/sysconfig Editor (which can be used via YaST):
DISPLAYMANAGER_REMOTE_ACCESS - change from no to yes
DISPLAYMANAGER_ROOT_LOGIN_REMOTE - change from no to yes
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN - change from no to yes

Thoughts?

Thanks!
tl
Attachment X0.log (3.4 KB)  
Monday, June 18, 2007 6:22 PM - @_@~

Re: Can't create a usable display on SLES 10 SP1

 
I had a same problem.

In my case, opening TCP 16001 solved the problem.

Try~
Monday, June 18, 2007 11:39 PM - Terry Lemons

Re: Re: Can't create a usable display on SLES 10 SP1

 
Hi

Thank you for the reply, but I don't have a firewall running on the SLES 10 system.

tl
Tuesday, June 19, 2007 6:41 AM - Terry Lemons

Re: Can't create a usable display on SLES 10 SP1

 
This sure feels like a Xmanager bug to me. I used a Solaris 10 system's login screen to access my SLES 10 system, using the Options -> Remote Login -> Choose Host From List feature. My SLES 10 system appeared in the list. I selected it, and was able to login with no problem.

So what is Solaris 10 doing that Xmanager isn't with SLES 10?

Thanks
tl
Tuesday, June 19, 2007 8:56 AM - VK

Re: Re: Can't create a usable display on SLES 10 SP1

 
Xmanager is a PC X server program and X applications such as CDE, Gnome, Xterm, and so on should be able to make the connection to the server as they are clients. Although your SLES 10 system does not run a firewall, please check if your PC or gateway between your PC and the remote host runs any firewall program.

Xmanager FAQ available on this site says Xmanager needs to have the following TCP ports to be opened:

From remote host to local PC (Inbound):
- TCP 6000 ~ 6010 for Xmanager
- *TCP 16001 for Gnome only
From local PC to remote host (Outbound):
- UDP 177 for XDMCP
- TCP 512, 513, 514, 23, 22 for Xstart

*Note: Gnome may fail to login or logout if TCP 16001 port is not allowed.

If your PC is running XP or 2003 or Vista, make sure to open those ports. A helpful guide is available on Xmanager FAQ under the Support menu.

Hope this helps.

-VK
Wednesday, June 20, 2007 3:42 AM - Terry Lemons

Re: Re: Re: Can't create a usable display on SLES 10 SP1

 
That did it! I opened TCP port 16001, and now everything works fine. Thanks for the explanation, and the pointer to the FAQ. I did read it (too quickly), but didn't think I could have a firewall problem since some of the communication happened correctly.

Thanks again
tl
Tuesday, June 19, 2007 9:09 AM - Andrew Jackson

Re: Re: Can't create a usable display on SLES 10 SP1

 
You should open TCP port 16001 on your PC, not on the server. Gnome requires this port to be open during the login process.


Wednesday, July 15, 2009 11:25 AM - Terry Lemons

Re: Can't create a usable display on SLES 10 SP1

 
Hi

I'm having the same problem with SLES 10 SP2. I'm runnning Xmanager V2.0 on Windows XP SP3. I've turned off the Windows firewall, so I think that no connection blocking could be occuring on the Xmanager system end.

I do see the SLES system name in Xbrowser. But, when I double-click to connect, a session window appears and then instantly disappears. I don't see any errors on /var/log/messages.

I did try to follow the SLES 10 setup instructions in your FAQ. But, where your FAQ says to modify /etc/X11/gdm/gdm.conf, that file and directory does not exist on my system. Instead, the gdm.conf is at /etc/opt/gnome/gdm/gdm.conf. I've checked that file, and it seems to have the right stuff:

[xdmcp]
# Distributions: Ship with this off. It is never a safe thing to leave
# out on the net. Setting up /etc/hosts.allow and /etc/hosts.deny to only
# allow local access is another alternative but not the safest.
# Firewalling port 177 is the safest if you wish to have xdmcp on.
# Read the manual for more notes on the security of XDMCP.
Enable=true


[security]
# If any distributions ship with this one off, they should be shot
# this is only local, so it's only for say kiosk use, when you
# want to minimize possibility of breakin
AllowRoot=true
# If you want to be paranoid, turn this one off
AllowRemoteRoot=true
# This will allow remote timed login
AllowRemoteAutoLogin=false
# 0 is the most restrictive, 1 allows group write permissions, 2 allows all
# write permissions
RelaxPermissions=0
# Check if directories are owned by logon user. Set to false, if you have, for
# example, home directories owned by some other user.
CheckDirOwner=true
# Number of seconds to wait after a bad login
RetryDelay=1
# Maximum size of a file we wish to read. This makes it hard for a user to DoS
# us by using a large file.
#UserMaxFile=65536
# If true this will basically append -nolisten tcp to every X command line,
# a good default to have (why is this a "negative" setting? because if
# it is false, you could still not allow it by setting command line of
# any particular server). It's probably better to ship with this on
# since most users will not need this and it's more of a security risk
# then anything else.
# Note: Anytime we find a -query or -indirect on the command line we do
# not add a "-nolisten tcp", as then the query just wouldn't work, so
# this setting only affects truly local sessions.
#DisallowTCP=true
DisallowTCP=false

I used Yast to set this up, so believe the values are correct.

Thoughts?

Thanks!
tl
Wednesday, July 15, 2009 8:03 PM - Support

Re: Can't create a usable display on SLES 10 SP1

 
Please send us the following information:

1. Upgrade to Xmanager 3.0 and see if the problem persists. Download Xmanager 3.0 at:

/download/down_xmg3.html

2. What is the language setting on the remote host.

3. Xmanager log file. Please follow the link below for the log file location:

/products/xmg_faq.html#i-1

Thank you.


---
NetSarang Support
Thursday, July 16, 2009 5:22 PM - Terry Lemons

Re: Can't create a usable display on SLES 10 SP1

 
Hi

Thanks for the suggestion. I upgraded to Xmanager V3, and see the same behavior. I've attached the log. I see the same behavior with both SLES 10 SP2 and RHEL 5.3.

Thanks
tl
Attachment X0.log (3.5 KB)  
Friday, July 17, 2009 4:35 AM - Support

Re: Can't create a usable display on SLES 10 SP1

 
The log file shows that the connection could not be established from server to PC direction. This can be caused by number of reasons:

  1. Misconfigured DNS. Perform the following diagnostics:

    1. Start Windows cmd.exe by clicking the Window Start menu and typing 'cmd' and enter.
    2. In the Windows cmd.exe window, type 'nslookup $PC_IP$
      *Replace $PC_IP$ with the real IP address.
    3. Make sure you only get one result.
    4. Again, in the Windows cmd.exe window, type 'nslookup $PC_HOSTNAME$
      *Replace $PC_HOSTNAME$ with the real host name of your PC.
    5. Make sure you only get one result.
    6. Perform the same diagnostics for the remote server. Make sure you get only one result for all nslookup requests.


  2. Gateway. If your Gateway is blocking TCP 6000 - 6010 from the remote server to PC direction, this problem may occur. Talk to your network administrator to allow these connections.

    Meanwhile, you can use Xstart to launch individual applications and desktops such as Gnome or KDE. Here are tutorials:

    Running X application through SSH protocol: /products/xmg_tutorial6.html

    Running KDE, Gnome or CDE through Secure Shell Tunnel:
    /products/xmg_tutorial7.html

    Also, this problem may occur when network driver is not installed correctly or network card is not functioning properly. If this might be your case, try using a different PC and see if the problem persists.



    ---
    NetSarang Support
Friday, July 17, 2009 7:46 AM - Terry Lemons

Re: Can't create a usable display on SLES 10 SP1

 
Hi

Thanks for the reply and the suggestion. I did forward and backward DNS lookup on both the Xmanager system and the SLES 10 system, and it works fine on both systems.

On the Xmanger system (which runs Windows 2003 SP2 Terminal Server), the firewall service is turned off (not running).

Other thoughts?

Thanks
tl
Monday, July 20, 2009 11:21 PM - NetSarang

Re: Can't create a usable display on SLES 10 SP1

 
This problem may occur when the Colors setting on the RDP (Remote desktop protocol) cannot handle Xmanager visual mode.

To resolve this problem, try using higher color setting on RDP client or try running Xmanager directly from the Terminal Servers console.

---
Technical Support