Xmanager Forum

Copy/Paste functionality is not consistent

Last post: Tuesday, June 26, 2007 10:06 AM by Support, 5 reply

 
Friday, June 8, 2007 2:39 AM - dynamox

Copy/Paste functionality is not consistent

 
I am currently evaluating the product (2.1 build 0026) and have problems copying and pasting from dtterm windows into a notepad.
If I simply double click on a single word or highlight the whole line ¿pasting into notepad works fine, but if I highlight multiple lines ..for example output for ¿ls ¿la¿ command ..it does not get copied into memory, hence I can¿t paste anything. Has anyone seen this?

thanks
Friday, June 8, 2007 6:05 PM - Support

Re: Copy/Paste functionality is not consistent

 
This problem may occur if you are trying to copy/paste UTF characters, becuase Xmanager does not support copy/paste for UTF characters yet.

If you are not using UTF encoding, please send us the following information:

1. Name and version of UNIX
2. Screenshot of the problem. (including dtterm and the copied text)

Thank you for your cooperation.

---
Technical Support
Saturday, June 9, 2007 2:52 AM - dynamox

Re: Re: Copy/Paste functionality is not consistent

 
How do i determine if it's UTF txt. I am experiencing this problem when i connect to AIX or Solaris. If you look in my screen shot you will see the text i am trying to highlite and paste into notepad. Nothing special but output from "ls -la"
Attachment dtterm.jpg (167 KB)  
Monday, June 11, 2007 5:50 PM - Support

Re: Re: Re: Copy/Paste functionality is not consistent

 
Thank you for the information. Please give us a few days to test the problem.

Meanwhile, please try using the en_US encoding instead, and let us know the result of it.

To open a dtterm in en_US encoding:
1. Start a dtterm as usual.
2. Set the LANG variable to en_US. To do this, in the dtterm window, type the following command:

setenv LANG en_US
or
export LANG=en_US

3. Start a new dtterm from the running dtterm.
4. Do "ls -al" and try copying and pasting the text.

We appreciate your cooperation.

FYI, you can check your encoding by typing "echo $LANG".

---
Support

Wednesday, June 13, 2007 9:05 PM - dynamox

Re: Re: Re: Re: Copy/Paste functionality is not consistent

 
still no luck, i put export LANG=en_US in my .profile. When i login and check "echo $LANG" i am seeing en_US, yet i am still experiencing this problem. If i use cygwin X server, i do not have this problem.

Thanks
Tuesday, June 26, 2007 10:06 AM - Support

Re: Re: Re: Re: Re: Copy/Paste functionality is not consistent

 
The problem has been fixed and the updated setup file is now available at:

/download/main.html

Thank you for using Xmanager.

---
Technical Support