Xmanager Forum

Xmanager CDE Fonts

Last post: Friday, March 23, 2007 7:05 PM by Support, 6 reply

Tuesday, March 20, 2007 5:49 AM - jwilgus

Xmanager CDE Fonts

We have X11Forwarding configured to conduct X traffic over SSH and Port 22. When attempting to log into CDE from windows machine to Solaris 10 server, I get the following errors (show reply messages is turned on) from the following command:

/usr/openwin/bin/xterm -ls -display $DISPLAY


xterm: unable to open font "-dt-interface user-medium-r-normal-s*utf*-*-*-*-*-*-*-*-*", trying "fixed" ....
font missing: KSC5601.1992-3 for Window
font missing: TIS620.2533-0 for Window
font missing: ISO8859-6 for Window
font missing: ISO8859-8 for Window
font missing: SUN.UNICODE.INDIA-0 for Window

Please advise what needs to be done on server or client to resolve this issue.

Thanks, Jeff
Tuesday, March 20, 2007 4:04 PM - Support

Re: Xmanager CDE Fonts

The problem occurs when Xstart cannot load UTF related resource required for your system language. In order to use xterm with the required resources fully loaded, please use Xbrowser instead. Or, to simply avoid this error, please change the LANG value to C for your user account only.

Hope this solves your problem.

Technical Support
Tuesday, March 20, 2007 10:56 PM - jwilgus

Re: Re: Xmanager CDE Fonts

Thanks so much for the reply.

If I need to change my language setting to "C", where do I do that? On the Xmanager side (Windows) or on my Solaris account on the server?

Please advise, thanks ...

Wednesday, March 21, 2007 9:19 AM - Wurm

Re: Re: Re: Xmanager CDE Fonts

Hello, this page (http://docs.sun.com/app/docs/doc/806-7492/6jgc4esii?a=view) will be a good place to find out how you can change your Lang setting for the solaris system. Usually, docs.sun.com is a good source to get the knowledge about solaris administration. Hope this helps.
Wednesday, March 21, 2007 11:12 AM - Support

Re: Re: Re: Xmanager CDE Fonts

To change your language setting on your Solaris account, add "setenv LANG C" or "export LANG=C" in your login script (.profile, .cshrc, .bash_profile, etc) according to your login shell.

Or, simply use the following command in Command box of Xstart:

For csh:
setenv LANG C; /usr/openwin/bin/xterm -ls -display $DISPLAY

For ksh or bash:
export LANG=C; /usr/openwin/bin/xterm -ls -display $DISPLAY

Technical Support
Thursday, March 22, 2007 4:41 AM - jwilgus

Re: Re: Xmanager CDE Fonts

I want to try the Xbrowser method. Xbrowser is defaulting to port 177. We have X11Forwarding set to yes so that X traffic is routed via SSH and Port 22. Can I merely change the Port to 22 and have the XDMCP functionality work as expected? Or ... do I really need to establish xterm via SSH from Xstart and then kick off Xsession from the xterm window?

Please advise ... Thanks again,

Friday, March 23, 2007 7:05 PM - Support

Re: Re: Re: Xmanager CDE Fonts

We have newly added the instruction for XDMCP Connection through SSH Tunneling into the Xshell Tutorial page available at:


If you have any problem on this instruction, please let us know.

Technical Support