Xmanager Forum

bad display name

Last post: Thursday, February 6, 2003 11:26 PM by jay jefferson, 2 reply

Thursday, February 6, 2003 6:13 AM - jay jefferson

bad display name

After trying to get xmanager working with XDMCP, and having no luck because I do not have a public IP and my linux box does not have a public IP either, I have attempted to try xstart. I can SSH into my machine fine using another SSH client, so I know SSH is running. When I run xstart however, this is the output:

( I removed my hostname and username but they are correct in the actual output )


Connected to :22.

Exchanging SSH version...Done.
Server: SSH-2.0-3.2.0 SSH Secure Shell (non-commercial).
Client: SSH-2.0-Xssh_1.0.
SSH2 is enabled.

Negotiating algorithms...
Initiating key exchange...Done.
Exchanging Diffie-Hellman KeyEx message...Done.
Waiting for new key message...Received.
Fingerprint: 1024 47:51:20:eb:20:71:5b:0d:bc:c8:11:75:aa:1f:3c:aa.Verifying host key...
Algorithm negotiation has been finished...
CS Cipher: 3des-cbc, SC Cipher: 3des-cbc
CS Compress: none, SC Compress: none
CS MAC: hmac-sha1, SC MAC: hmac-sha1

Trying to login as .
Trying password authentication...Done.

Requesting session channel...Done.

Requesting X11 forwarding...Done.

Executing remote command...Done.
/usr/X11R6/bin/xauth: (stdin):1:
bad display name "jay-mandrake:10.0" in "add" command


Any ideas? I have enabled X11Forwarding in the sshd2_config file. I have tried the following commands when trying to run xstart:

/usr/bin/X11/xterm -ls
/usr/bin/X11/xterm -ls -display $DISPLAY

Thursday, February 6, 2003 8:04 PM - Support

Re: bad display name

The problem might happen when the xauth can't convert "jay-mandrake" into an IP address, an error in DNS lookup table.

Please check the /etc/hosts file and there should be a line for "localhost": localhost.localdomain localhost

And check the sshd config file for the following option:

X11UseLocalhost yes

Then, restart the sshd server.

We hope this can help you.

Technical Support
Thursday, February 6, 2003 11:26 PM - jay jefferson

Re: Re: bad display name

When I tried putting this option in I got the following error on the restart of the sshd2 service:

[root@jay-mandrake ssh2]# service sshd2 start
Starting sshd2 in port 22: sshd2[8155]: WARNING: Unrecognized configuration parameter 'X11UseLocalhost'.
sshd2[8155]: WARNING: Failed to parse some variables from config file '/etc/ssh2/sshd2_config'.
sshd2[8155]: FATAL: Failed to read config file /etc/ssh2/sshd2_config

Any ideas? The line in the sshd2_config file looks like this:

X11UseLocalhost yes

The line wasn't in the file originally. I had to manually add it.