Xmanager Forum

"Software caused connetion abort" error

Last post: Friday, February 14, 2003 11:27 AM by Mike, 6 reply

Friday, January 31, 2003 10:31 AM - Mike

"Software caused connetion abort" error

I am using Openssh on my Linux machine. When I use Xstart to connect it get the error: Xssh Error: Software caused connection abort.

This is the message in the Remote execution result:

Exchanging SSH version...Done.
Server: SSH-2.0-OpenSSH_3.5p1.
Client: SSH-2.0-Xssh_1.0.
SSH2 is enabled.

Negotiating algorithms...
Initiating key exchange...Done.
Exchanging Diffie-Hellman KeyEx message...

What is going wrong?

Tuesday, February 4, 2003 11:57 PM - Support

Re: "Software caused connetion abort" error

The error is displayed when an ssh connection is closed by the server unexpectedly. This might happen due to a bug in Xstart or ssh server.

You can try our ssh client, Xshell, instead of Xstart. Xshell can be used as a front-end interface for Xmanager. Xshell is a normal ssh client, but you can run xterm or other X applications at the prompt and Xmanager is automatically launched when required. To download it, please visit at:


Please let us know whether the Xshell also fails or not. It would be very helpful for our future service.

Thanks for your cooperation.

Technical Support
Thursday, February 6, 2003 11:38 AM - Mike

Re: Re: "Software caused connetion abort" error

XShell gives me this error:

SSH protocol started.

Exchanging SSH version....
server: SSH-2.0-OpenSSH_3.5p1
client: SSH-2.0-Xshell_1.0.0
SSH2 enabled.

Negotiating algorithms...
key exchange: diffie-hellman-group1-sha1
No matching server host key algorithm found.
server: ssh-rsa
client: ssh-dss

Connection closed.
Thursday, February 6, 2003 6:03 PM - Support

Re: Re: Re: "Software caused connetion abort" error

The error occurs when a DSA key is not specified in the /etc/ssh/sshd_config file. Currently Xstart and Xshell support only a DSA encryption for host key authentication.

Multiple host keys are defined in the sshd_config file as following:

HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key

And restart the sshd server:

# /etc/rc.d/init.d/sshd restart

We hope this can help you.

Technical Support
Monday, February 10, 2003 3:18 AM

Re: Re: Re: Re: "Software caused connetion abort" error

Thanks for the help unfortunately I did what you said but I get the same error.

Tuesday, February 11, 2003 2:18 PM - Support

Re: Re: Re: Re: Re: "Software caused connetion abort" error

OpenSSH 3.5p1 is the newest version and most Linux doesn't comes with it. If you installed it manually, the installed directory will be /usr/local/etc/sshd_config. And the sshd will be /usr/local/sbin/sshd.

Please check HostKey value again in /usr/local/etc/sshd_config and also you should check if "ssh_host_rsa_key" and "ssh_host_dsa_key" files exist in /usr/local/etc directory. When those key files do not exist, you should make and install the sshd package again.

If the problem persists, please let us know the Linux name and version, how you installed the sshd and so on.

Thanks for your cooperation.

Technical Support
Friday, February 14, 2003 11:27 AM - Mike

Re: Re: Re: Re: Re: Re: "Software caused connetion abort" error

I am not sure what happened. I followed tyour advise from the previous message and it generated the "ssh_host_rsa_key" and "ssh_host_dsa_key" files. I restarted the server but it said they where not started. Yet, I could log in remotely.

After reading your last post I ran /etc/init.d/sshd zap and then ran /etc/init.d/sshd start. I got an [!!] but I do not have enough logging turned on because the log didn't say there was an error. Anyway, it worked this time! I have some more digging to do on what was going on there and why the server says it is stopped when clearly it is running.

BTW I am running Gentoo Linux.

Thanks for your help!