Xmanager Forum

difference in character representation

Last post: Wednesday, January 10, 2007 9:59 PM by Tom, 6 reply

 
Friday, January 5, 2007 10:53 PM - Tom

difference in character representation

 
I have the following problem:

when I connect to my Linux server via ssh, there is a difference in character representation between the original xterm, and a second xterm launched from the original. For example, I type '¿n', but when I delete the word, it is removed with only 2 deletes, although the word consists of 3 letters. So the two ¿s are deleted with only one delete. When I try the same test in the second xterm, it is deleted with 3 deletes. And there also other differences. I believe that the problems are caused by character encodings or fonts, but am unable to find the cause.
The locale on the Redhat is set to en_GB.UTF-8, and I have installed the additional ISO10646-1 Fonts (Latin Unicode Fonts).

Connection Method: Xstart (Part of XManager 2.0, build 0501)
OS: Redhat ES 3
Network configuration: directly in same LAN
Monday, January 8, 2007 1:57 PM - VK

Re: difference in character representation

 
Try the xterm command with the '-ls' option. It forces xterm to read the user's login scripts such as .login or .profile.

-VK
Monday, January 8, 2007 7:43 PM - Tom

Re: Re: difference in character representation

 
I already tried it with this option, but it does not make a difference.
Tuesday, January 9, 2007 4:12 PM - Support

Re: Re: Re: difference in character representation

 
To help solving your problem, please provide us the following:

- The 'env' command output for both Xterms

Thank you for your cooperation.

---
Technical Support
Wednesday, January 10, 2007 1:02 AM - Tom

Re: Re: Re: Re: difference in character representation

 
Output of env of first xterm:

HOSTNAME=picasso.pks.be
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
SSH_CLIENT=192.168.70.2 4785 22
INFORMIXDIR=/opt/informix
WINDOWID=4194320
USER=amcc
LD_LIBRARY_PATH=/opt/fourjs/fgl-3.54.2k/bin:/opt/informix/lib:/opt/informix/lib/c++:/opt/informix/lib/cli:/opt/informix/lib/client:/opt/informix/lib/dmi:/opt/informix/lib/esql:
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
AMCC_LIB=/opt/amcc/amcc-lib
PATH=/opt/fourjs/fgl-3.54.2k/bin:/opt/fourjs/fgl-3.54.2k/bin:/opt/informix/bin:/usr/kerberos/bin:/opt/informix/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/opt/amcc/amcc-lib/bin:/opt/amcc/amcc-lib/bin:/home/amcc/bin
MAIL=/var/spool/mail/amcc
INPUTRC=/etc/inputrc
PWD=/home/amcc
LANG=en_GB.UTF-8
LAMHELPFILE=/etc/lam/lam-helpfile
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
TEST=and
HOME=/home/amcc
SHLVL=2
LOGNAME=amcc
FGLGUI=1
SSH_CONNECTION=192.168.70.2 4785 192.168.46.14 22
LESSOPEN=|/usr/bin/lesspipe.sh %s
FGLDIR=/opt/fourjs/fgl-3.54.2k
DISPLAY=localhost:10.0
G_BROKEN_FILENAMES=1
_=/bin/env


Output of env in second xterm:

HOSTNAME=picasso.pks.be
SHELL=/bin/bash
TERM=xterm
HISTSIZE=1000
SSH_CLIENT=192.168.70.2 4785 22
INFORMIXDIR=/opt/informix
WINDOWID=8388624
USER=amcc
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
LD_LIBRARY_PATH=/opt/fourjs/fgl-3.54.2k/bin:/opt/informix/lib:/opt/informix/lib/c++:/opt/informix/lib/cli:/opt/informix/lib/client:/opt/informix/lib/dmi:/opt/informix/lib/esql:
AMCC_LIB=/opt/amcc/amcc-lib
MAIL=/var/spool/mail/amcc
PATH=/opt/informix/bin:/opt/fourjs/fgl-3.54.2k/bin:/opt/fourjs/fgl-3.54.2k/bin:/opt/informix/bin:/usr/kerberos/bin:/opt/informix/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/opt/amcc/amcc-lib/bin:/opt/amcc/amcc-lib/bin:/home/amcc/bin:/opt/amcc/amcc-lib/bin
PWD=/home/amcc
INPUTRC=/etc/inputrc
LANG=en_GB.UTF-8
LAMHELPFILE=/etc/lam/lam-helpfile
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
TEST=and
SHLVL=3
HOME=/home/amcc
LOGNAME=amcc
FGLGUI=1
SSH_CONNECTION=192.168.70.2 4785 192.168.46.14 22
LESSOPEN=|/usr/bin/lesspipe.sh %s
FGLDIR=/opt/fourjs/fgl-3.54.2k
DISPLAY=localhost:10.0
G_BROKEN_FILENAMES=1
_=/bin/env
Wednesday, January 10, 2007 3:54 PM - Support

Re: Re: Re: Re: Re: difference in character representation

 
At the time of starting Xterm, the language setting is important. To fix this problem, please follow the instruction below:

1. Open Xstart.
2. Select SSH in the Protocol list.
3. Click Setup.
RESULT: SSH Protocol Setup dialog box opens up.
4. Click the Options tab.
5. Select Allocated a pseudo terminal before executing a command.
6. Click OK to save the change.

Hope this solves your problem.

---
Technical Support
Wednesday, January 10, 2007 9:59 PM - Tom

Re: Re: Re: Re: Re: Re: difference in character representation

 
Yes, this solves my problem. Thank you.