Xmanager Forum

mkfontdir

Last post: Wednesday, September 20, 2006 5:44 PM by R.I.U.F., 11 reply

 
Friday, September 8, 2006 7:33 AM - Steve Jones

mkfontdir

 
Please be more specific on how to create and use a font directory (from FAQ):

To create and use a font directory:
Create a new directory under the following directory:
C:\Program Files\NetSarang\Xmanager2\Fonts

or

C:\Program Files\NetSarang\Xmanager Enterprise\Fonts

Copy new fonts to the new directory.
Run mkfntdir.exe on the new directory:
C:\Program Files\...\Fonts\NewFonts> ..\..\mkfntdir .


This last line does not work for me. I get this error that says something to this effect:

C:\Program is not a know command.

So, I assume that I need some kind of quotes or something on it, but the best I seem to be able to do is -overwrite- the mkfntdir.exe file.

I tried copying the file to my new font directory and ran it in there, to no avail (A little verbosity on the file wouldn't of killed any developers I am sure).

Please help.


Friday, September 8, 2006 10:39 AM - Paradigm

Re: mkfontdir

 
"C:\Program Files\...\Fonts\NewFonts>" is not part of the command. It is just the prompt sign.

Assuming you have already created the NewFonts folder, you should only type "..\..\mkfntdir" in the NewFonts directory (without the quotation marks).
Saturday, September 9, 2006 1:25 AM - Steve Jones

Re: Re: mkfontdir

 
Ok, I assume the point of this is to run the mkfntdir (actually Mkfntdir in the release) -in- the new font directory.

I did this by copying Mkfntdir -into- the directory and running it. It is a directory of 100 TrueType fonts. I assume it is supposed to create the FONTS.DIR file. However, it does not do this (or as far as I can tell anything).

To be very specific this is what I did:

1) create new dir under fonts, called it TrueType
2) copied fonts into this directory
3) copied Mkfntdir.exe into this directory
4) cd'd into TrueType directory
5) ran Mkfntdir.exe (simply typed: 'Mfntdir' at command line)
6) Nothing new is in directory.

Also, FWIW, the FAQ has a period '.' after the mkfntdir. I tried it with and without the period.

Please help. Thanks.
Saturday, September 9, 2006 2:21 AM - Propaganda

Re: Re: Re: mkfontdir

 
True type font is not supported in Xmanager. Maybe you should try using the font server instead.
Tuesday, September 12, 2006 6:28 AM - Steve Jones

Re: Re: Re: Re: mkfontdir

 
If I use the font server the XManager will display with TrueType fonts?

Please clarify.

Thanks.
Tuesday, September 12, 2006 3:39 PM - Propaganda

Re: Re: Re: Re: Re: mkfontdir

 
If the font server supports true type fonts, yes, Xmanager will display those fonts.


Thursday, September 14, 2006 3:15 AM - Steve Jones' IT

Re: Re: Re: Re: Re: Re: mkfontdir

 
It seems as though the fonts are working, but antialiasing is not. How can I get antialiasing to work so that my fonts look smooth?
Thursday, September 14, 2006 1:53 PM - platonic

Re: Re: Re: Re: Re: Re: Re: mkfontdir

 
Did you enable the anti-aliasing option in the desktop environment you are using? I am using Red Hat 9 with Gnome and anti-aliasing option is located in RedHat main menu icon(Fabulous Redhat icon in the bottom left corner!) > Preferences > Fonts > Detail.

Also, keep in mind that some applications do not support anti-aliasing.
Thursday, September 14, 2006 9:41 PM - Steve Jones' IT

Re: Re: Re: mkfontdir

 
Will setting that option take care of antialiasing on my client? I'm trying to connect to the Red Had font server from a Windows XP machine using Xmanager.
Friday, September 15, 2006 12:28 AM - platonic

Re: Re: Re: Re: mkfontdir

 
Antialiasing is managed on the remote host side. PC X server such as Xmanager simply displays it.

Wednesday, September 20, 2006 6:54 AM - Steve Jones' IT

Re: Re: Re: mkfontdir

 
Does XManager support antialiasing?
Wednesday, September 20, 2006 5:44 PM - R.I.U.F.

Re: Re: Re: mkfontdir

 
I seems someone else already answered your question, but anways...

Xmanager CAN and DOES display anti-aliasing. Antialiasing is set on the remote server side. So if antialiasing is not displayed correctly, it means that your server is not properly setup.

- R.I.U.F.