Xmanager Forum

Problems of launching X apps remotely to WinXP PCs

Last post: Wednesday, June 7, 2006 9:46 AM by Support, 5 reply

 
Sunday, June 4, 2006 5:31 AM - Eruisi

Problems of launching X apps remotely to WinXP PCs

 
I like Xmanager because it can display remote Linux X11 apps to my WinXP screen (even if the IP address is dynamic) and not requiring set the $DISPLAY enviroment but only one exception.

I have some WinXP clients with different IPs and one Linux machine (FC2.0). In my XShell session configuration, I did set the X11 Forwarding to "Forward X11 connections to Xmanager". On the Linux machine, /etc/ssh/sshd_config has set X11Forwarding option to "yes"

Everytime, I login Linux machine in XShell, type "xterm", then get the following response:
X connection to localhost:10.0 broken (explicit kill or server shutdown). The Xmanager does start everytime but now xterm window shows up.

If I set $DISPALY to my current WinXP IP, xterm can show up correctly. But this requires me to set DISPLAY everytime because I need to start X11 apps from different WinXP machines.

In fact I have another Linux machine with the same X11 configuration. This machine works well and doesn't require setting $DISPLAY.

The only different between these two Linux machines is perhaps the previous one has two network cards eth0 and eth1. I am wondering if this is the reason. If you know, please tell me how to correct it.

Thanks a lot!
Monday, June 5, 2006 11:18 AM - Brian Wilson

Re: Problems of launching X apps remotely to WinXP PCs

 
X11 forward for root privileged user is prohibited in some UNIX/Linux machines. Also, if you switch to a different user after login, this may cause MIT-MAGIC-COOKIE-1 miss match and stop you from running xterm. Try logging in to a normal user account and running xterm.

Multiple network cards rarely have anything to do with this type of problem.

Hope this helps.
Monday, June 5, 2006 11:37 AM - Eruisi

Problems of launching X apps remotely to WinXP PCs

 
I always use normal user to login.
I guess the tunnel has been triggled since the x server on my WinXP starts but the tunnel is cut by the Linux machine for some reasons I don't know.

Monday, June 5, 2006 3:34 PM - Support

Re: Problems of launching X apps remotely to WinXP PCs

 
We have tested this problem on our Fedora Core 2 server but the problem could not be duplicated.

First, let¿s test where this problem is rooted. Try running different X applications. For example, you can execute ¿gnome-terminal¿ or ¿konsole.¿

Second, let¿s see if there is problem in your account setting. Using a different user account, try opening a xterm window.

Finally, please send us the following information. We will do our best to return you a solution as soon as possible.

1. Name/version of SSH server and xterm
2. Can you run gnome-terminal or konsole?
3. Can you start xterm using a different account?

Thank you for your cooperation.

---
Technical Support
Tuesday, June 6, 2006 1:19 PM - Eruisi

Problems of launching X apps remotely to WinXP PCs

 
I figure it out.

The reason is the home directory of this account on Linux machine is a mounted NFS volume. If I use a local file volume, X apps can be launch.

Thanks for you advices.
One of the best customer services I have ever seen.
Wednesday, June 7, 2006 9:46 AM - Support

Re: Problems of launching X apps remotely to WinXP PCs

 
Thank you for your kindness.

We will do our best to continue providing you with the best service possible.

Have a nice day.

---
Technical Support