Xmanager Forum

Xmanager - Broadcast -> Broadcast Chooser List is empty

Last post: Tuesday, April 11, 2006 6:10 PM by Support, 5 reply

 
Thursday, April 6, 2006 2:57 PM - Ken

Xmanager - Broadcast -> Broadcast Chooser List is empty

 
Hi,

I am trying to connect to remote Servers (HP, Solaris, AIX Linux, doesn't matter) at my workplace from my machine at home. My home machine connects via a VPN, so is on a different subnet (IP) to the servers. I am using Xmanager 2.0 (Build 0010).

When I do this from my WinXP machine at work, I get a list of servers, I then double click on one and get the login screen (I think this is called CDE ??). Once logged in I get (options set to single window) a single window full GUI desktop environment which I can start various terminals, run gui debuggers etc. etc. (please see attchment XmanagerDesktop.jpg to see what I am describing).

Since I cannot get any servers in the "Broadcast Chooser" list (I think someone mentioned this may be because I am not on the same subnet as the servers ??), I cannot seem to get access to a gui desktop so I can run GUI debuggers etc.. I can get basic "telnet style" single windows up but that doesn't allow me to run gui debuggers or multiple consoles withing a single "session" as such.
This access to a single window desktop is what I really want so am hoping someone can tell me how to achieve this ?

Thanks
Ken
Thursday, April 6, 2006 4:08 PM - Support

Re: Xmanager - Broadcast -> Broadcast Chooser List is empty

 
If your PC is located in a different subnet with UNIX machines, making XDMCP connection can be very difficult to setup and also it requires netowrk admin privilage.

However, you can still start CDE or Gnome terminal from a terminal window. Follow the instruction below:

1. Start xterm or dtterm.
2. Type the following command accordingly.

For CDE: /usr/dt/bin/Xsession &
For Gnome: /usr/bin/gnome-session &

This will launch CDE or Gnome.

Please let us know if we can be of further assistance.

Monday, April 10, 2006 2:55 PM - Ken Gusse

Re: Re: Xmanager - Broadcast -> Broadcast Chooser List is empty

 
Thanks very much for that !

Unfortunately I must have been kidding myself when I said that I could get an XStart session up and running. That must have been when I tried from Japan but still on the companies network (NOT via a VPN).

From home I just get the "cannot open display xxx.xxx.xxx.xxx:y

I also tried manually setting the display number from 0 through to 5 with a similar result. It also didn't seem to matter which connection protocol I used either.

Any ideas ?
Monday, April 10, 2006 5:33 PM - Support

Re: Re: Re: Xmanager - Broadcast -> Broadcast Chooser List is empty

 
If you are using a protocol other than SSH, communication may have been blocked by firewall or router. Please try using SSH with the following command.

For HP: /usr/X11R6/bin/xterm -ls -display $DISPLAY
For Linux: /usr/dt/bin/dtterm -ls -display $DISPLAY

If your problem persists, please send us the following information:

1. IP addresses of the server and your PC.
2. Screenshot of any error message.

Hope this fixes your problem.
Tuesday, April 11, 2006 7:45 AM - Ken Gusse

Re: Re: Re: Re: Xmanager - Broadcast -> Broadcast Chooser List is empty

 
Hi,

No luck. I am not a Unix admin, so sorry for running around in circles. The command for HP didn't exist so I tried the normal xterm (maybe this is a problem ?).

The server IP is 137.172.75.24, my ip is 137.172.75.61 (I think ? Not really sure how this VPN stuff works. ipconfig on my machine just gives me my local home network IP (10.1.1.40), I found this address in the VPN software event log).

Below is the output from the reply messages window:

[08:14:22] Connecting to '137.172.75.24'...
[08:14:23] Connected.
[08:14:23] Version exchange initiated...
[08:14:23] server: SSH-2.0-OpenSSH_3.6.1p2
[08:14:23] client: SSH-2.0-libssh_1.2.1697 NetSarang Computer, Inc.
[08:14:23] SSH2 is selected.
[08:14:23] Algorithm negotiation initiated...
[08:14:23] key exchange: diffie-hellman-group1-sha1
[08:14:23] host key: ssh-dss
[08:14:23] outgoing encryption: aes128-cbc
[08:14:23] incoming encryption: aes128-cbc
[08:14:23] outgoing mac: hmac-sha1
[08:14:23] incoming mac: hmac-sha1
[08:14:23] outgoing compression: none
[08:14:23] incoming compression: none
[08:14:23] Host authentication initiated...
[08:14:23] Hostkey fingerprint:
[08:14:23] ssh-dsa 1024 68:b8:5b:ab:ce:64:d7:56:20:e2:7c:1a:b7:fd:78:d1
[08:14:23] Accepted. Verifying host key...
[08:14:23] Verified.
[08:14:23] User authentication initiated...
[08:14:23] Sent user name 'keng'.
[08:14:23] Sent password.
[08:14:23] Access granted.
[08:14:23] Sent X11 forwarding request...
[08:14:23] Succeeded.
[08:14:23] Sent the command line.
[08:14:23] /usr/bin/X11/xterm -ls -display $DISPLAY
[08:14:23] Start timer (TIMER_SHUTDOWN, 180).
X connection to 137.172.75.24:10.0 broken (explicit kill or server shutdown).
[08:14:57] Connection closed.
[08:17:00] Xmanager has terminated.

[08:17:23] Stop timer (TIMER_SHUTDOWN).

An error message appeared saying "The server sent a disconnect packet. Recieved oclose for nonexistent channel 0. (code: 3777745)
Tuesday, April 11, 2006 6:10 PM - Support

Re: Re: Re: Re: Re: Xmanager - Broadcast -> Broadcast Chooser List is empty

 
It seems like your login script (.profile, .cshrc, .bashrc etc) is manually assigning the DISPLAY value. SSH protocol automatically configures the DISPLAY variable and there is no need to set it up manually. Remove the following line from the login script that starts with:

export DISPLAY=137.172.75.24

After this is done, to start CDE or Gnome terminal from a terminal window, follow the instruction below:

1. Start xterm or dtterm.
2. Type the following command accordingly.

For CDE: /usr/dt/bin/Xsession &
For Gnome: /usr/bin/gnome-session &

This will launch CDE or Gnome.

Hope this solves your problem.