Xmanager Forum

viewing man pages on an xterm (Red Hat 8.0)

Last post: Tuesday, January 28, 2003 9:54 AM by Hojae Lee, 9 reply

 
Friday, November 15, 2002 8:52 AM - Waqar Mohsin

viewing man pages on an xterm (Red Hat 8.0)

 
Hi,

Red Hat 8.0 man pages and support color and bold type faces. When I start a new xterm using XStart and view a man page, certain characters are displayed imporeperly (eg, bold spaces become 'a' with a cap).

However, when I launch a new xterm by typing 'xterm &' on the current xterm, the problem goes away, and man pages are displayed with proper characters and spacing on this new xterm.

Could you please advise ?

Waqar
Friday, November 15, 2002 1:38 PM - Support

Re: viewing man pages on an xterm (Red Hat 8.0)

 
Please remove "-ls" option in the Command box of Xstart. The "-ls" option processes login shell scripts and might cause such a problem.

----
Technical Support
Monday, December 30, 2002 1:30 AM - Steve McMillan

Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
I have exactly the same problem and removing "-ls" from the initialisation doesnt work for me.

Running midnight commander in an xterm displays block characters and "a"s with "^"s over them instead of horizontal and vertical lines.

Running the xterm from within an xterm seems to solve the problem... as per the originating append.

I have exactly the same configuration in Redhat 7.2 and everything works fine. (I access both 8.0 and 7.2 boxes from the same machine)

Interestingly when I access the Rehat 8.0 box backspace stopped working in xterms and I had to put "NoSymbol" in to shifted backspace to get it to work.

Any help much appreciated.

Steve
Monday, December 30, 2002 5:07 PM - Support

Re: Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
The problem might occur due to a terminal type setting in your login script. If there is a line which configures the terminal type explicitly, please try to remove it.

If the problem persists, please give us more information on:

- Connection protocol in Xstart (TELNET, REXEC, etc.)
- The output messages of "stty -a" command at the xterm prompt.
- Your shell type (csh, bash, etc.)
- Login script files (.profile, .login, .cshrc, .bash_profile, etc.)

Thanks for your cooperation.

----
Technical Support
Thursday, January 23, 2003 4:48 AM - Robert Levas

Re: Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
I have exactly the same situation (RH7.2 and RH8.0) and problems and would love to hear a solution.

Rob
Thursday, January 23, 2003 1:54 PM - Support

Re: Re: Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
Please check your locale settings by:

$ locale
LANG=en_US.UTF-8
...

If the locale is en_US.UTF-8 or en_US.utf8, the man page can be misformatted. In this case, you can add a line in your shell script file (e.g.: .bashrc, .login, .profile).

For bash (in .bashrc):
LANG=C
export LANG

For csh (in .login):
setenv LANG C

If the problem persists, let us know the result of "locale" command at the xterm prompt.

----
Technical Support
Thursday, January 23, 2003 9:58 PM - Robert Levas

Re: Re: Re: Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
That worked... originally $LANG was set to en_US.UTF-8. If set it to en_US or C it works! :) I know this isn't your department, but do you know how to set the locale for the system on RH8?

Rob
Thursday, January 23, 2003 10:06 PM - Robert Levas

Re: Re: Re: Re: Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
Sorry to answer my own question.. but FYI...

I edited the /etc/sysconfig/i18n file and set my LANG variable to en_US. Now my problem is solved.

Thanks,
Rob
Tuesday, January 28, 2003 3:30 AM - Steve

Re: Re: Re: Re: Re: viewing man pages on an xterm (Red Hat 8.0)

 
My Environment variable LANG was set to en_GB.UTF-8.

Setting it to C solved the problem. Just need to find where the default shell environment variable setting happens.

Thanks.
Tuesday, January 28, 2003 9:54 AM - Hojae Lee

You can add environmental settings to login script.

 
If you want to change global LANG environmental setting, see below. (It's effective for all users.)

1. Open "/etc/sysconfig/i18n" with something like vi.
2. edit LANG option. For example,
LANG="en_US"

Or if you want to change LANG environmental setting only for one user, see below.

1. Open "$HOME/.bash_profile" with something like vi.
2. Add environmental settings. For example,
LANG=c
export LANG

:)