Xmanager Forum

How to enable GLX?

Last post: Monday, January 16, 2006 7:57 PM by Sephiros, 3 reply

 
Saturday, January 7, 2006 8:34 PM - MaxOut

How to enable GLX?

 
I am using Xmanager Enterprise Edition with GLX support declared.
I am connecting through Xbrowser (XDCMP) to my debian box. Both my client (WinXP) and server PCs are capable to OpenGL.
OpenGL application, tuxracer as an example, locally runs at server host smoothly - so, glx works locally.
But there are huge lags when i try to run tuxracer trough Xbrowser, glx doesn't works.

The question is: how to set up all the things to support GLX in XManager Enterprise?

Here's info on glx from Xmanager connection:
maxout@gate [~]$ glxinfo
name of display: 192.168.1.1:0.0
display: 192.168.1.1:0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
GLX_ARB_get_proc_address, GLX_EXT_import_context, GLX_EXT_visual_info,
GLX_EXT_visual_rating
OpenGL vendor string: Generic
OpenGL renderer string: Generic
OpenGL version string: 1.2.1 Generic
OpenGL extensions:
GL_ARB_multitexture, GL_ARB_transpose_matrix, GL_EXT_abgr,
GL_EXT_draw_range_elements, GL_EXT_multi_draw_arrays,
GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x20 8 pc 0 8 0 c y . 0 0 0 0 0 32 8 0 0 0 0 0 0 None
0x21 8 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
0x22 8 gs 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
0x23 8 sc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
0x24 8 sg 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
0x25 24 tc 0 24 0 r y . 8 8 8 0 0 32 8 16 16 16 16 0 0 None
maxout@gate [~]$

Xmanager log is attached.
Attachment X0.log (3.3 KB)  
Monday, January 9, 2006 5:57 PM - Sephiros

Re: How to enable GLX?

 
Your glxinfo shows that glx is functioning normally. In my experience, Tuxracer lags even from the console environment. Sometimes, glx applications require high system resources and can cause application slow down. But moreover, you may have insufficient bandwidth. If it is possible, you should test it within the same network environment.

If your problem continues, you should post the name and version of the remote host and the application.
Saturday, January 14, 2006 6:08 PM - MaxOut

Re: Re: How to enable GLX?

 
If your problem continues, you should post the name and version of the remote host and the application.

glxgears application runs on remote server's console at 450 FPS
And it runs through Xmanager at 100 FPS
This is a huge slow-down :(
Both client and server hosts are OpenGL-capable, and moreover, client host is much faster (both on CPU and Video).
Client and server stands in one network environment: both connected by patch-cords to single swithing hub.

What do you mean by "name and version of the remote host"?

I have a fresh Debian Etch, here is all installed packages related to X server:
x-window-system-core 6.8.2.dfsg.1-11
x11-common 6.8.2.dfsg.1-11
xlibmesa-dri 6.8.2.dfsg.1-11
xlibmesa-gl 6.8.2.dfsg.1-11
xlibs 6.8.2.dfsg.1-11
xserver-common 6.8.2.dfsg.1-11
xserver-xorg 6.8.2.dfsg.1-11
Monday, January 16, 2006 7:57 PM - Sephiros

Re: Re: Re: How to enable GLX?

 
As I tested in my machines (Windows XP with SP2 and Red Hat 9.0) and I get around 340 FPS in console and 180 FPS with Xmanager which is I think it¿s pretty close considering it is happening over a network. My machines are connected through10Mb hub.

If you are running heavy programs on your PC, you may get low FPS rate.

Try setting the Backing Store option to when mapped. You can find this option at Xconfig > Default Profile > Advanced tab > Backing Store.

Also, check your switching hub, and see if it is doing anything than may reduce the performance.

- Sephiros