Xmanager Forum

Trouble installing new fonts

Last post: Thursday, August 19, 2004 5:21 PM by Support, 8 reply

 
Thursday, November 7, 2002 7:06 AM - James Avery

Trouble installing new fonts

 
Hi,

I'm using xmanager to run Mathematica remotely, or trying to. Mathematica's front end relies heavily on several special fonts, which are downloadable from Wolfram Research both as Type1 and PCF.

Running any Unix (Irix, BSD or linux), these work fine. However, I am unable to get Xmanager on Win2k to acknowledge the existance of the fonts _at all_. (following the directions in the Xmanager Help)

The attached fonts.dir shows that, for example,

wri-Math1Mono-medium-r-normal-*-*-120-75-75-*-*-*-*

should be present, but it is not found, nor is a fall-back font found.

My questions are:

- Is there a way similar to xlsfonts of seeing which fonts are available to Xmanager?
- What can typically go wrong when installing new fonts?
- Is this a known problem?

I've spent several hours fiddling back and forth with the Type1, .pcf and .pcz fonts available, but with no discernable difference in behaviour from Xmanager.

Thanks in advance
Attachment fonts.dir ()  
Thursday, November 7, 2002 10:09 AM - Support

Re: Trouble installing new fonts

 
The font name "wri-Math1Mono-medium-r-normal-*-*-120-75-75-*-*-*-*" is incorrect becuase it omits a preceding dash('-') in the name. It is a bug of Mathematica configuration.

You can solve the font problem by turning off the "Automatic Font Substitution" option in the Xconfig.

Also, you can list all fonts registered in Xmanager just by running xlsfonts in the xterm on Xmanager.

We hope this can help you.

----
Technical Support
Friday, November 8, 2002 2:57 AM - James Avery

Re: Re: Trouble installing new fonts

 
I'm sorry, I of course miscopied the fontname. The required resource has a leading dash, as can be verified from the systrace:

http://www.uptimecompany.com/staff/avery/STRACE

searching om "-wri-math1mono-medium-".

I'll try xlsfonts when I next have access to the windows machine; In the mean time: Has anyone successfully used mathematica remotely under Xmanager/win2k?

Thanks in advance.

(As a side node: I did turn off font substitution (actually every possible combination of configurations in Xconfig fonts was tried), but this just results in program termination when no fonts are found)
Friday, November 8, 2002 4:47 PM - Support

Re: Re: Re: Trouble installing new fonts

 
A font pack of Mathematica is available at:

http://download.conux.com/files/fonts/mathematica.exe

You can install it into Xmanager by running the file above on your Windows PC.

We've tested Mathematica with the font pack and worked well with Xmanager.

We would appreciate your feedback.

----
Technical Support
Monday, November 11, 2002 4:30 AM - James Avery

Re: Re: Re: Re: Trouble installing new fonts

 
Thank you!

Your font pack worked immediately.

May I suggest that you link to it from the web page?

Alternatively, you may want to notify support@woldfram.com - the packages at

http://support.wolfram.com/mathematica/systems/unix/interface/

were impossible to get to work, even after fiddling for several hours several hours. They already have specific directions for the "Exceed" windows X server, and this would save people trying to use mathematica with Xmanager a lot of time and grief! :)

Thank's very much for the help!
Friday, August 13, 2004 10:09 AM - Chris

Re: Re: Re: Re: Trouble installing new fonts

 
Hi,

Is downloading the font pack from the link

http://download.conux.com/files/fonts/mathematica.exe

and installing it all I have to do, or are there many other small things I have to do as well?

I'm trying to use Mathematica 5 remotely on my laptop (WinXP Pro). I've run "mathematica.exe" on my machine and there is a mathematica font folder under Xmanager font directory. But, I still get the following font error message:

"Unable to find font with family Mathematica1, weight Plain, slant Plain, and size 12. Substituting Courier"

I'd appreciate if you could list all other settings (such as, de-selecting "automatic font substitution" if it's required, or downloading other fonts). Perhaps, connecting through SSH causes the headache? I'm just clueless.

Thank you very much.
Friday, August 13, 2004 2:51 PM - Support

Re: Re: Re: Re: Re: Trouble installing new fonts

 
If you are using Xmanager 2.0, download the following font pack:

http://download.xmanager.com/files/fonts2/mathematica.exe

For all font packs for v2.0, please visit at:

/download/download.html

----
Technical Support
Thursday, August 19, 2004 6:55 AM - Chris

Re: Re: Re: Re: Re: Re: Trouble installing new fonts

 
Even after installing font pack for Xmananger 2.0 and other font packs, I still get the error message saying, "font family mathematica1, ... missing."

I've checked the font directory under properties and there is mathematica folder, but no "mathematica1" font family.

What should I do at this point?

Thanks.
--------------------

If you are using Xmanager 2.0, download the following font pack:

http://download.xmanager.com/files/fonts2/mathematica.exe

For all font packs for v2.0, please visit at:

/download/download.html

----
Technical Support
Thursday, August 19, 2004 5:21 PM - Support

Re: Re: Re: Re: Re: Re: Re: Trouble installing new fonts

 
We have updated the mathematica font pack for the latest Mathematica. Please try the font pack again at:
http://download.xmanager.com/files/fonts2/mathematica.exe

Hope this helps you.

----
Technical Support