Xmanager Forum

SSH User Authentication Failed

Last post: Wednesday, December 14, 2005 10:29 AM by Kay, 9 reply

 
Sunday, December 11, 2005 5:34 PM - Mahdi Bashiri

SSH User Authentication Failed

 
Hi
I have been download xmanager to use to many unix base server ( sco unixware 7.1.1 , aix 5100-09 , solaris 9,10 ) .i have been create session with ssh conection and when i want to connect to session , iahve got ssh user authenticaion fail and prompt to enter password ,i entered correct password but then prompt again to enter password .
please let me know where is the probelm amd how can i fix them

Regards,
Mahdi Bashiri
Monday, December 12, 2005 3:10 PM - Support

Re: SSH User Authentication Failed

 
Depending on the SSH server settings, your servers may not allow root user from remote login. Please check your SSH server settings.

If your problem still persists, please send us the following information:
  1. everything in the Xrcmd: Reply Messages dialog box.
    To do this, select the Show reply messages option on the main Xstart window, and keep the dialog box open until the X application exits abruptly.

  2. Plese describe your problem in more detail.
Monday, December 12, 2005 4:50 PM - Mahdi Bashiri

Re: Re: SSH User Authentication Failed

 
Thanks for your mail.
i can login remotly to server with root user via ssh .

i send you Xrcmd output:

[11:21:47] Connecting to '192.168.168.23'...
[11:21:47] Connected.
[11:21:47] Version exchange initiated...
[11:21:47] server: SSH-2.0-5.0.0.844 SSH Tectia Server
[11:21:47] client: SSH-2.0-libssh_1.3.3.0 2169 NetSarang Computer, Inc.
[11:21:47] SSH2 is selected.
[11:21:47] Algorithm negotiation initiated...
[11:21:47] key exchange: diffie-hellman-group1-sha1
[11:21:47] host key: ssh-rsa
[11:21:47] outgoing encryption: aes128-cbc
[11:21:47] incoming encryption: aes128-cbc
[11:21:47] outgoing mac: hmac-sha1
[11:21:47] incoming mac: hmac-sha1
[11:21:47] outgoing compression: none
[11:21:47] incoming compression: none
[11:21:47] Host authentication initiated...
[11:21:47] Hostkey fingerprint:
[11:21:47] ssh-rsa 1536 39:10:29:d9:20:f1:3d:f8:61:32:40:f5:9c:ab:95:38
[11:21:47] Accepted. Verifying host key...
[11:21:47] Verified.
[11:21:47] User authentication initiated...
[11:21:47] Sent user name 'root'.
[11:21:47] Sent password.
[11:21:51] Canceled.

please let me know how can i fix it
Monday, December 12, 2005 6:07 PM - Memento

Re: Re: Re: SSH User Authentication Failed

 
Your problem occurs when the root user is not allowed to login. Tectia, as far as I know, disables root login by defaut. Check out the following page:

http://www.ssh.net/support/documentation/online/ssh/adminguide/40/Configuring_Root_Logins.html
Tuesday, December 13, 2005 3:30 PM - mahdi bashiri

Re: Re: Re: Re: SSH User Authentication Failed

 
Hi
i do not think so about root login , becuase i can not use xbrowser with another user , while i can ssh with root or all of user in aix box from command prompt on windows xp

please let me know more
Mahdi Bashiri
Tuesday, December 13, 2005 5:29 PM - Support

Re: Re: Re: Re: Re: SSH User Authentication Failed

 
Xbrowser and SSH uses two different protocol and cannot be compared.

This problem occurs when the server preventing root user from logging in. You should contact your system administrator to reconfigure the SSH server and restart it when done.

However, logging into a root user account is not recommended for its security vulnerability issues. We recommend you to login as a normal user, and then switch to a root user.

Thank you for using Xmanager.

---
Techincal Support
Tuesday, December 13, 2005 9:20 PM - Mahdi Bashiri

Re: Re: Re: Re: Re: Re: SSH User Authentication Failed

 
I do not think so , because i can login with root user via comand prompt on windows xp cmd line

please let me know more
Wednesday, December 14, 2005 1:26 AM - Andrew

Re: Re: Re: Re: Re: Re: Re: SSH User Authentication Failed

 
I don't think you logged in to the server using the SSH protocol because Windows cmd line doesn't support SSH protocol. It is hard to imagine what your problem is from your postings. At first, you said you cannot login to the root account, and now you can? And what's it got to do with Xbrowser?

I really recommend you to describe your problem in more detail.

Do these:

  1. Describe what you've done in the cmd window. (Copy everything in the cmd window and include it in your next posting)
  2. Attach screenshots of your problem. (include Xrcmd: reply message and the Xstart window)
Wednesday, December 14, 2005 4:52 PM - Mahdi Bashiri

Re: Re: Re: Re: Re: Re: Re: Re: SSH User Authentication Failed

 
Hi
I use putty program to ssh to all of existing servers .
and xrcmd message if aix 5.1 os is:

11:24:49] Connecting to '192.168.168.23'...
[11:24:49] Connected.
[11:24:49] Version exchange initiated...
[11:24:49] server: SSH-2.0-5.0.0.844 SSH Tectia Server
[11:24:49] client: SSH-2.0-libssh_1.3.3.0 2169 NetSarang Computer, Inc.
[11:24:49] SSH2 is selected.
[11:24:49] Algorithm negotiation initiated...
[11:24:49] key exchange: diffie-hellman-group1-sha1
[11:24:49] host key: ssh-rsa
[11:24:49] outgoing encryption: aes128-cbc
[11:24:49] incoming encryption: aes128-cbc
[11:24:49] outgoing mac: hmac-sha1
[11:24:49] incoming mac: hmac-sha1
[11:24:49] outgoing compression: none
[11:24:49] incoming compression: none
[11:24:49] Host authentication initiated...
[11:24:49] Hostkey fingerprint:
[11:24:49] ssh-rsa 1536 39:10:29:d9:20:f1:3d:f8:61:32:40:f5:9c:ab:95:38
[11:24:49] Accepted. Verifying host key...
[11:24:49] Verified.
[11:24:49] User authentication initiated...
[11:24:49] Sent user name 'root'.
[11:24:49] Sent password.
[11:24:53] Canceled.


and in another server ( aix 5.1 ):
[11:26:44] Connecting to '192.168.168.21'...
[11:26:44] Connected.
[11:26:44] Version exchange initiated...
[11:26:44] server: SSH-2.0-5.0.0.844 SSH Tectia Server
[11:26:44] client: SSH-2.0-libssh_1.3.3.0 2169 NetSarang Computer, Inc.
[11:26:44] SSH2 is selected.
[11:26:44] Algorithm negotiation initiated...
[11:26:44] key exchange: diffie-hellman-group1-sha1
[11:26:44] host key: ssh-rsa
[11:26:44] outgoing encryption: aes128-cbc
[11:26:44] incoming encryption: aes128-cbc
[11:26:44] outgoing mac: hmac-sha1
[11:26:44] incoming mac: hmac-sha1
[11:26:44] outgoing compression: none
[11:26:44] incoming compression: none
[11:26:44] Host authentication initiated...
[11:26:44] Hostkey fingerprint:
[11:26:44] ssh-rsa 1536 c1:10:d0:0e:a8:df:eb:08:d1:4d:2e:79:e5:99:4c:25
[11:26:44] Accepted. Verifying host key...
[11:26:44] Verified.
[11:26:44] User authentication initiated...
[11:26:44] Sent user name 'root'.
[11:26:44] Sent password.
[11:26:44] Access granted.
[11:26:44] Sent X11 forwarding request...
[11:26:44] Succeeded.
[11:26:44] Sent the command line.
[11:26:44]
[11:26:44] Start timer (TIMER_SHUTDOWN, 180).
[11:26:45] XLT: GOT EOF [0]
[11:26:45] XLT: GOT CLOSE [0]


thanks ,and i would like to know more

bashiri
Wednesday, December 14, 2005 10:29 AM - Kay

Re: Re: Re: Re: Re: Re: Re: SSH User Authentication Failed

 
I think you should select a "TELNET" protocol in the Xshell Session Properties dialog box.