Xmanager Forum

issue Xmanager 2.0 connect to redhat 9.0

Last post: Tuesday, October 11, 2005 2:03 PM by Support, 11 reply

 
Thursday, September 29, 2005 12:29 PM - Tonny Liu

issue Xmanager 2.0 connect to redhat 9.0

 
I updated all need files in redhat9, just as the FAQ forum said, and installed XManager 2.0, but when connected to redhat, echoes "cannot connect to xxx.xxx.xxx.xxx", anyone can help? thanks
Tonny
Thursday, September 29, 2005 3:37 PM - Andrew

Re: issue Xmanager 2.0 connect to redhat 9.0

 
From your error message, I am assuming you are using Xstart.

Make sure to run the connection daemons such as sshd or telnet server before attempting to make connection.

For your information, in Red Hat 9, telnet is disabled by default. Try using SSH instead. It is much secure and feature packed!

If you are using Xmanager, make sure to allow incoming TCP 6000~6010 ports.


Thursday, September 29, 2005 10:54 PM - Tonny

Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
but I am already use ntsysv start the telnet server, and even tried SSH, but still cannot connect to server, and of course TCP 6000 is under waiting, any suggestion? thx
Attachment scrshot.jpg (581 KB)  
Friday, September 30, 2005 2:13 PM - Paris

Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
Hello there~

First, check the firewall settings of the remote server. Telnet (23) and SSH ports (22) should be allowed.

And last time I checked, ntsysv does not start telnet automatically. After checking telnet and SSH entries in ntsysv, you should restart the xinetd service.

You can restart xinetd with the following command:

$ su -
password:

# service xinetd restart

Also, see if your server is reachable by running the following command in the cmd window.

C:> telnet $IPADDRESS

If it is not reachable, your server is not ready to accept telnet connection.

*You can open the cmd window by clicking Start, Run, and then typing cmd.


Friday, October 7, 2005 12:28 AM - Tonny

Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
thx, the root reason is the system security config, now it is ok. but I can only telnet to the host through Xmanager, when I use startx cmd, it just show the result on the host screen, not on my local pc, and when I use xbrowser, it just echoes XDMCP connection failed, try again? what shall I do? telnet is ok, ssh is ok too. already use export DISPLAY=IPADDRESS:0.0, but problem exists. can you help? thx
Friday, October 7, 2005 2:10 PM - Support

Re: Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
startx command is for console only. To use the gnome environment, please use 'gnome-session' command instead.

Also, there is no need to assign the DISPLAY variable. Please comment out the export DISPLAY=IPADDRESS:0.0 line and try again.

Since Xmanager is a server program, connection must be made back to your PC. If your remote server and PC are in a different network, TCP 6000~6010 ports may be blocked by routers or firewalls. Please allow TCP 6000~6010 ports towards your PC direction.

If your problem persists, please send us the Xmanager log file. It is located in the following directory:
C:\Documents and Settings\%USER%\Application Data\NetSarang\Xmanager\2\Log\*.log

Please let us know if we can be of further assistance.
Friday, October 7, 2005 3:50 PM - Tonny

Re: Re: Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
thanks, man, gnome-session works well, that is one method to start xwindows, any other method to start xwindows from remote pc? for example,xbrowser, I can find my linux server in xbrowser,but when I click the icon,it echoes XDMCP connection failed, try again?my remote pc and linux server in same network.
Friday, October 7, 2005 6:03 PM - Support

Re: Re: Re: Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
XDMCP connection may fail when:

1. Firewall is blocking the TCP ports that Xmanager uses. Please allow incoming TCP 6000~6010 ports on your PC. This may include the default Windows firewall and any kind of 3rd party firewalls.

2. DNS Your problem may be caused by an invalid name-to-ip or ip-to-name entry for your PC. Try adding your PC's IP address to /etc/hosts file as following:

192.168.1.198 PC_NAME

If your problem persists, please send us the following information:

1. Xmanager log file. It is located in the following directory:

C:\Documents and Settings\%USER%\Application Data\NetSarang\Xmanager\2\Log\*.log

2. Descripton of your network environment

Hope this solves your problem.
Monday, October 10, 2005 5:04 PM - Tonny Liu

Re: Re: Re: Re: Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
thanks for your suggestion, it doesnot work now, please find the file you need, our envoironment is as following:
server: redhat9
laptop:windows XP SP2
server and PC in same ethernet. thx
Attachment logfile.zip (7.3 KB)  
Monday, October 10, 2005 6:18 PM - Support

Re: Re: Re: Re: Re: Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
Your log messages show that you have multiple IPs assigned to your PC. In this case, you may need to assign an IP address for Xmanager manually. Please follow the instruction below:

1. Start Xbrowser.
2. Right click on the XDMCP session file and select Properties.
3. In the XDMCP area, select 172.16.101.38 (or select an IP address that is in the same network with the remote host.)
4. Click OK.

Also, please check any firewall, including the Windows XP firewall, located between your PC and the remote machine. TCP 6000~6010 ports must be reachable by the remote host.
Tuesday, October 11, 2005 10:29 AM - Tonny

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
thx for your reply, but it seems still cannot work, the TCP 6000 port is open in PC and remote linux server, and select exactly as you suggested, not sure the reason.
Tuesday, October 11, 2005 2:03 PM - Support

Re: Re: Re: issue Xmanager 2.0 connect to redhat 9.0

 
If your can connect to the remote host with SSH and run gnome-session, it means Xmanager is functioning properly. Only problem that still remains seems to be related to your network environment. Since every corporate has different network configuration, this matter beyond our scope of technical support.

Please consult with your network administrator about this matter and inform him about the following matters:

1. TCP 6000~6010 must be reachable from the remote host to your PC direction.
2. Your remote host must be properly configured as it is instructed in the Xmanager FAQ # 2.

/products/xmg_faq.html#p2

Thank you for using Xmanager.