Xmanager Forum

First logon problem... Unexpected packet

Last post: Thursday, August 11, 2011 1:13 AM by Support, 10 reply

 
Tuesday, October 22, 2002 11:37 AM

First logon problem... Unexpected packet

 
I have just begun to use X-Manager. I am trying to use X-Start to log into my University Solaris machines. I am using SSH... It begins to log in and says...

Connected to (host).
Exchanging SSH version...Done.
Server: SSH-1.99-2.4.0 SSH Secure Shell (non-commercial).
Client: SSH-1.5-Xssh_1.0.
SSH1 is enabled.

It then says...

Authenticating remote SSH server...
Waiting for server host key...

Here a "Xssh Error" window pops up and says:

Recieved unexpected packet (type=1).

What can be done about this? I know I have used Xmanager in the past... I don' know what is different this time.

Thanks!

-Rob
Tuesday, October 22, 2002 3:23 PM - Support

Re: First logon problem... Unexpected packet

 
The message is displayed when the ssh server disconnects a session unexpectedly. Please try SSH2 instead of SSH1. You can do it as following:

1. Open Xstart.
2. In the Protocol box, click Advanced button.
3. Choose Protocol tab.
4. In the Protocol Version, Select SSH2.
5. Save and run the session.

We would appreciate your feedback.

----
Technical Support
Friday, December 6, 2002 8:51 AM - Rob

Re: Re: First logon problem... Unexpected packet

 
Now I have a new problem...

It now says...

Connected to (host)

Exchanging SSH version...Done.
Server: SSH-2.0-3.2.0 SSH Secure Shell (non-commercial).
Client: SSH-2.0-Xssh_1.0.
SSH2 is enabled.

Negotiating algorithms...
Initiating key exchange...Done.
Exchanging Diffie-Hellman KeyEx message...Done.
Waiting for new key message...Received.
Fingerprint: 1024 f9:d6:be:da:fa:1f:10:d4:14:b1:6d:fb:cc:59:16:55.Verifying host key...
Algorithm negotiation has been finished...
CS Cipher: 3des-cbc, SC Cipher: 3des-cbc
CS Compress: zlib, SC Compress: zlib
CS MAC: hmac-sha1, SC MAC: hmac-sha1
At this point a window pops up that says...

"Server refused ssh-userauth protocol request."

It then disconnects... This is quite frustrating because, as I said before, I know I have used Xmanager to connect to these same amachines in the past.

Thanks!
Friday, December 6, 2002 1:44 PM - Soon

Re: Re: Re: First logon problem... Unexpected packet

 
I had the same error when using an ssh client. The problem might occur when zlib data compression option is not set properly in some ssh.com servers. I solve it by turning the data compression option off.

Please try to turn the zlib option off in the Xstart Advanced dialog.

Soon.
Wednesday, June 4, 2003 5:29 AM - Walt Bunch

Re: First logon problem... Unexpected packet

 
Every time we update an old machine to the latest Solaris (or get a new machine) I get the Xssh Error "Received unexpected packet (type=60)". However, I am able to ssh in to the newer machines from an older machine after using Xstart to connect to an older machine. When I run out of older machines I won't be able to use Xstart (or Xmanager) anymore.
Wednesday, June 4, 2003 2:15 PM - Support

Re: Re: First logon problem... Unexpected packet

 
It seems that the new ssh server has a feature that is not supported in Xstart. Could you please post the messages displayed on the "Result Window" of Xstart? It would be a great help for our future service.

Thanks for your cooperation.

----
Technical Support
Wednesday, June 4, 2003 4:05 PM - Walt Bunch

Re: First logon problem... Unexpected packet

 
Copy/Paste didn't work from the window. See the attached image.
Attachment Xstart.gif ()  
Wednesday, June 4, 2003 5:31 PM - Support

Re: Re: First logon problem... Unexpected packet

 
Thanks for your information.

The error (type 53) is occured because a banner feature is not supported in Xstart. You can fix it by installing the newest version of Xmanager at:

/download/download.html

Type 60 error is displayed when your password is to expire. You should change your password on the console to disable this message. This feature will also be supported in our future version.

----
Technical Support
Thursday, June 5, 2003 5:52 AM - Walt Bunch

Re: First logon problem... Unexpected packet

 
Thanks for the great support!! That fixed the problem.
Saturday, August 6, 2011 4:54 PM - Subrat

Re: First logon problem... Unexpected packet

 
I am getting (Received unexpected packet (type=53) ) error, while starting X manager session in my desktop for accessing a hp-ux server. Please help me to resolve it.
Attachment xmanager.bmp ()  
Thursday, August 11, 2011 1:13 AM - Support

Re: First logon problem... Unexpected packet

 
Please give us the following information:

1. Connection protocol (XDMCP, SSH, TELNET, RLOGIN and etc.)
2. If you are using SSH, ssh log on the remote server (usually /var/log/secure)
3. Your screenshot was not attached properly, please attach it again.
4. Xmanager log.
- If you are using Xstart, copy all messages in the "Xrcmd: reply message" dialog box.
- If you use XDMCP session, wait until the XDMCP failed message to open and right click on the Xmanager title bar. Select Log > File.



---
Technical Support