Xmanager Forum

Missing Buttons - APC PowerChute Business Edition v7.0.4 for Solaris 9.0

Last post: Tuesday, June 14, 2005 1:50 PM by Support, 4 reply

 
Monday, June 13, 2005 11:41 PM - dr-J

Missing Buttons - APC PowerChute Business Edition v7.0.4 for Solaris 9.0

 
I have Xmanager 2.0 (Build 0401). I connect via xbrowser on a network LAN behind a firewall.
.
When I login and run the PowerChute installation wizard under Solaris 9 CDE or GNOME desktops, the [NEXT] button doesn't appear. When the wizard first runs, I receive [CANCEL], [BACK], and [I AGREE] buttons. After I procede. The following screen does not have a [NEXT] button. I cannot continue the installation and am forced to cancel out.
.
I do NOT have this problem when I run the installer logged into a redhat server with a GNOME desktop.
.
To me the problem appears to be Xmanager since the GUI problems only happen when using Xmanager as a client.
.
Thank you,
Jim
Monday, June 13, 2005 11:51 PM - dr-J

Re: Missing Buttons - APC PowerChute Business Edition v7.0.4 for Solaris 9.0

 
Attached is the X0.log
Attachment X0.log (2.7 KB)  
Monday, June 13, 2005 11:59 PM - dr-J

Re: Missing Buttons - APC PowerChute Business Edition v7.0.4 for Solaris 9.0

 
and here's the rest of the X0.log:
Xdmcp KeepAliveTime: 0 seconds
Client 3 error: tried to allocate color cells on StaticClass
Client 3 error: tried to allocate color cells on StaticClass
Client 3 error: tried to allocate color cells on StaticClass
Client 3 error: tried to allocate color cells on StaticClass
Client 16 error: tried to allocate color cells on StaticClass
Client 16 error: tried to allocate color cells on StaticClass
Client 16 error: tried to allocate color cells on StaticClass
Client 16 error: tried to allocate color cells on StaticClass
Client 16 error: tried to allocate color cells on StaticClass
Client 16 error: tried to allocate color cells on StaticClass
Xdmcp: Control client is closed and the entire session is closed.
All clients are closed down. Going to server reset...
Terminate at server reset is active.

Exiting the waiting loop ...

X server was terminated normally.
Tuesday, June 14, 2005 12:09 AM - dr-J

Re: Re: Missing Buttons - APC PowerChute Business Edition v7.0.4 for Solaris 9.0

 
I modified:
Color->Default Visual: PseudoColor
Option->Backing Store: When Mapped
and now the log files contains these errors:
.
Client 15 error: tried to allocate color cells on StaticClass
Client 15 error: tried to allocate color cells on StaticClass
.
The GUI wizard buttons still don't appear either.
hmmmm.
Tuesday, June 14, 2005 1:50 PM - Support

Re: Re: Re: Missing Buttons - APC PowerChute Business Edition v7.0.4 for Solaris 9.0

 
It seems like buttons are displayed outside the application's frame. Please try the following solutions.
  1. From the login screen, select C for language.
  2. Try using Xstart. Please see below for detailed instruction.
  3. APC PowerChute installation requires JVM (Java Virtual Machine) 1.4.2 or higher. Check your JVM version and upgrade it if necessary.
Instruction for Using Xstart:
  1. Open up an xterm window using Xstart.
  2. Start remote window manager by typing the following command.
    # twm &
  3. Start installation procedure.
If you problem persists, please send us the following information:
  1. Result of the following command:
    # echo $LANG
  2. JVM version.
Hope this will solve your problem.