Xmanager Forum

Cursor Solved! XDMCP not responding rooted!

Last post: Friday, June 10, 2005 3:47 PM by Ioan NIKY Pricop, 3 reply

Thursday, June 9, 2005 8:04 AM - Ioan NIKY Pricop

Cursor Solved! XDMCP not responding rooted!

Dear Sirs,

Thanx for cursor problem patch! It solved problems in BOTH places.

As for the FIRST problem, XDMCP sessions stalling in a "not responding" status [SSH is plagued also, but it only occurs later], I found the reason why! After installing a FRESH XP on a borrowed HDD, with only the basic OS and Network card driver, it also stalled. I got out of the computer everything except the processor, video card, memory and that HDD. The same stalling! It obviously was a hardware issue, but than, why the same hardware works flawless under Win98?!? And than it struck me: Win98 DOES NOT KNOW ABOUT HYPERTHREADING. And I also realized the other computers I was testing on were also non-hyperthreading. A simple test with hyperthreading deactivated proved I am right: it worked like a charm.

But this is not acceptable. I won't pay for a product which cuts the performance of my processor in half! Now, the ball is in your terrain, gentlemen!!! I pinned the problem, the code is yours to upgrade to the latest technologies. But if I can further assist you in any way, just let me know!

PS: Excuse me for starting another thread, but the last one was growing too long...
Thursday, June 9, 2005 10:06 AM - Support

Re: Cursor Solved! XDMCP not responding rooted!

We really appreciate your cooperation.

We will test this problem in our facility and let you know the result as soon as possible.
Thursday, June 9, 2005 6:43 PM - Ioan NIKY Pricop

Re: Re: Cursor Solved! XDMCP not responding rooted!


I remember there was another application which had problems with hypertrading, and those guys were able to provide two solutions: An OS-level way to force an application to run ONLY ON ONE of the two virtual processors, and a wrapper-application [free on the Internet] doing the same thing without complicated setups. Do you know anything about any of those topics? It would be a good transient solution untill a final one, but I can't remember the details right now...

I will search for myself also, and test whatever I figure. Anyone of us with a working temporary solution will broadcast it here, right?
Friday, June 10, 2005 3:47 PM - Ioan NIKY Pricop

Re: Re: XDMCP not responding temporary solution


Till you make the program to do it by default, look how you can make it work - for sure! - on a computer with enabled hyperthreading processor [Method 1]:

- Start Xbrowser [it would be best to set it to show all type of sessions, including Xstart ones, to work ONLY from under Xbrowser];
- Press Ctrl-Alt-Del and choose "Task Manager";
- From Task Manager, choose "Processes" tab;
- Right-click the Xbrowser.exe process;
- From the pull-down menu, select the last [lower] option, called "Set Affinity" [if you don't see it, than either you don't have an Intel processor with hyperthreading, or you have the Hyperthreading functionality disabled from BIOS setup - call a specialist for assistance];
- In the shown dialog, uncheck the CPU 01 processor, to let the application run ONLY under CPU 00;
- Press ok and start working with any session you like.

[Method 2]:

Use the attached "affinity" application [author's explanations included] to launch Xbrowser and set the CPU 0 processor only to be used.

[Method 3]:

And this is the second method given to me by the people at ChrisTV [TV-Tuner software]: use the command-line "procaff" utility [second attachment] to write a batch thru which one can start Xbrowser with preset affinity [and give it the icon of Xbrowser, of cause!]. Documentation included in the archive also. THIS is what I will do this evening when reaching home [just re-fount this procaff in a google search].


If one has a processor with hyperthreading, CPU 0 is the real unit and CPU 1 is the virtual one. For a two-processors system, CPU 0 and CPU 1 are the real ones, while CPU 2 and CPU 3 are their respective virtual counterparts. From all I read about hyperthreading, applications which launches threads and other applications, must be rewritten to abide this technologie's rules. But meanwhile, any application with problems, can be used if forced to start threads only on ONE and preferably REAL processor. And that's what setting that affinity is doing.