Xmanager Forum

XDMCP sessions starting but... [not responding]

Last post: Wednesday, June 8, 2005 3:21 PM by Support, 11 reply

 
Tuesday, May 31, 2005 7:26 AM - Ioan NIKY Pricop

XDMCP sessions starting but... [not responding]

 
Dear Sirs,

I recently got the trial version of Xmanager as most of the reviews on the net say it's the best choice for working on a remote Linux with X from your Windows...

But I couldn't work in any kind of XDMCP session, which quickly stalls and shows [not responding] in the window title. I made all the appropriate settings in Xacces and kdmrc files. It shows the login dialog but stalls while writing the user or password, or even while initializing KDE. Tried once Gnome [which - BTW - I hate!] but it's the same!!! You have attached the log on the XP machine and the errors on the Debian.

I don't want to close this request without mentionig that - after successfuly editing ssh.conf and sshd.conf - I could "Xstart" without problems an xterm and a mozilla. Only once, an xterm running a mc stalled the same way.

PS: I also have screen-captures of these problems, and a tcpdump list of LAN packets during such a failed XDCMP session, if it could help...
Tuesday, May 31, 2005 2:39 PM - Support

Re: XDMCP sessions starting but... [not responding]

 
The problem may occur when Xmanager is in conflict with your video or LAN card driver.

Please try to update your device driver to the latest version.

If your problem persists, send us following information.

1. Hardware specs including the model and version of your video/LAN card.
2. Debian Version.

Hope this solves your problem.
Tuesday, May 31, 2005 6:05 PM - Ioan NIKY Pricop

Re: Re: XDMCP sessions starting but... [not responding]

 
The computer running Xmanager on an XP-prof SP1a is based on an INTEL PERLL motherboard [including Intel LAN card onboard] and the Video it's a Leadtek GeForce FX5700Ultra-128M. The drivers ARE up-to-date, as I am using eDimensional stereoscopic glasses on it and I have the last Nvidia genuine pair of drivers [videocard+stereo]. Processor: Prescott3.2G socket 478; 4 x 256M DDR400 GEIL; other hardware: Leadtek tv-tuner with hardware compression, and an USB-enclosed HDD [enclosure branded INTEX...]

The Debian is freshly installed from a bootable DVD generated by a jigdo process just last week and it's a Woody R5 distribution. [I allways wait a while before going to a new distribution - at least for the second release, if there were not VERY BIG troubles with R0!] The machine is an old Jetway830CN motherboard - not very sure on the last two letters, but I can tell it has NO LAN onboard and it's based on the SIS730 chipset. For this one I bought a LAN Adapter Intel PRO/100S with 56bits DES coprocessor [used for it the e100 driver from Debian - works well on internet and on apt-get installations]. I intend to buy two such LAN-adapters more to turn it into a home-router; I want to do much more on it but from MY computer - this one is cramped in the video space below a TV, without case and intended to be used without monitor, keyboard and mouse... The processor it's an AMD XP1800, 2 x 256M PC133 RAM.

For the local area network, there are 5 computers on it: two neighbours, mine, my wife's and the newly-installed Debian. For now, there are also two SMC7008BR broadband routers: one towards a cable-modem to internet, and the second one towards the district network [around 300 computers in all the surrounding buildings]. There is also a Hawking-Technologies USB printer-server wich has attached an USB HP1500L color printer to it.

I will attach the output of the tcpdump for an Xbrowser failed session - maybe it would help you put the finger on the issue... And I also attach an archive with the two screen-captures: one in gnome almost initialized and the other, with a stall in the initial login dialog.

PS: The Xstart session I previously mentioned to have stalled was an xterm with mc in it and it refused to accept any kind of input after a mouse right-click in it. Except this one, Xstart based on SSH worked like a charm!
Tuesday, May 31, 2005 6:40 PM - Support

Re: Re: Re: XDMCP sessions starting but... [not responding]

 
It has been reported that onboard LAN adapter sometimes fails when there is too much network traffic at any given moment.

To further assist you, please tell the result of the following tests.

1. Try connecting to Debian from different PCs.
2. Try using a different LAN card.

Thank you for your cooperation.

Wednesday, June 1, 2005 7:03 PM - Ioan NIKY Pricop

Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Well... I tried from two other PC's:

- From one of my neighbours, wich has an old Fujitsu-Siemens Scenic, with 1G Pentium III processor and Win2K Prof. OS;
- From my wife's computer, a no-name based on a PC-CHIPS motherboard and Duron1300 processor, with Win2K server OS.

I want to say that on both computers the Xbrowser launched and ran well in connection with the Debian, BUT BOTH HAVE ONBOARD LAN ADAPTERS!

The only problem was on my wife's computer, with a garbled mouse-cursor and it was VERY difficult to "feel" it's hot-spot... [mouse-cursor's, not my wife's ;->]

I have to borrow a LAN card to try with it on my computer - maybe this evening - but it seems the problem does not lay in the onboard LAN adapter. People, if it works with that puny PC-CHIP's onboard LAN, why wouldn't it work with a GENUINE INTEL PERLL'S MOTHERBOARD ONE?!? I would rather suspect the damn' WindowsXP on this one!!!
Wednesday, June 1, 2005 11:27 PM - Support

Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Xmanager is a network and video intensive program and your problem may come from a lot of sources: network driver, other network applications, video driver, and so on.

I have a similar problem with Internet Explorer in my Windows XP on an IBM notebook. Sometimes IE is not responding when I visit a complex web site.
I know that this dose not justify your problem with our software. What I mean is that the problem is very difficult for us to pinpoint the reason.

I suggest the following test steps:

1. Terminate any network application in your XP including a firewall or anti-virus program.
2. Make sure that your Windows XP is up-to-date.

If your problem persists, we need to replicate your problem in our environment with the same desktop configuration.

The cursor problem in another computer occurred on the latest Xmanager that supports a large cursor. This will be fixed in the next version.

Hope to solve your problem.

----
Technical Support
Thursday, June 2, 2005 6:12 PM - Ioan NIKY Pricop

Re: Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
I tested with the onboard LAN adapter disabled and a RTL8139D LAN-card in the third PCI slot, but IT WAS THE SAME.

I also tried your approach with terminating any network-related applications but with no success. In fact, there was only NAV2001 guarding on the computer.

I have another ideea to try to split between a hardware incompatibility or an XP-related problem: I have space on disk for a FreeBSD partition - which I didn't found time to install... I will try to put there a Windows 98 and see how Xmanager works under this OS with my hardware...

Before closing, another issue: I am an IT System-Engineer here in Romania - with my share of programming in the early '90-s - and if I could assist you by running any kind of diagnostic tools on my machine, I would gladly do it. I like your product and I would FOR SURE BUY A LICENCE IF WE COULD MAKE IT WORK ON MY COMPUTER.
Monday, June 6, 2005 5:57 AM - Ioan NIKY Pricop

Re: Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Well, Gentlmen...

I installed a sketchy Win98 [only nvidia video driver and Intel Chipset+onboardLAN] and it seems it does not stall anymore. So it seems it's not a hardware compatibility issue, but a software one. But still don't know if it's OS or driver related. And - by any means - I REALLY NEED ALL MY DRIVERS AND DEVICES!!!

PROBLEM: The cursor does not change it's shape as it should!!! As an example, it does not show the dirrection of "walls" in Jezzball, but it changes to show the action for the window-splitting in package manager. And - look! - even here it does not become the "hair-shape-I" as it should be.

I will further investigate what's keeping Xmanager from running properly in full-configuration, by Installing drivers one by one and test functionality in between. I already suspect either the printing-driver to a Hawkings-technologies USB printer-server or the HP4670 scanner which prompts me from time to time to download upgrades from internet, by DISCOVERING them as newly-arrived versions. But we shall see!
Tuesday, June 7, 2005 4:58 PM - Support

Re: Re: Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Thank you for your cooperation.

To further test your mouse cursor problem, please send us the screenshots of your problem, and names of the programs which produce such errors.

Wednesday, June 8, 2005 3:21 AM - Ioan NIKY Pricop

Re: Re: Re: Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Dear Sirs,

I have attached a screen-capture from my wife's computer with an xterm launched and runing [don't be worried, that's how I launch it: xterm -bg black -fg green; remembers me the first VT52's on which I ran unixes and PDP 11...], and a ping -t. But as I use the PrtScr key and than "paste" it in paint, it does not show the cursor!!! If you can direct me to another capture method, I am available...

But I tried to Draw the cursor in "paint" also... Hope you would understand my "art" :-)

On my computer, under Win98, The cursor does not appear when I start XDMCP session in full screen, but if I go to an edge, it becomes "upper-left" arrow and changes very hard...
Wednesday, June 8, 2005 3:17 PM - Ioan NIKY Pricop

Re: Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Dear Sirs,

Thinking it's something wrong with Xmanager, I searched with google for "PC X-server" and tried on my XP machine two other similar applications: X-Deep/32 and Omni-X [www.xlink.com].

The first one worked ALMOST fine - having moments of freezing for maximum a couple of seconds, but the second one had EXACTLY the same stalling [not responding...] behaviour as your Xmanager. And even X-Deep/32, ran on my wife's computer, did not behave with those nasty freezing moments, so I suspect what's keeping your application from running, is momentarily freezing the X-Deep.

So I guess for the NOT RESPONDING problem, the ball is in my side - aas your site advertises Xmanager as working under XP [in usual conditions - of cause]. The alternative OS approach didn't reveal anything, so I must try another one: borrow a Harddisk and try with a bare XP and Xmanager [won't risk another XP instance on my main HDD, caue I have had troubles with two Win2K's on the same hard...]. And if it works I would put on it driver-by-driver to the actual status, to discover the root of the problem; than, you could replicate it and study the unwanted interaction...

BTW: I still like more Xmanager... ;-)
Wednesday, June 8, 2005 3:21 PM - Support

Re: Re: Re: Re: Re: Re: Re: XDMCP sessions starting but... [not responding]

 
Please apply the attached patch file to your Xmanager installed directory. This may fix your mouse pointer problem.

If your problem persists, you can use the third party software to capture the mouse pointer such as Snagit or Hypersnap DX.

Thank you for your cooperation.