Xmanager Forum

XBrowser with ssh connection!

Last post: Wednesday, February 16, 2005 5:09 PM by Tran Kien, 4 reply

 
Wednesday, February 2, 2005 5:38 PM - Tran Kien

XBrowser with ssh connection!

 
Hello, Any one help me this trouble? I want to use a secure connection from my windows clinet to linux box via XBrowser! But i'm not sure this XDMCP connection is secure one or not???if it is not, how to use this connection via ssh??? Thanks for help! Any soon help will be warmly appriciated! Regards,
Thursday, February 3, 2005 3:24 PM - Support

Re: XBrowser with ssh connection!

 
XDMCP is not a secure connection method. And there is no way to use an ssh connection with Xbrowser.

However, you can get a remote desktop environment using Xstart with SSH. To do that, follow the instruction below:
1. Run Xstart, login to a remote host using SSH protocol, launch an xterm window.
2. At the command prompt of xterm, type in the command below.
For KDE (K Desktop Environment):
# /usr/bin/startkde
For GNOME:
# /usr/bin/gnome-session
For CDE (Common Desktop Environment):
# /usr/dt/bin/Xsession
For XDM:
# /usr/lib/X11/xdm/Xsession (Unix)
# /etc/X11/xdm/Xsession (Linux)

Hope this helps you.

----
Technical Support
Thursday, February 3, 2005 5:33 PM - Tran Kien

Try your product first, buy later but XDMCP connection failed...!

 
Hello,

My linux box is using gnome, but when issued Xstart with SSH to bring a remote desktop env, I got this error "
[root@linux01 root]# /usr/bin/gnome-session
Gdk-ERROR **: X connection to localhost:11.0 broken (explicit kill or server shu
tdown).
SESSION_MANAGER=local/linux01:/tmp/.ICE-unix/19300
Gdk-ERROR **: X connection to localhost:11.0 broken (explicit kill or server shu
tdown)"
So, how to resole this???
Regards,
Friday, February 4, 2005 5:16 PM - Support

Re: Try your product first, buy later but XDMCP connection failed...!

 
Please make sure that you have started an xterm before running gnome-session. In Command box of Xstart, enter the following command:

/usr/bin/X11/xterm -ls

And then click Run to launch an xterm.
Once an xterm window opens, run the gnome command from the xterm window as following:

# gnome-session &

Also, make sure that you have not changed user id after login. If you switch user id, the environment settings of ssh connection may be lost.

Hope this helps you.

----
Technical Support
Wednesday, February 16, 2005 5:09 PM - Tran Kien

Try your product first, buy later but XDMCP connection failed...!

 
Hello,


Thanks for your support! That help me so much! that's OK now!
Thanks again!
Nye!