Xmanager Forum

Backspace not working

Last post: Saturday, September 29, 2001 1:42 AM by Simon, 9 reply

 
Sunday, September 23, 2001 11:35 PM - Simon

Backspace not working

 
I'm using the UK 102 key layout and the backspace key doen't work. It acts as a delete key instead. I can't work it out, as the layout indicates backspace and the linux system I'm connecting to works fine from other x servers (another linux system).

Anyone got any ideas?
Monday, September 24, 2001 12:31 AM - Kay

Re: Backspace not working

 
Please try the Q11 answer of FAQ list.

/bbs/listfaq.html

You should change the shifted value of Backspace key to "NoSymbol".

- Kay
Monday, September 24, 2001 8:16 PM - Simon

Re: Re: Backspace not working

 
Sorry and thank you.
Tuesday, September 25, 2001 1:31 AM - Simon

Re: Re: Backspace not working

 
OK, I've tried that. Unfortunately it doesn't work. Now the key does nothing at all! Any further ideas?

Cheers.
Tuesday, September 25, 2001 8:58 PM - Support

request for uk102.xkb file

 
Thank you for trying our Xmanager software.

Could you please upload the uk102.xkb file on this board?
You can find it at "C:Program FilesXmanager" directory.

Looking forward to your reply.

- Technical Support
Thursday, September 27, 2001 1:40 AM - Simon

Re: request for uk102.xkb file

 
Here is the keyboard layout file as requested. Thanks for looking into this.
Attachment uk102.xkb ()  
Thursday, September 27, 2001 11:12 PM - Support

Re: Re: request for uk102.xkb file

 
Your keyboard file is correct.

Please check the following things:

1. How to run an xterm. (using Xstart or XDMCP)
2. xterm options. "-ls" option may affect Backspace.
remove "-ls" option or add it at the Xstart command field.
3. run "stty all" command at the xterm prompt and
compare the result with another xterm that is working well.

Your Unix brand and version might also be a good hint.

- Technical Support
Friday, September 28, 2001 4:16 AM - Simon

Re: Re: Re: request for uk102.xkb file

 
I use Xstart to run my xterm. It has the -ls option, but it makes no difference if I remove it.

The stty all command gives the following:

speed 38400 baud; line = 0;
-brkint -imaxbel

It's the same if I run it on a xterm that is running well.

I have the following brand and version of Unix:

Red Hat Linux release 7.1 (Seawolf)
Kernel 2.4.2-2 on an i586

(that's what it reports when I log on).

I hoep this is helpful. It would be very good to come up with a solution.

Thanks once again.
Friday, September 28, 2001 3:06 PM - Support

Modified uk102.xkb

 
Please copy the attached file into "C:Program FilesXmanager139" directory and restart Xmanager.

Your uk102.xkb has an incorrect compose key sequence for Backspace key, so we used the original uk102.xkb to change the Backspace symbol.

- Technical Support
Attachment uk102.xkb ()  
Saturday, September 29, 2001 1:42 AM - Simon

Re: Modified uk102.xkb

 
That works a treat. Thanks very much.