Xmanager Forum

Frames removed when running Java APP, or JAVA apps fail to load

Last post: Thursday, December 30, 2004 5:52 PM by Support, 3 reply

 
Thursday, December 23, 2004 5:15 AM - James Gallogly

Frames removed when running Java APP, or JAVA apps fail to load

 
6 A java application with no window frame Steve 08/15/2001
08:54:29 179


Xconfig: Multiple Window Mode
Client Launching: using Xstart with SSH protocol
Detailed Steps:
1. Open an xterm using Xstart with SSH protocol.
2. Run a java application.
3. Window title and frames of xterm are removed.


The old fix was to change the Windows Manager from auto to remote. This worked great for java 1.4.x but with the latest version of Java (JDK5 or java 1.5) is the behavior below.

The behaior I know see is

Auto: Removes frames
Remote: Removes frames
Local: provides the following error

*************
Mapped windows:
8388612->sun.awt.X11.XRootWindow@12ad19e
Mapped peers:
Mapped special peers:
Mapped dispatchers:
8388612->[sun.awt.X11.XToolkit$5@8997d1]



Friday, December 24, 2004 1:42 AM - Support

Re: Frames removed when running Java APP, or JAVA apps fail to load

 
We have tested java applications under JDK 1.5.0 environment. However, we could not replicate your problem.

Please send us following information so we can further assist you.

- Server type
- Application name/version
- Detailed procedure for duplicating your problem

Mean while try using Xmanager in remote window mode with twm or mwm.

----
Technical Support



Wednesday, December 29, 2004 10:25 PM - James Gallogly

Re: Re: Frames removed when running Java APP, or JAVA apps fail to load

 
It turns out this issue is specific to the application I am using.

The Java app runs fine on windows and linux, however through xmanager it fails to set either load the icon(from the jar file) or set the Windows Icon.

This is likely an network race condition or other issue inside the application. Unfortunately this application is not publicaly availble and I have been unable to find a publicly availble application where this can be duplicated in. I am running Xmanager on Windows XP sp2, to connect to a Redhat 9.0.

Below is some more information, this seems to indicated it is not directly an xmanager issue.


jar:file:/home/jgallogly/dev/lib/atc.jar!/images/atc_icon.gif
Status: COMPLETE
Image good
sun.awt.image.ToolkitImage
java.lang.IllegalArgumentException: Width (0) and height (0) cannot be <= 0
at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:999)
at sun.awt.X11.XFramePeer.setIconImage(XFramePeer.java:217)
at java.awt.Frame.setIconImage(Frame.java:564)
at javax.swing.JFrame.setIconImage(JFrame.java:571)
Thursday, December 30, 2004 5:52 PM - Support

Re: Re: Re: Frames removed when running Java APP, or JAVA apps fail to load

 
Thank you for your feedback.

It seems this problem is specific to your application only. Please let us know if you find any application that we can duplicate your problem.

Meanwhile, try using "Auto" for window manager. Run an xterm window, run "twm" on the xterm prompt, and then run your java application.

----
Technical Support