Xmanager Forum

How can i disable the Right-Click function in Xmanager window-bar?

Last post: Wednesday, December 8, 2004 4:49 PM by David, 6 reply

 
Monday, December 6, 2004 11:14 AM - Zhangyi

How can i disable the Right-Click function in Xmanager window-bar?

 
How can i disable the Right-Click function in Xmanager window-bar?
when i start the Xmanager, at this Xmanager's windows bar, if i right click my mouse, a sub menu come: it include like 'move', 'Close' ... the standard windows bar option, but also come something like 'File', 'Clients','Option' 'Help' the Xmanager special option item, Now, i want disable these Xmanager special option items. please help me.

thanks!

zhangyi
Monday, December 6, 2004 12:42 PM - zhangyi

i just want prevent somebody to access my local disk (He can use the X-termail resource only))

 
i just want prevent somebody to access my local disk (He can use the X-termail resource only))
Monday, December 6, 2004 1:32 PM - David

Re: How can i disable the Right-Click function in Xmanager window-bar?

 
You can remove the title bar entirely. Run Xconfig, click Settings, click the Multiple Window Mode tab, and then select Full Screen from the Window Size list box.

David
Monday, December 6, 2004 6:38 PM - zhangyi

It is a good solution, but when i start the Xmanager from xbrowser, the windows bar come again

 
It is a good solution, but when i start the Xmanager from xbrowser, the windows bar come again, please help me

thanks!
Monday, December 6, 2004 6:55 PM - Andrew

Re: It is a good solution, but when i start the Xmanager from xbrowser, the windows bar come again

 
Try using single window mode and full screen in combination. This should work.

But my question is, how can you prevent anyone from accessing your local hard drive by disabling this menu?

BTW the picture you attached, I can't open it.
Tuesday, December 7, 2004 10:59 AM - zhangyi

Re: Re: It is a good solution, but when i start the Xmanager from xbrowser, the windows bar come again

 
This is used in Win2003 terminal service mode, when user login to win2003, he should follow the rule which defined by Administrator.
Wednesday, December 8, 2004 4:49 PM - David

Re: Re: Re: It is a good solution, but when i start the Xmanager from xbrowser, the windows bar come again

 
Are you using Xmanager 1.3.9?
If then, run Xconfig, click the Window tab, select Single Window Mode, select Use Full Screen.

In my workstation, that removes the title bar of Xmanager.

David.