Xmanager Forum

SSH display problem

Last post: Wednesday, October 7, 2009 2:28 AM by Stefan Neupert, 3 reply

 
Monday, November 8, 2004 1:43 PM - endrue

SSH display problem

 
Hi i recieved this problem only when i connect to some IP :

[11:42:34] Connecting to '10.1.1.14'...
[11:42:34] Connected.
[11:42:34] Version exchange initiated...
[11:42:34] server: SSH-1.99-OpenSSH_3.6.1p2
[11:42:34] client: SSH-2.0-libssh_1.2.1697 NetSarang Computer, Inc.
[11:42:34] SSH2 is selected.
[11:42:34] Algorithm negotiation initiated...
[11:42:34] key exchange: diffie-hellman-group1-sha1
[11:42:34] host key: ssh-dss
[11:42:34] outgoing encryption: aes128-cbc
[11:42:34] incoming encryption: aes128-cbc
[11:42:34] outgoing mac: hmac-sha1
[11:42:34] incoming mac: hmac-sha1
[11:42:34] outgoing compression: none
[11:42:34] incoming compression: none
[11:42:34] Host authentication initiated...
[11:42:34] Hostkey fingerprint:
[11:42:34] ssh-dsa 1024 52:ae:1d:67:8b:88:6b:2c:6f:4d:82:a5:e2:6b:26:9c
[11:42:34] Accepted. Verifying host key...
[11:42:34] Verified.
[11:42:34] User authentication initiated...
[11:42:34] Sent user name 'root'.
[11:42:34] Sent password.
[11:42:34] Access granted.
[11:42:34] Sent X11 forwarding request...
[11:42:34] Succeeded.
[11:42:34] Sent the command line.
[11:42:34] /usr/X11R6/bin/xterm -ls -display $DISPLAY
[11:42:34] Start timer (TIMER_SHUTDOWN, 180).
Warning: This program is an suid-root program or is being run by the root user.
The full text of the error or warning message cannot be safely formatted
in this environment. You may get a more descriptive message by running the
program as a non-root user or by removing the suid bit on the executable.
/usr/X11R6/bin/xterm Xt error: Can't open display: %s

are there some settings i need to know about this?
Thx
Tuesday, November 9, 2004 1:49 AM - Support

Re: SSH display problem

 
The setuid bit of xterm seems to interfere with security policy of your system.

Try to clear the suid bit as following:

# chmod -s /usr/X11R6/bin/xterm

If the problem persists, let us know the detailed version of your Unix machine.

----
Technical Support
Wednesday, October 7, 2009 1:53 AM - Stefan Neupert

Re: SSH display problem

 
Same problem here. Running Xstart 3.0 against a Suse Linux SLES10. Got no suid on /usr/X11R6/bin/xterm.

Is there any solution?

Thanx
Wednesday, October 7, 2009 2:28 AM - Stefan Neupert

Re: SSH display problem

 
Well, found a solution here: /bbs/detail.html?id=xmanager&num=2999

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Try allocating pseudo terminal:

1. Open Xstart.
2. Select a session.
3. For Protocol, select SSH.
4. Click Setup.
RESULT: SSH Protocol Setup dialog box opens up.
5. Select the Option tab.
6. In Command Execution, select Allocate a pseudo terminal before executing the command.
7. Click OK to save the changes.
8. Start the session.

then, if the problem persists, try restarting SSH server.

Also, try removing the $HOME/.Xauthority file.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Removing the .Xauthority-file didn't cure the problem, but the pseudo terminal request did!

Thankx