Xmanager Forum

PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

Last post: Thursday, August 26, 2004 6:23 PM by ¿eljko, 9 reply

 
Wednesday, August 25, 2004 6:48 PM - ¿eljko

PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
I selected fonts iso8859-5 from the list and put it on the top of lsting fonts of the menu and selected ru.xkb (or russian2.xkb) but still have problems writing russian letters. I tried using english or russian keyboard (I meant hardware) but nothing helps. Could you help me by telling me which files on linux are also important and what should be written in them??

help me please!!
Thursday, August 26, 2004 12:03 AM - Tseng

Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
How about trying an additional font for Russian? You can find it in download section of this homepage.

Tseng.
Thursday, August 26, 2004 2:25 PM - ¿eljko

Re: Re: PROBLEMS DISPLAYING RUSSIAN CHARACTERS

 
which additonal fonts you mean?? could you be more specific are send to me as attachment??
I am using xmanager2.0 and linux 9.0
Thursday, August 26, 2004 2:26 PM - ¿eljko

Re: Re: PROBLEMS DISPLAYING RUSSIAN CHARACTERS

 
i am already using that fonts on this page iso8859-5
Thursday, August 26, 2004 3:24 PM - Support

Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
This is a brief guide to enter Russan characters with a standard US-101 keyboard (hardware):

1) Install the ISO8859-5 font pack at download page.
2) Select a Russian keyboard in the Xconfig:
1. Run Xconfig.
2. Double-click Default Profile.
3. Click the Devices tab.
4. Click Keyboard Settings.
5. Click Add, and then select ru.xkb.
6. Click Set Default to use it by default.
7. Click OK.
3) Connect to the RedHat server via XDMCP. (Gnome or KDE)
From the logon window, select the Russian language.
4) When you want to enter swap keyboard maps, click Ctrl+Alt+K.

For an Xstart connection, you need to LANG variable of your terminal.

----
Technical Support
Thursday, August 26, 2004 4:26 PM - ¿eljko

Re: Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
If I understand you correctly I need to install iso8859-5 fonts and set to default ru.xkb on xmanager2.0 and on linux server set LANG=ru?? In dialog box for setting fonts on xmanager2.0 which type of fonts need to be on the top??
Is there anything also to do because I tried this and it is not working.
Plesa write me down what actually need to be set or written and in which place or file.

thanks very much
Thursday, August 26, 2004 4:33 PM - Support

Re: Re: Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
Can you provide us with a screenshot of your problem?
Thursday, August 26, 2004 4:54 PM - ¿eljko

Re: Re: Re: Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
I think screenshot couldn't help you. On my aplication it is correctly displayed russian characters but when I tried to type russian characters in empty field in my application it displays on normal characters.
What should be written in /etc/sysconfig/i18n and keyboard?? Give me the whole example what should be written.
thanks
Thursday, August 26, 2004 5:45 PM - Support

Re: Re: Re: Re: Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
What is your application?
We've tested it with gnome-terminal and xterm, and can enter Russian characters without any problem.

A screenshot would be helpful for us to figure out what you are doing and in which environment you are trying to enter Russian characters.
Thursday, August 26, 2004 6:23 PM - ¿eljko

Re: Re: Re: Re: Re: Re: PROBLEMS DISPLAYINF RUSSIAN CHARACTERS

 
It is our own application. Screen shots will, i am sure, not be helpfull. I use it in xterm environment and it doesn't work