Xmanager Forum

Can't connect to RedHat Linux 7.0

Last post: Thursday, July 4, 2002 2:11 PM by Andrey Kudrun, 8 reply

 
Monday, July 1, 2002 2:51 PM - Andrey Kudrin

Can't connect to RedHat Linux 7.0

 
Hello!
I have a RH Linux 7.0 and want to use X-window on my Windows Desktop. I try to use Xmanager but it doesn't help me. I do exactly as described in Faq about Linux configuration. But when I connecting to Linux thru XDMCP but it's failes (it says XDMCP connection failed), when I trying to connect by telnet or SSH (by runing xterm with default parameters) it's nothing happens.
Have you any suggestions? I'll apreciate any help.
Monday, July 1, 2002 8:37 PM - Kay

Re: Can't connect to RedHat Linux 7.0

 
You need to check if gdm or kdm is running on your Linux.

# ps -aux | grep dm

Also, a telnet server should be running on the Linux to use Xstart with a TELNET.

A firewall configuration might also block the connection.

Kay
Tuesday, July 2, 2002 2:18 PM - Andrey Kudrin

Re: Re: Can't connect to RedHat Linux 7.0

 
>You need to check if gdm or kdm is running on your Linux.
>
> # ps -aux | grep dm

My system running gdm.

>Also, a telnet server should be running on the Linux to use Xstart >with a TELNET.

The telnet server is runing ok! I can login and what I want, but when I try to run X , X manager connects to telnet, login and run xterm blah-blah-blah (all arguments by default, I just selecting linux-box)and nothing happens.

>A firewall configuration might also block the connection.

I don't use firewall. Just 2 PC (server and workstation) connected to each other.
Tuesday, July 2, 2002 2:57 PM - Support

Re: Re: Re: Can't connect to RedHat Linux 7.0

 
Could you post the messages displayed in the "execution result dialog" box after running Xstart? That would help us to figure out the reason.

And you should change /etc/X11/gdm/gdm.conf file for XDMCP connection as described in FAQ #2.

Also, check out the followings:

1. An error in DNS configuration.
In this case, you need to add your PC in the /etc/hosts file.
2. A DISPLAY variable is defined in your login shell scripts.
You need to remove all DISPLAY variable settings.

----
Technical Support
Wednesday, July 3, 2002 3:58 PM - Andrey Kudrin

Re: Re: Re: Re: Can't connect to RedHat Linux 7.0

 
>Could you post the messages displayed in the "execution result >dialog" box after running Xstart? That would help us to figure out >the reason.

-----------------------------------------------------------------

Red Hat Linux release 7.0 (Guinness)
Kernel 2.2.16-22 on an i586
login: xxxxx
Password:
Last login: Sat Jun 29 23:30:48 from xxxxxxx
You have mail.

[xxxx@xxxx xxxx]$
[xxxx@xxxx xxxx]$ /usr/bin/X11/xterm -ls -display 192.168.1.2:0.0

-----------------------------------------------------------------

Thats all

>And you should change /etc/X11/gdm/gdm.conf file for XDMCP >connection as described in FAQ #2.

I done everything that listed in FAQ.

>Also, check out the followings:
> 1. An error in DNS configuration.
> In this case, you need to add your PC in the /etc/hosts file.

All ok, my workstation already was added to etc/hosts, and in hosts. allow

> 2. A DISPLAY variable is defined in your login shell scripts.
> You need to remove all DISPLAY variable settings.

When I'm running Xstart with full default parapemetrs nothing happens. When I'm delete -ls option and run it (the full run string was /usr/bin/X11/xterm -display $DISPLAY), something going on on the server, it's start to havily utilize HDD, but nothing at my Xmanager Window. When I remove -ls -display #DISPLAY option the result was same as without -ls.
Wednesday, July 3, 2002 5:42 PM - Support

Re: Re: Re: Re: Re: Can't connect to RedHat Linux 7.0

 
The display variable, "192.168.1.2:0.0", means that your PC is located in a private network. In this case, your Linux server should also be located in "192.168.1.xxx". Or else the xterm can reach at your PC. Please do a ping test from Linux to your PC like this:

# ping 192.168.1.2

When the IP address is not a valid one, xterm hangs and doesn't respond until the connection is closed.
Wednesday, July 3, 2002 6:34 PM - Andrey Kudrin

Re: Re: Re: Re: Re: Re: Can't connect to RedHat Linux 7.0

 
>The display variable, "192.168.1.2:0.0", means that your PC is >located in a private network. In this case, your Linux server should >also be located in "192.168.1.xxx". Or else the xterm can reach at >your PC. Please do a ping test from Linux to your PC like this:

My Linux server IP is 192.168.1.1 and Win Workstation - 192.168.1.2 and it works ok. I can reach server from workstation and workstation from server.
Wednesday, July 3, 2002 9:41 PM - Support

Check a firewall setting in Windows

 
Up to this point, everything is OK and there are no reason for xterm failure.

If your Windows is XP or 2000, please check the firewall settings. You can get an idea from FAQ #12 at:

/bbs/listfaq.html
Thursday, July 4, 2002 2:11 PM - Andrey Kudrun

Re: Check a firewall setting in Windows

 
>If your Windows is XP or 2000, please check the firewall settings. >You can get an idea from FAQ #12 at:

The problem was exactly in that! I just remove firewalling in WinXP and now everything ok.
Thanks a lot for a good product and support.