Xmanager Forum

cannot connect to linux redhat9 through xmanager 1.3.9

Last post: Monday, July 12, 2004 4:58 PM by Support, 1 reply

 
Monday, July 12, 2004 3:21 PM - ananth

cannot connect to linux redhat9 through xmanager 1.3.9

 
Hi there i am trying to connect to linux redhat 9 through Xmanager from my system (windows 2000 Server) but it is not getting connected it gives error "Cannot connect to remote host Please make sure if host is ready" as per one of the previous results i had made the following changes in both linux and x manager For runlevel: /etc/inittab For GDM: /etc/X11/gdm/gdm.conf For KDM: /etc/X11/xdm/xdm-config /etc/X11/xdm/Xaccess /etc/X11/xdm/kdmrc /usr/share/kdm/kdmrc /usr/share/config/kdm/kdmrc /etc/opt/kde2/share/config/kdm/kdmrc For Firewall: /etc/sysconfig/ipchains Step 1. Change runlevel to enable gdm or kdm. 1. Open /etc/inittab file. 2. Change the runlevel to 5 as following: id:5:initdefault: Step 2. GDM configuration (When the Linux is using gdm) 1. Open /etc/X11/gdm/gdm.conf file. 2. Go to the [xdmcp]section. 3. Set the value of "Enable" option to "1". Step 3. KDM configuration (When the Linux is using kdm) 1. Open /etc/X11/xdm/xdm-config file. 2. Comment out "requestPort" option as following: DisplayManager.requestPort: 0 ==> !DisplayManager.requestPort: 0 3. Open /etc/X11/xdm/Xaccess file. 4. Remove the initial "#" character for the following line: #* #any host can get a login window ==> * #any host can get a login window 5. Open /etc/X11/xdm/kdmrc, /usr/share/config/kdm/kdmrc or /etc/opt/kde2/share/config/kdm/kdmrc file. 6. Change the value of "Enable" option to "true". Step 4. Firewall configuration (If the firewall has been configured) 1. Open /etc/sysconfig/ipchains file. 2. Add the following lines at the top of the file: -A input -p udp -s 0/0 -d 0/0 177 -j ACCEPT -A input -p tcp -s 0/0 -d 0/0 telnet -j ACCEPT -A input -p tcp -s 0/0 -d 0/0 ssh -j ACCEPT -A input -p tcp -s 0/0 -d 0/0 login -j ACCEPT -A input -p tcp -s 0/0 -d 0/0 exec -j ACCEPT -A input -p tcp -s 0/0 -d 0/0 shell -j ACCEPT -A input -p tcp -s 0/0 -d 0/0 7100 -j ACCEPT Step 5. Restart your Linux to activate the changes. Gnome terminal fails to open in RedHat 7.3. The problem occurs due to the font used by gnome-terminal. To fix this problem, configure xfs program and add the specific font server into the font list of Xconfig. 3. Comment the following line out in the file /etc/X11/fs/config. #no-listen = tcp 4. Restart xfs process or reboot the system. 5. Open Xconfig utility. 6. Choose Font tab. 7. Click Add Font Server button. 8. In the Host box, enter the hostname or IP address of Linux. 9. In the Port box, enter 7100. 10. Restart Xmanager. Make sure that the font server should be listed in the bottom of the font list. but still i cannot connect to the linux box i am able to connect to linux through telnet but not able to connect through x manager Kindly help me ill be greatfull to u
Monday, July 12, 2004 4:58 PM - Support

Re: cannot connect to linux redhat9 through xmanager 1.3.9

 
Your problem may occur when there is a connection problem using the selected protocol. Please try to use telnet or ssh in Xstart.

---
Technical Support