Xmanager Forum

xterm unexpectedly closes with ssh

Last post: Friday, June 7, 2002 6:32 AM by Byron Guernsey, 2 reply

Friday, June 7, 2002 12:40 AM - Byron Guernsey

xterm unexpectedly closes with ssh

I'm connecting to a network using Aventail VPN. I can establish a ssh xterm to RedHat 7.3 just fine, but after an indeterminant amount of time (sometimes 10 seconds, sometimes 2 minutes) the xterm simply disappears and the XSSH log window does not show that the session ends.

I decided to try a different ssh program with X-Forwarding to see if it was the ssh client implementation. I tried SecureCRT. This too had an unexpected disconnect from the X Server and the ssh session that started the xterm continued to work and displayed:

xterm: fatal IO error 32 (Broken pipe) or KillClient on X server "localhost:10.0"

So I tried another program - xeyes and it ran for a little while then got:
X connection to localhost:10.0 broken (explicit kill or server shutdown).

The ssh session never disconnects. I'm running:
OpenSSH_3.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f

and Xmanager 1.3.9. I have a NVidia GeForce 2 display card with the latest display drivers.

Is there any way to have Xmanager log what is taking place? I couldn't find any debug settings...

Any help would be appreciated.

Byron Guernsey

Friday, June 7, 2002 12:47 AM - Byron Guernsey

Re: xterm unexpectedly closes with ssh


Well, I checked the XManager directory and found the following in the XManager.log:

WSAAyncSelect() on fd 0 failed, event: 40

It appears that the Aventail Connect client can fail in a WSAAsyncSelect. It layers itself on top of Winsock as a layered service provider. I've already seen issues with this causing failures from WSADuplicateSocket().

The question here is whether Xmanager should allow for WSAAsyncSelect() to fail and retry. While the standard Winsock doesn't appear to fail here, the Aventail winsock layer does...and this might be a scenario that is perfectly valid.

Byron Guernsey
Friday, June 7, 2002 6:32 AM - Byron Guernsey

Re: Re: xterm unexpectedly closes with ssh


Well, I think I resolved this myself. The aventail software supports an exception list- or a list of applications for whom which winsock calls will be passed through without modification or tunneling. If you add xmanager.exe to this list, it works ok- however it also means it cannot connect through the VPN. This isn't so bad because you can use a 3rd party ssh client with X-Forwarding on the local machine to transport the packets. Also, it may be unnecessary to use the 3rd party ssh since the xssh.exe could still be tunneled while the xmanager.exe is set not to tunnel through the VPN. It would then be a question of whether xssh.exe uses the WSAAsyncSelect() function.

It appears that this is mainly a fault of the Aventail winsock layer.