Xmanager Forum

Xlib: extension "GLX" missing on display

Last post: Wednesday, May 19, 2004 2:24 PM by Support, 1 reply

 
Tuesday, May 18, 2004 8:25 PM - Julian

Xlib: extension "GLX" missing on display

 
Hello,

i have some problems with my Xmanager-Connection to an redhat server.

When i login over Xmanager 1.3.9 on the server, sometimes i get these messages:

xsession-errors file:
startkde: Starting up...
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
kbuildsycoca running...
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Server has no DPMS extension
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
Xlib: extension "GLX" missing on display "my-ip-address".
mcop warning: user defined signal handler found for SIG_PIPE, overriding
ksmserver: Fatal IO error: client killed
startkde: Shutting down...
KLauncher: Exiting on signal 1
ICE default IO error handler doing an exit(), pid = 28789, errno = 0
startkde: Running shutdown scripts...
startkde: Done.

Could it be, that Xmanager 1.3.9 does not supports GLX?

What can i do, to fix the problem?

Thanks for your helping,

Julian.
Wednesday, May 19, 2004 2:24 PM - Support

Re: Xlib: extension "GLX" missing on display

 
Even though the GLX extension is not available, you should have no problem in running startkde.

The problem may occur when you run "startkde" directly with Xstart. To fix the problem, do one of the following:

1. Run an xterm ahead, and then run startkde from the xterm.
2. Clear the "Terminate at server reset" option in the Options tab of Xconfig.

If the problem persists, let us know the following:

- Connection method with protocol (e.g.: Xstart with SSH, XDMCP)
- Detailed connection steps you followed.

----
Technical Support