Xmanager Forum

XManager2 Beta Installation Problem (Error 1603)

Last post: Thursday, May 27, 2004 5:27 PM by Neil Brown, 10 reply

 
Wednesday, May 12, 2004 10:48 PM - Neil Brown

XManager2 Beta Installation Problem (Error 1603)

 
I've been using the Beta of XManager2 that I downloaded back in March and it's been working great, but today I downloaded the latest beta (filename xmgr2b5.exe) and it failed during the installation. I got two errors, which can be seen in the attached images.

I tried downloading the latest Windows Installer from Microsoft, but I'm already running that version, so it wouldn't install. A look at InstallSheild.com's support section tells me to check the version field in the msi file properties of XManager (which was 9.x) and install the appropriate ISScript.msi, which I did, but it made no difference.

After these errors, the installation aborts.

Any ideas what's causing these errors and how I can fix them?

Cheers,
Neil
Wednesday, May 12, 2004 11:31 PM - Support

Re: XManager2 Beta Installation Problem (Error 1603)

 
Sorry for the trouble.

Today we have uploaded Xmanager 2 beta 6 (xmgr2b6.exe). Please try the new version and let us know if you have the same problem.

----
Technical Support
Thursday, May 13, 2004 4:54 PM - Neil Brown

Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
Hi,

I've just tried downloading Beta 6 and I get exactly the same errors as with Beta 5. Any other suggestions?

Cheers,
Neil
Thursday, May 13, 2004 6:12 PM - Support

Re: Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
Xmanager 2.0 beta 6 was packaged with InstallShield 9.
Please try to install Xmanager as Administrator. Some limitation in privilege can cause such a problem. If it doesn't work, you need to upgrade ISScript as following:

1. Delete the "%Program Files%\Commen Files\InstallShield\Driver" folder.
2. Install IsScript at:
http://support.installshield.com/kb/files/Q108158/IsScript9.zip
3. Install Xmanager program.

Please read an article on the problem at:

http://consumer.installshield.com/kb.asp?id=q108158

Hope this can help you.

----
Technical Support
Monday, May 24, 2004 7:01 PM - Neil Brown

Re: Re: Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
I tried your suggestion of updating ISScript with v9 and I tried to reinstall XManager again, this time I used Beta 7, all of this was done with admin rights. I still get the same errors as before.

Cheers,
Neil
Tuesday, May 25, 2004 4:42 PM - Support

Re: Re: Re: Re: Re: XManager2 Beta Installation Problem (Error 1603)

 

You can generate log messages while installing Xmanager as following:

    xmgr2b7.exe /Verbose"c:\place for logs\package.log"

Please upload "package.log" file for further research. Also, let us know the following:

  • Detailed version information of your Windows.

Thanks for your time.

----
Technical Support

Tuesday, May 25, 2004 5:33 PM - Neil Brown

Re: Re: Re: Re: Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
I've run the setup again with verbose logging turned on. Please find attached the log file "package.log".

FYI, I'm running Windows 2000 Pro with SP4 + any MS critical updates.

Cheers,
Neil
Tuesday, May 25, 2004 10:42 PM - Support

Re: Re: Re: Re: Re: Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
According to the log message, there is a problem in starting Windows Installer.

You may try to upgrade the engine at:

http://www.microsoft.com/downloads/release.asp?releaseid=32832

Download and install InstMsiW.exe on the page above.

Hope to solve the problem.

----
Technical Support
Wednesday, May 26, 2004 5:15 PM - Neil Brown

Re: XManager2 Beta Installation Problem (Error 1603)

 
I downloaded the WinInstall file from MS, but upon trying to install it, I get the error "The Specified Service Already Exists". Thinking about it, WinInstall v2 is included in Win2k SP4, so I'll already have it on my machine. That's probably why the "specified service already exists" error is occurring. It also means that my WinInstall and InstallShield installations should be up to date now?

Out of curiosity, I also tried stopping and restarting the Windows Installer service and tried to install Beta7 of Xmanager2 again, but I still get the same errors.

Cheers,
Neil
Thursday, May 27, 2004 5:05 PM - Support

Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
We have built two new packages:

http://download.xmanager.com/files/xmgr2b7_withSP1.exe
http://download.xmanager.com/files/xmgr2b7_withoutSP1.exe

The first one was packaged with InstallShield 9.0 with service pack 1 patched.

Also, some internal GUID values have changed to overcome unknown InstallShield bugs.

Please try the new packages.
We would appreciate your feedback.

Thanks again for your time and effort.

----
Technical Support
Thursday, May 27, 2004 5:27 PM - Neil Brown

Re: Re: Re: XManager2 Beta Installation Problem (Error 1603)

 
Victory!

I tried the file xmgr2b7_wthSP1.exe and got the same errors as before, but when I tried the install with the file xmgr2b7_withoutSP1.exe it worked fine!

Thanks for you help with this!

Neil