Xmanager Forum

Xstart password authentication fails, using SSH

Last post: Sunday, May 29, 2005 10:17 PM by Charles Cloughly, 6 reply

 
Friday, March 26, 2004 1:20 AM - Bruhacs

Xstart password authentication fails, using SSH

 
Hello,

using Xmanager 1.3.9.8 on WinXP and OpenSSH_3.7.1p2 on SuSE Linux 9.0 as remote server, Xstart connection attempts fail.

Xstart and the OpenSSH server are both configured for password authentication. Zlib compression is turned on, and Xstart is set up to prefer SSH protocol version 2.x.

The error message is as follows:

Negotiating algorithms...
Initiating key exchange...Done.
Exchanging Diffie-Hellman KeyEx message...Done.
Waiting for new key message...Received.
Fingerprint: 1024 [blablabla] Verifying host key...
Algorithm negotiation has been finished...
CS Cipher: 3des-cbc, SC Cipher: 3des-cbc
CS Compress: zlib, SC Compress: zlib
CS MAC: hmac-sha1, SC MAC: hmac-sha1

Trying to login as [foo].
Trying password authentication...Failed.

Disconnected.


Any ideas as to what could be causing this?

I tried deactivating Zlib compression but that didn't help.
Friday, March 26, 2004 2:50 PM - Support

Re: Xstart password authentication fails, using SSH

 
We have tested Xmanager 1.3.9 with OpenSSH on SuSE Linux 9.0 internally and did not experience the same problem. Please try the newest version of Xmanager 1.3.9 at:

/download/download.html

If the problem still remains, please provide us the full messages on Remote Execution.

----
Technical Support
Wednesday, September 1, 2004 7:45 PM - Chris

Re: Re: Xstart password authentication fails, using SSH

 
i have the same problem with v. 1.3.9.9.

no problem with putty(ssh) to connect.
Wednesday, September 1, 2004 8:08 PM - Support

Re: Re: Re: Xstart password authentication fails, using SSH

 
Could please provide us with the version information of your ssh server? Also, the entire connection log messages would be a great help.

----
Technical Support
Friday, February 4, 2005 4:09 AM - terryg

Re: Re: Re: Re: Xstart password authentication fails, using SSH

 
Hi,

I, too, see the same password authentication problem with SUSE 9.1 Professional.

The particulars are:
XManager: v1.3.9
Execution window contents at failure:
============ start window contents ============
Connected to SIPServer:22.

Exchanging SSH version...Done.
Server: SSH-1.99-OpenSSH_3.8p1.
Client: SSH-1.5-Xssh_1.0.
SSH1 is enabled.

Authenticating remote SSH server...
Waiting for server host key...Received.
Fingerprint: 1024 ff:8a:24:35:c0:25:c7:76:9b:bd:fd:21:ad:9d:4a:44.
Verifying host key...Verified.

Negotiating cipher (encryption method)...Done.
Selected cipher: 3DES.

Trying to login as root.
Trying password authentication...
============= end window contents =============

The message box with XManager error:
"Server rejected password authentication. Please make sure that remote server supports password authentication and you typed correct password."

After clicking "OK",
============ start window contents ============
Disconnected.
============= end window contents =============

When I run cygwin's ssh from 4NT shell, the connection is made without problems:
============ start cygwin contents ============
[1] >ssh -l root -v -c 3des SIPServer
OpenSSH_3.7.1p2, SSH protocols 1.5/2.0, OpenSSL 0.9.7c 30 Sep 2003
debug1: Connecting to SIPServer [192.168.0.10] port 22.
debug1: Connection established.
debug1: identity file /home/Administrator/.ssh/identity type -1
debug1: identity file /home/Administrator/.ssh/id_rsa type -1
debug1: identity file /home/Administrator/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.8p1
debug1: match: OpenSSH_3.8p1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.7.1p2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client 3des-cbc hmac-md5 none
debug1: kex: client->server 3des-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'sipserver' is known and matches the RSA host key.
debug1: Found key in /home/Administrator/.ssh/known_hosts:4
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/Administrator/.ssh/identity
debug1: Trying private key: /home/Administrator/.ssh/id_rsa
debug1: Trying private key: /home/Administrator/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
Password:
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
Last login: Thu Feb 3 12:03:32 2005 from 192.168.0.7
Have a lot of fun...
SIPServer:~ # exit
logout
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to SIPServer closed.
debug1: Transferred: stdin 0, stdout 0, stderr 33 bytes in 74.7 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.4
debug1: Exit status 0

[1] >
============= end cygwin contents =============

I hope this helps.
Terry
Friday, February 4, 2005 5:39 PM - Support

Re: Re: Re: Re: Re: Xstart password authentication fails, using SSH

 
According to the log messages, your Linux box does not allow password authentication. Instead it requires public key and keyboard-interactive authentication for successful login.

Unfortunately Xmanager 1.3.9 supports only password authentication for SSH2 protocol. To fix this problem, try Xmanager 2.0 at:

/download/main.html

Xmanager 2.0 supports "Password", "Public Key" and "Keyboard-interactive" authentication methods.

----
Technical Support
Sunday, May 29, 2005 10:17 PM - Charles Cloughly

Re: Re: Re: Re: Re: Re: Xstart password authentication fails, using SSH

 
You can make SUSE Enterprise Server 9 (and likely other versions as well) work with Xmanager 1.3.9 by commenting out or removing the "PasswordAuthentication no" line in /etc/ssh/sshd_config on the server and restarting sshd.