Xmanager Forum

russian keyboard

Last post: Thursday, June 24, 2004 5:43 PM by Support, 10 reply

Friday, April 26, 2002 1:47 AM - Peter

russian keyboard

when I set russian keyboard in Xconfig i can't input english(latin) chars.
how i can do it.
and whit is it - "Mode switch" and how a can set this on keyboard key

P.S. Sorry for my very bad English

Monday, April 29, 2002 4:47 PM - Support

Re: russian keyboard

Please download the attached Russian keyboard map and copy it into "C:\Program Files\Xmanager1.3.9" folder.

A Mode_switch keysym has been defined for the Alt_Right key. Now, you can enter Latin characters using "Alt_R + a" combination.
Attachment Russian.xkb ()  
Sunday, May 12, 2002 3:33 AM - Peter

Re: Re: russian keyboard

Monday, June 21, 2004 8:20 PM - Zeljko

Re: Re: russian keyboard

I have russian characters on menu but a still can typed russian charasters. I downloaded that keyboard but it doesn't help. How do you meant ALT_GR + a typing?? What is the problem????

help please!!
Tuesday, June 22, 2004 2:58 PM - Support

Re: Re: Re: russian keyboard

If you are using Xmanager 1.3.9, select "Russian.xkb" in the Xconfig.

1. Copy "Russian.xkb" into "C:\Program Files\Xmanager1.3.9" directory.
2. Run Xconfig in the Xmanager folder.
3. Click Input tab.
4. In the Keyboard File list, select the Russian.xkb.
5. Save the change and restart Xmanager.

You can enter "ALT_GR + a" by using "Right-Alt-Key + a" combination.

Hope to solve the problem.

Technical Support
Wednesday, June 23, 2004 3:19 PM - Zeljko

Re: Re: Re: Re: russian keyboard

I don't have russian keyboard attached to my PC but standard. I won't to type russian characters on the menu buy using standard keyboard. I tried by pressing ALT_GR plus 'a' and the result was character '+a' on the screen but I still couldn't get typed russian characters. Please explain me how do you meen ALT_GR+a to type russian characters?? I don't understand it still.

Wednesday, June 23, 2004 5:21 PM - Support

Re: Re: Re: Re: Re: russian keyboard

We understood that you want to use English character as default
and sometimes use Russian character by using the "Alt-GR" key.

If so, we do not have the keymap file for that at this time.
So you have to make your own keymap file with Russian.xkb as a reference.

For example, please change the keysym of "A" key in the keyboard editor.

Unshifted: Cyrillic_ef -> a
Shifted: Cyrillic_EF -> A
ModeSwitch: A -> Cyrillic_ef
ShiftedModeSwitch: NoSymbol -> Cyrillic_EF

Also set Unshifted keysym of Alt_R to Mode_switch.

If what we understand is differ from what your situation is,
then please explain it with more detail.

Technical Support
Wednesday, June 23, 2004 8:27 PM - Zeljko

Re: Re: Re: Re: Re: Re: russian keyboard

yes i have standard keyboard without russian characters and i would like to type russian characters whithout attaching russian keyboard to PC.
in columns keysym for key A I have:
ShiftedMode Switch:NoSymbol

for ALT_GR key I have:
ShiftedMode Switch:NoSymbol

I pressed ALT_GR and tryed to type russian character for example on key A should be russian characters but it displays a.

what now???

Thursday, June 24, 2004 3:01 PM - Support

Re: Re: Re: Re: Re: Re: Re: russian keyboard

Please check the followings:

1. Fonts

To display russian character, you need russian fonts.
Refer to the Xmanager FAQ 1 to add a font server.


2. Keymap file

Load the Russian.xkb in Xconfig.

Optionally if you want to have a LATCH property acting like
"Caps Lock" or "Scroll Lock" keys, and the ALT_GR key does not
have it, edit the keysym of keys as below for your convenience.

Example for the key A:

Unshifted: a
Shifted: A
ModeSwitch: Cyrillic_ef
ShiftedModeSwitch: Cyrillic_EF

To know how to use Keyboard Editor, refer to
Xmanager Help > Components of Xmanager > Keyboard Editor.

3. Locale

Select 'ru' or 'ru_RU.ISO8859-5' locale on CDE login screen.
Or set this locale in the shell, for example:

$ export LANG=ru_RU.ISO8859-5

Hope this solve your problem.

Technical Support
Thursday, June 24, 2004 3:13 PM - Zeljko

Re: Re: Re: Re: Re: Re: Re: Re: russian keyboard

1. I have add directory with russian fonts and this works ok because it displays russian characters on the menu
3. This is also set on russian language.
2. This is the problem keyboard. I will tried what you wrote me.

Also I couldn't find where is xmanager help
Thursday, June 24, 2004 5:43 PM - Support

Re: russian keyboard

Thanks for your patience. Please try the followings:

1. Change the keysym of Alt_R.

- uncheck Mod1
- check Mod3

2. Open xterm or dtterm with -fn option.

- /usr/dt/bin/dtterm -fn "*-iso8859-5"

3. Try XDMCP connection with Xbrowser instead of Xstart.

4. Please give us the information below.

- C:\Program Files\Xmanager1.3.9\Xmanager.log
- C:\Program Files\Xmanager1.3.9\Xmanager.ini
- Unix vendor and version.
- What X applications you are using.
- A screenshot would be a great help.

Technical Support