Xmanager Forum

Cannot establish any listening sockets

Last post: Tuesday, January 20, 2004 1:40 AM by Soterro, 2 reply

 
Tuesday, January 20, 2004 1:02 AM - Soterro

Cannot establish any listening sockets

 
Make sure any Server isn't already running.

This is the message I get when I try to start Xmanager or anything involving it. Of course I have no server, I checked with ActivePorts and I have nothing on 600x ports range. Neither on 51x, nor 2x.
The message doesn't bother to say 'which' port wants to use, all I can see is what I listed above.
I just installed it now under Windows 2000 Advanced Server, and I didn't work so far. Any suggestion please?

S
Tuesday, January 20, 2004 1:29 AM - Support

Re: Cannot establish any listening sockets

 
By default Xmanager uses the TCP port 6000. If it is already used by some other applications, the problem might happen. When you cannot find the application that allocates port 6000, try to allocate another port as following:

1. Open the Xconfig utility in Xmanager folder.
2. Click Options tab.
3. In the Display Number box, enter 1 or 2.
4. Click OK to save the change.
5. Restart Xmanager.

Hope to solve the problem.

----
Technical Support
Tuesday, January 20, 2004 1:40 AM - Soterro

Re: Re: Cannot establish any listening sockets

 
Yes it worked on 6001. However I am VERY sure no application has or had port 6000 opened (I enumerated all the ports and their status on the machine), so the issue must be somewhere else.

Thanks a lot for the fast solution,
S