Xmanager Forum

XDMCP connection failed

Last post: Tuesday, January 13, 2004 1:10 AM by Support, 5 reply

 
Friday, January 9, 2004 12:08 PM - Jeremy Block

XDMCP connection failed

 
I have installed Xmanager and set up my linksys router to port forward TCP connections across ports 6000-6010 to the computer that is running Xmanager. However I always get the connection failed message. I tried removing my router from the equation and I had no problems connecting to the server when directly connected to my cable modem. Is there something else that needs forwarded through the router? I do not have firewall software running on the PC.

Thanks
Friday, January 9, 2004 4:13 PM - Support

Re: XDMCP connection failed

 
You should edit "C:\Program Files\Xmanager1.3.9\Xmanager.ini" as following:

[StartUp]
XdmcpConnectionAddress=123.123.xxx.xxx

The IP address should be the one of the router (a public IP address).

Hope to solve the problem.

----
Technical Support
Friday, January 9, 2004 10:28 PM - Jeremy Block

Re: Re: XDMCP connection failed

 
I have made the requested adjustments to the .ini file, but still no connection. I tried placing it in different areas of the [Startup] section, does it matter what order those appear?

I am attaching my entire ini file in case it is of use.
Saturday, January 10, 2004 2:41 AM - Support

Re: Re: Re: XDMCP connection failed

 

To my understanding, your network looks like this:

  PC (192.168.1.102) <---> (192.168.1.xxx) Router (24.210.68.57) <---> (xxx.xxx.xxx.xxx) Unix

In this configuration, you should set the XdmcpConnectionAddress in Xmanager.ini as following:

  [StartUp]
  XdmcpConnectionAddress=24.210.68.57

And the port fowarding should be like this:

  (Router:port)           (PC:port)
  24.210.68.57:6000 ---> 192.168.1.102:6000
  24.210.68.57:6001 ---> 192.168.1.102:6001
  24.210.68.57:6002 ---> 192.168.1.102:6002
  ...

Hope to solve the problem.

----
Technical Support

Monday, January 12, 2004 5:08 AM - Jeremy Block

Re: Re: Re: Re: XDMCP connection failed

 
I have made the changes, however the connection still dies everytime.

My [StartUp] section looks like the folowing

[StartUp]
XdmcpConnectionAddress=24.210.68.57
Mode=1
XdmQueryHost=stdsun.cis.ohio-state.edu
XdmIndirectHost=
UseBroadcastAddress=1
DefaultIPAddress=
XdmUdpPort=177

I have the router as the XDMCP connection address and I have the ports 6000-6010 open and forwarded to the correct local IP. I checked with a port scanner to make sure that they are open as well.

The server seems fine as I can still remove my router from the equation and connect just fine with the local PC plugged directly into the outside world. And when the router is in the network I have no problem using SSH to connect to the server either.

Do you have any other suggestions or tips?

I am attaching the log file from my failed attempt.
Tuesday, January 13, 2004 1:10 AM - Support

Re: Re: Re: Re: Re: XDMCP connection failed

 
At initial connection steps, Xmanager sends a packet to UDP port 177 (xdm or dtlogin) of the remote Unix machine. According to the Xmanager.log messages, there is no reply from the remote xdm process.

Please check your router for any configuration that preventing outbound UDP connections.

----
Technical Support