Xmanager Forum

Red Hat 7.3 Unknown Server

Last post: Saturday, December 13, 2003 1:35 AM by Support, 9 reply

 
Tuesday, December 2, 2003 1:07 AM - Luca Mondella

Red Hat 7.3 Unknown Server

 
I'm using open-ssh supplied in the Linux CDs, ssh and sshd work on Linux machine (I'm able to remote login), I'm not able to connect with Xmanager. My OS is W2k, Service pack 5.
Remote Host: my IP server
SSH server: Unknown server
Username: root
Command: /usr/X11R6/bin/xterm -ls -display $DISPLAY

Firewall on both linux and windows machines are off.
Thank you a lot
Tuesday, December 2, 2003 3:47 PM - Support

Re: Red Hat 7.3 Unknown Server

 
The information you posted is not enough to solve your problem. Could you let us know any error messages or a screenshot of your problem?

----
Technical Support
Tuesday, December 2, 2003 8:46 PM - Luca Mondella

Re: Re: Red Hat 7.3 Unknown Server

 
simply: doesn't work. Connecting to another machine in the same network, xmanager works. I have installed both of then with the same redhat 7.3 disk. One of them works, one no.

Wednesday, December 3, 2003 4:16 PM - Support

Re: Re: Re: Red Hat 7.3 Unknown Server

 

The error may occur when the ssh server doesn't send its version string to Xstart or the connection is refused by Linux firewall.

Please try to connect to the ssh server using a standard telnet program like this:

  C:\> telnet redhat7 22
  Connecting to host redhat7:22...
  Connected.

  SSH-2.0-OpenSSH_3.2.3p1

The ssh server should echo a proper version information to the terminal. If it doesn't, you should check the firewall settings or the configuration of your ssh server.

Thursday, December 4, 2003 9:11 PM - Luca Gusella

Re: Red Hat 7.3 Unknown Server

 
... using putty telnet on port 22 I have the answer
SSH-1.99-OpenSSH_3.1p1
using telnet in the windows prompt (cmd.exe)
I have no answer.

Hope this can help:
[root@localhost sysconfig]# service --status-all
anacron dead but subsys locked
apmd (pid 901) is running...
atd (pid 1154) is running...
Configured Mount Points:
------------------------

Active Mount Points:
--------------------
crond (pid 1066) is running...
cupsd is stopped
gpm (pid 1048) is running...
identd is stopped
Chain input (policy ACCEPT):
Chain forward (policy ACCEPT):
Chain output (policy ACCEPT):
No status available for this package
lpd is stopped
Configured devices:
lo eth0
Currently active devices:
lo eth0
rpc.mountd is stopped
nfsd is stopped
rpc.rquotad is stopped
rpc.statd (pid 794) is running...
nscd is stopped
ntpd is stopped
portmap (pid 766) is running...
The random data source exists
rpc.rstatd is stopped
rpc.rusersd is stopped
sendmail (pid 1029) is running...
smbd is stopped
nmbd is stopped
snmpd is stopped
env: /etc/init.d/snmptrapd: No such file or directory
sshd (pid 11180 10507 9734) is running...
syslogd (pid 741) is running...
klogd (pid 746) is running...
winbindd is stopped
Wine binary format handlers are registered.
xfs (pid 1118) is running...
xinetd (pid 10568) is running...
ypbind is stopped
[root@localhost sysconfig]#



[root@localhost ssh]# more ssh_config
# $OpenBSD: ssh_config,v 1.12 2002/01/16 17:55:33 stevesk Exp $

# This is the ssh client system-wide configuration file. See ssh(1)
# for more information. This file provides defaults for users, and
# the values can be changed in per-user configuration files or on the
# command line.

# Configuration data is parsed as follows:
# 1. command line options
# 2. user-specific file
# 3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for various options

# Host *
# ForwardAgent no
# ForwardX11 no
# RhostsAuthentication yes
# RhostsRSAAuthentication yes
# RSAAuthentication yes
# PasswordAuthentication yes
# FallBackToRsh no
# UseRsh no
# BatchMode no
# CheckHostIP yes
# StrictHostKeyChecking ask
# IdentityFile ~/.ssh/identity
# IdentityFile ~/.ssh/id_rsa
# IdentityFile ~/.ssh/id_dsa
# Port 22
# Protocol 2,1
# Cipher 3des
# Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
# EscapeChar ~
Host *
ForwardX11 yes


I stopped ipchains and iptables.
If I try to connect with xstart and telnet, xstart ask me for the password, and then open a dialog box:
Cannot connect to the remote host. Please make sure if the host is ready

Is it possible that I forget something to do?
thank you a lot
Friday, December 5, 2003 3:29 PM - Support

Re: Re: Red Hat 7.3 Unknown Server

 
Attached please find an update file for the ssh connection. Uncompress and copy the file into the "C:\Program Files\Xmanager1.3.9" folder.

If it also fails, please try our ssh client program at:

/products/xsh_detail.html

We would appreciate your feedback.

----
Technical Support
Attachment Xssh.zip (89.2 KB)  
Saturday, December 6, 2003 2:00 AM - luca

Re: Re: Re: Red Hat 7.3 Unknown Server

 
this is a redhat7.3 working
Xshell 1.0 (Build 1460 - Nov 3 2003)
Copyright (c) 2003 NetSarang Computer, Inc. All rights reserved.
Connecting to host xxx.xxx.xxx.xxx:22...
Connected.

[17:42:20] Version exchange initiated...
[17:42:20] server: SSH-1.99-OpenSSH_3.1p1
[17:42:20] client: SSH-2.0-libssh_1.2
[17:42:20] SSH2 is selected.
[17:42:20] Algorithm negotiation initiated...
[17:42:20] key exchange: diffie-hellman-group1-sha1
[17:42:20] host key: ssh-dss
[17:42:20] outgoing encryption: aes128-cbc
[17:42:20] incoming encryption: aes128-cbc
[17:42:20] outgoing mac: hmac-sha1
[17:42:20] incoming mac: hmac-sha1
[17:42:20] outgoing compression: none
[17:42:20] incoming compression: none
[17:42:20] Host authentication initiated...
[17:42:20] Hostkey fingerprint:
[17:42:20] ssh-dsa
[17:42:22] Accepted. Verifying host key...
[17:42:22] Verified.
[17:42:22] User authentication initiated...
[17:42:25] Sent user name 'root'.
[17:42:28] Sent password.
[17:42:28] Access granted.

this is the other redhat 7.3 not working:

with telnet:22

Xshell 1.0 (Build 1460 - Nov 3 2003)
Copyright (c) 2003 NetSarang Computer, Inc. All rights reserved.
Connecting to host xxx.xxx.xxx.xxx:22...
Connected.

SSH-1.99-OpenSSH_3.1p1

and with ssh
Xshell 1.0 (Build 1460 - Nov 3 2003)
Copyright (c) 2003 NetSarang Computer, Inc. All rights reserved.

Type `help' to learn how to use Xshell prompt.
Xshell>
Connecting to host xxx.xxx.xxx.xxx:22...
Connected.


the main difference between the computer is the network adapter (3c2000.o for the not working pc, 8139too.o for the working pc) and the window manager (the working pc is using gnome, the not working pc is using kde)

the ssh connection under linux between the computers is working...

what should I do to use Xstart? how I have to configure my linux machine?
(I've only to use x11 Forwarding in the sshd_config or there are other things to do?)

I tried also shutting down firewall using service iptables stop and service ipchains stop.

thanks a lot, and excuse me.

Next week I'll try reinstalling linux. If you know, are there some package that I must install (open-ssh, but there are others????)




Saturday, December 6, 2003 2:41 AM - Support

Re: Re: Re: Re: Red Hat 7.3 Unknown Server

 
In the previous reply, you uploaded ssh_config, not sshd_config. Please confirm that you have configured the sshd_config file correctly. Also, upload it for further support.

----
Technical Support
Tuesday, December 9, 2003 7:53 PM - luca

Red Hat 7.3 Unknown Server

 
excuse me:
[root@localhost ssh]# more sshd_config
# $OpenBSD: sshd_config,v 1.48 2002/02/19 02:50:59 deraadt Exp $

# This is the sshd server system-wide configuration file. See sshd(8)
# for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 3600
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 600
#PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# rhosts authentication should not be used
#RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
# KerberosAuthentication automatically enabled if keyfile exists
#KerberosAuthentication yes
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# AFSTokenPassing automatically enabled if k_hasafs() is true
#AFSTokenPassing yes

# Kerberos TGT Passing only works with the AFS kaserver
#KerberosTgtPassing no

# Set this to 'yes' to enable PAM keyboard-interactive authentication
# Warning: enabling this may bypass the setting of 'PasswordAuthentication'
#PAMAuthenticationViaKbdInt yes

#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
#UseLogin no

#MaxStartups 10
# no default banner path
#Banner /some/path
#VerifyReverseMapping no

# override default of no subsystems
Subsystem sftp /usr/libexec/openssh/sftp-server

thanks a lot
Saturday, December 13, 2003 1:35 AM - Support

Re: Red Hat 7.3 Unknown Server

 
We cannot find any problem in sshd_config. There seems following reasons for the problem:

- The network interface of Windows machine doesn't work well with the one of Linux.
- There is some problem in the ssh server.
- The TCP kernel of Linux has some problems.

So, you can try to update the network driver of Windows machine or install the ssh server again. Unfortunately we don't have a better solution to the problem.

----
Technical Support